Bug 311711 - Hover-on horizontal appmenu right there on the title bar of the window
Summary: Hover-on horizontal appmenu right there on the title bar of the window
Status: RESOLVED LATER
Alias: None
Product: kwin
Classification: Plasma
Component: appmenu (show other bugs)
Version: 4.9.90 (Beta 2)
Platform: Archlinux Other
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: Cédric Bellegarde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 21:17 UTC by Luke
Modified: 2013-02-25 09:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Mocap of horizontal appmenu (408.16 KB, image/png)
2012-12-14 21:18 UTC, Luke
Details
I meant "mockup" of menu right on the title bar all the time (420.21 KB, image/png)
2012-12-14 21:20 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2012-12-14 21:17:14 UTC
Hi, I was testing betas and I remember some screencast of appmenu long time ago when it wasn't part of the upstream yet. There was option to have _horizontal_ menu right on the window title bar but there's not such option. Vertical menus are not intuitive for me, seems more clutter, slower - this is just an opinion. But still it would be nice to have "regular" horizontal (app)menu option to choose from. Preferably with hover on option because additional click also look slower. Yet windows without menus looks awesome and save a lot of vertical space (eat that Gnome3!).

Hover-on would require some kind of hot-spot area (and maybe shortcut or mouse wheel button click).

Second idea is to have menu right there on the title bar all the time, look at attachments.

Regards.

Reproducible: Always
Comment 1 Luke 2012-12-14 21:18:16 UTC
Created attachment 75837 [details]
Mocap of horizontal appmenu
Comment 2 Luke 2012-12-14 21:20:13 UTC
Created attachment 75838 [details]
I meant "mockup" of menu right on the title bar all the time
Comment 3 Cédric Bellegarde 2013-02-25 09:40:20 UTC
Is someone wants to give a try.