Bug 311705 - Can't create Hotspot (AP master mode) connection when adding shared
Summary: Can't create Hotspot (AP master mode) connection when adding shared
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Wireless (show other bugs)
Version: 0.9
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL: https://fedoraproject.org/wiki/QA:Tes...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 18:33 UTC by Martin Holec
Modified: 2013-03-06 13:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.9.0.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holec 2012-12-14 18:33:39 UTC
Can't create Hotspot (AP master mode) connection when adding shared.

Reproducible: Always
Comment 1 Lamarque V. Souza 2012-12-14 18:47:48 UTC
You need a very new NetworkManager (0.9.6 is *not* enough) and at least wpa_supplicant 1.0 for this to work:

https://mail.gnome.org/archives/networkmanager-list/2012-November/msg00208.html

and it does not work with all wifi cards. Until there you can only use wep encrypted ad-hoc hotspots. We from KDE does not implement NetworkManager, so I am marking this bug as upstream.
Comment 2 Martin Holec 2012-12-14 18:57:07 UTC
I have:
NetworkManager-0.9.7.0-9.git20121004.fc18.x86_64
wpa_supplicant-1.0-1.fc18.x86_64

Linksys WUSB54GC adapter:
iw list:
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
	software interface modes (can always be added):
		 * AP/VLAN
		 * monitor

similar bug in Gnome: wpa_supplicant-1.0-1.fc18.x86_64
Comment 3 Lamarque V. Souza 2012-12-15 11:48:07 UTC
According to this 
http://fedoraproject.org/wiki/Features/RealHotspot no change in Plasma NM is needed to make this work. Since this is an experimental feature you should contact NetworkManager developers about any additional detail on how to enable this feature that is not documented in the two links I sent. Since the main NetworkManager developer is a RedHat employee I think you should open a bug report in RedHat's bugzilla too, which you already did by what I can see here https://bugzilla.redhat.com/show_bug.cgi?id=886236
Comment 4 Martin Holec 2013-01-16 17:42:23 UTC
According to this: https://bugzilla.redhat.com/show_bug.cgi?id=886236#c7 GUI change is needed to make this work.

You can ask Dan Williams (dcbw at redhat.com) if he can provide details on how to implement this feature in KDE Network Management.
Comment 5 Lamarque V. Souza 2013-01-23 00:59:41 UTC
(In reply to comment #4)
> According to this: https://bugzilla.redhat.com/show_bug.cgi?id=886236#c7 GUI
> change is needed to make this work.
> 
> You can ask Dan Williams (dcbw at redhat.com) if he can provide details on
> how to implement this feature in KDE Network Management.

You could do me a favour and ask that in the redhat's bug report since I do not have an account there.
Comment 6 Lamarque V. Souza 2013-03-01 17:33:14 UTC
Ok, the required changes are described in https://bugzilla.gnome.org/show_bug.cgi?id=686732. I will try to implement them next weekend.
Comment 7 Lamarque V. Souza 2013-03-01 22:57:04 UTC
Git commit b770588672e4e5b729329586d3bb3037f834da6c by Lamarque V. Souza.
Committed on 01/03/2013 at 22:56.
Pushed by lvsouza into branch 'master'.

Add support to wireless ap-mode.

M  +6    -0    dbus/introspection/nm-device-wifi.xml
M  +7    -0    wirelessdevice.cpp
M  +5    -2    wirelessdevice.h

http://commits.kde.org/libnm-qt/b770588672e4e5b729329586d3bb3037f834da6c
Comment 8 Lamarque V. Souza 2013-03-01 22:57:46 UTC
Git commit 7efdba8e8098c60c871ab7e21086fcb414f6f8f9 by Lamarque V. Souza.
Committed on 01/03/2013 at 23:14.
Pushed by lvsouza into branch 'master'.

Add support to wireless ap-mode. Still needs testing since my wifi card [1]
does not support ap-mode but the configuration is saved and seems correct. Also
requires NetworkManager >= 0.9.7.995.

[1] Intel Ultimate-N 6300 (8086:422b)

M  +10   -0    backends/NetworkManager/settings/802-11-wirelessdbus.cpp
M  +1    -0    libs/internals/interfaceconnectionhelpers.cpp
M  +1    -1    libs/internals/settings/802-11-wireless.h
M  +6    -9    libs/internals/uiutils.cpp
M  +5    -3    libs/internals/wirelessinterfaceconnectionhelpers.cpp
M  +8    -4    libs/service/wirelessnetworkinterfaceactivatableprovider.cpp
M  +6    -1    libs/ui/802-11-wireless.ui
M  +13   -6    libs/ui/802_11_wirelesswidget.cpp
M  +4    -0    libs/ui/wireless.ui
M  +24   -0    libs/ui/wirelesspreferences.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/7efdba8e8098c60c871ab7e21086fcb414f6f8f9
Comment 9 Lamarque V. Souza 2013-03-01 22:57:47 UTC
Git commit cfd99a8eaec1fa16232d8282afae62bdab5cda81 by Lamarque V. Souza.
Committed on 01/03/2013 at 23:32.
Pushed by lvsouza into branch 'nm09'.

Add support to wireless ap-mode. Still needs testing since
my wifi card [1] does not support ap-mode but the
configuration is saved and seems correct. Also requires
NetworkManager >= 0.9.7.995.

[1] Intel Ultimate-N 6300 (8086:422b)

M  +10   -0    backends/NetworkManager/settings/802-11-wirelessdbus.cpp
M  +1    -0    libs/internals/interfaceconnectionhelpers.cpp
M  +1    -1    libs/internals/settings/802-11-wireless.h
M  +4    -2    libs/internals/wirelessinterfaceconnectionhelpers.cpp
M  +8    -4    libs/service/wirelessnetworkinterfaceactivatableprovider.cpp
M  +6    -1    libs/ui/802-11-wireless.ui
M  +13   -6    libs/ui/802_11_wirelesswidget.cpp
M  +4    -0    libs/ui/wireless.ui
M  +24   -0    libs/ui/wirelesspreferences.cpp
M  +1    -1    plasma_nm_version.h
M  +3    -2    solidcontrolfuture/libs/solid/control/wirelessnetworkinterface.h
M  +8    -0    solidcontrolfuture/solid/networkmanager-0.9/wirelessnetworkinterface.cpp

http://commits.kde.org/networkmanagement/cfd99a8eaec1fa16232d8282afae62bdab5cda81
Comment 10 Martin Holec 2013-03-06 13:51:26 UTC
Thanks, I'll test it after 4.10.2 release.