Bug 311703 - krita 2.5.9 (2.6 alpha version): crash when resizing an arrow shape
Summary: krita 2.5.9 (2.6 alpha version): crash when resizing an arrow shape
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools (show other bugs)
Version: git master (please specify the git hash!)
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 17:32 UTC by Silvio Grosso
Modified: 2013-12-31 18:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio Grosso 2012-12-14 17:32:36 UTC
I have just installed Krita 2.5.9 (2.6 alpha) on:
- Windows 7 - 64 bit (premium edition);
- Windows xp professional (this one is a vbox 4.2.4 guest - virtual machine).

On *both* these Windows System I get always a crash whenever I resize an arrow shape.
Sooner or later, Krita always crashes.

BTW, I have tried all these same steps with Krita 2.5.3 - Kubuntu 2.10 (KDE desktop).
These same steps do NOT crash Krita on Linux (Kubuntu - Kde).
However, Krita behaves "wildly" on Kubuntu as well.
More precisely, as soon as the shape has been resized everything freezes.
Krita 2.5.3 is completely unresponsive for many (6-7)  seconds...

Reproducible: Always

Steps to Reproduce:
To reproduce this bug on Windows (and Linux):
1. Fire up Krita 2.5.9 (2.6 alpha);
2. File > Custom Document;
3. Add Shape > Arrow;
4. Resize manually the arrow shape until it *disappears* (that is, the shape is no longer visible);
5. Most of the time (NOT always), Krita 2.5.9 crashes here.
Actual Results:  
Krita 2.5.9 crashes while resizing an arrow shape on Windows 7 and Windows Xp professional.

On Kubuntu 12.10 (kde desktop) it behaves "wildly" (everything freezes but Krita does NOT crash).

Expected Results:  
Krita 2.5.9 should not crash while resizing an arrow shape

I have recorded a video with all my steps on Windows 7 (64 bit - Premium Edition):
https://dl.dropbox.com/u/3095134/KRITA_2.5.9_SHAPE_ARROW_CRASH.avi

On Windows 7, I have tried to "debug" this crash as well [1].
Maybe it is a duplicate of some previous crash (since the vector shapes have always been   "problematic" on Krita)

[1]
00000001    0.00000000    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000002    1.01375818    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000003    2.02737522    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000004    3.04115272    [6080] Inv(21) OK,
 0x0, retVT(0x3), ErrArg(0)    
00000005    4.05482864    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000006    5.06863070    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000007    5.82434368    [6848] rmt Register server    
00000008    5.82436514    [6848]     
00000009    5.82508278    [6848] rmt Prague loaded    
00000010    5.82509518    [6848]     
00000011    5.82634068    [6848] ldr Module params.ppl loaded    
00000012    5.82635403    [6848]     
00000013    5.82689953    [6848] ldr Module pxstub.ppl
 loaded    
00000014    5.82691193    [6848]     
00000015    5.82696486    [6848] rmt InitConnection: to server PRRemote:1776 (current 6848)    
00000016    5.82697773    [6848]     
00000017    5.82759571    [6848] Perf @@@ Memory cache settings: min=2097152, max=268435456 @@@    
00000018    5.82769918    [6848]     
00000019    5.82772493    [6848] cache set limits: low=2097152, high=268435456    
00000020    5.82774019    [6848]     
00000021    5.82902384    [6848] rmt Connection bound: remote_root=857545408    
00000022  
  5.82903910    [6848]     
00000023    5.82917595    [6848] ldr Cannot load modules for pid=0x3039 iid=0x2b    
00000024    5.82918882    [6848]     
00000025    5.82927608    [6848] ldr Cannot load modules for pid=0x3039 iid=0x9    
00000026    5.82928848    [6848]     
00000027    5.82981062    [6848] ldr Cannot load modules for pid=0x3039 iid=0xbf87    
00000028    5.82982254    [6848]     
00000029    5.83059216    [6848] ldr Cannot load modules for pid=0x3039 iid=0xfbd    
00000030    5.83060455    [6848]     
00000031  
  5.83073378    [6848] ldr Cannot load modules for pid=0x3039 iid=0xfb6    
00000032    5.83074570    [6848]     
00000033    5.88808060    [6848] rmt RPC stoping server...    
00000034    5.88810682    [6848]     
00000035    5.88822842    [6848] rmt Disconnect from server...    
00000036    5.88824224    [6848]     
00000037    5.88866854    [6848] rmt rpc_disconnect_from_server exit    
00000038    5.88868332    [6848]     
00000039    5.88870001    [6848] rmt Disconnect from server done    
00000040  
  5.88871336    [6848]     
00000041    5.88877106    [6848] rmt Prague unloading...    
00000042    5.88878393    [6848]     
00000043    5.88907194    [6848] ldr Unload modules...    
00000044    5.88908052    [6848]     
00000045    5.88909769    [6848] ldr Deinit module 00000000041C0000 - params.ppl...    
00000046    5.88911104    [6848]     
00000047    5.88937140    [6848] ldr Deinit module 00000000023C0000 - pxstub.ppl...    
00000048    5.88938332    [6848]     
00000049    5.88940191    [6848] ldr
 Clear exp 000000006662A110    
00000050    5.88940954    [6848]     
00000051    5.88942575    [6848] ldr Clear exp 000000000238BC40    
00000052    5.88943720    [6848]     
00000053    5.88945293    [6848] ldr Unloading module params.ppl...    
00000054    5.88946486    [6848]     
00000055    5.88957262    [6848] ldr Unloading module pxstub.ppl...    
00000056    5.88958120    [6848]     
00000057    6.08225632    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000058  
  6.56411028    [6316] krita(6316)/koffice (lib
 pigment) void __thiscall 
KoColorConversionSystem::insertColorSpace(const class 
KoColorSpaceFactory *): Cannot add node for  "YCBCR (8-bit 
integer/channel)" , since there are no profiles available     
00000059  
  6.56420279    [6316] krita(6316)/koffice (lib pigment) void __thiscall
 KoColorConversionSystem::insertColorSpace(const class 
KoColorSpaceFactory *): Cannot add node for  "YCBCR (16-bit 
integer/channel)" , since there are no profiles available     
00000060  
  6.56428719    [6316] krita(6316)/koffice (lib pigment) void __thiscall
 KoColorConversionSystem::insertColorSpace(const class 
KoColorSpaceFactory *): Cannot add node for  "YCBCR (32-bit 
float/channel)" , since there are no profiles available     
00000061  
  6.73023701    [6316] krita(6316)/kdecore (KLibrary) class 
KPluginFactory
 *__cdecl kde4Factory(class KLibrary *): The library "c:/program files 
(x86)/krita/lib/kde4/kritahistorydocker.dll" does not offer a 
qt_plugin_instance function.    
00000062    6.76420736    [6316] 
krita(6316)/koffice (lib kopageapp) __thiscall 
KoOdfLoadingContext::KoOdfLoadingContext(class KoOdfStylesReader 
&,class KoStore *,const class KComponentData &): could not parse
 manifest document     
00000063    6.89440250    [6316] 
krita(6316)/kdecore (services) int __cdecl mimeDataBaseVersion(void): 
Unexpected version scheme from update-mime-database -v: got 
"update-mime-database (update-mime-database) 0.71     
00000064    6.89440250    [6316] Copyright (C) 2003 Thomas Leonard.     
00000065    6.89440250    [6316] update-mime-database comes with ABSOLUTELY NO
 WARRANTY,     
00000066    6.89440250    [6316] to the extent permitted by law.     
00000067    6.89440250    [6316] You may redistribute copies of update-mime-database     
00000068    6.89440250    [6316] under the terms of the GNU General Public License.     
00000069    6.89440250    [6316] For more information about these matters, see the file named COPYING.     
00000070    6.89440250    [6316] "     
00000071    7.09394169    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000072    7.99085712    [2140] [PopCon]WiFiSearchComplete()    
00000073    8.10783672  
  [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000074    8.54683876    [5308] Debug:trying to load 'kio_trash'    
00000075    9.12150860    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000076    9.75808620    [2508] Debug:trying to load 'kio_file'    
00000077    9.81171417    [1456] Debug:trying to load 'kio_file'    
00000078    10.13530636    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000079    11.15483856    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000080    12.16859627    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000081  
  13.18229961    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000082    14.19604111    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000083    15.20977020    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000084    16.22547913    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000085    17.23926926    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000086    18.25285530    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000087    18.97769928    [2140] [PopCon]DeviceManager::RefreshMonitor, 51    
00000088    18.97780800    [2140] [PopCon]WiFiMonitor::Refresh  
  
00000089    19.25843048    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000090  
  19.94151306    [6316] krita(6316)/koffice (lib kopageapp) __thiscall 
KoOdfLoadingContext::KoOdfLoadingContext(class KoOdfStylesReader 
&,class KoStore *,const class KComponentData &): could not parse
 manifest document     
00000091    20.17654037    [6316] 
krita(6316)/kdeui (KAction) void __thiscall 
KActionCollection::setComponentData(const class KComponentData &): 
this does not work on a KActionCollection containing actions!     
00000092    20.27166748    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000093    20.28495789    [6316] libpng warning: Duplicate iCCP chunk    
00000094  
  20.28579521    [6316] libpng warning: Duplicate iCCP chunk    
00000095    20.28672791    [6316] libpng warning: Duplicate iCCP chunk    
00000096    20.28991318    [6316] libpng warning: Duplicate iCCP chunk    
00000097    20.52393913    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000098    20.52398872    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000099    20.52402687    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000100    20.52406502    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000101    20.52409935  
  [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000102    20.52413368    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000103    20.52417183    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000104    20.52420807    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000105    20.52424240    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000106    20.52427673    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000107    20.52431107    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000108  
  20.52434540    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000109    20.52437782    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000110    20.52441406    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000111    20.52444649    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000112    20.52448273    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000113    20.64089966    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000114    20.64096642    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)  
  
00000115    20.64100838    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000116    20.64104652    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000117    20.64108467    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000118    20.64111900    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000119    20.64116859    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000120    20.64121628    [6316] QCursor: Cannot create bitmap cursor; invalid bitmap(s)    
00000121    21.28606033    [6080] Inv(21) OK, 0x0, retVT(0x3),
 ErrArg(0)    
00000122    21.29495621    [6316] libpng warning: Duplicate iCCP chunk    
00000123    21.31926727    [6316] libpng warning: Duplicate iCCP chunk    
00000124    21.38989830    [6316] libpng warning: Duplicate iCCP chunk    
00000125    22.29979515    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000126    23.32258224    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000127    24.33627319    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000128    25.35204697    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000129    26.36589241    [6080]
 Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000130    27.37952805    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000131    27.98867607    [2140] [PopCon]WiFiSearchComplete()    
00000132    28.39320564    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000133    29.40692139    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000134    30.42061806    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000135    31.43430328    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000136    32.44802475    [6080] Inv(21) OK, 0x0, retVT(0x3), ErrArg(0)    
00000137  

  32.73058701    [6316] krita(6316)/koffice (lib koguiutils) void 
__thiscall KoToolBox::setActiveTool(class KoCanvasController *,int): 
KoToolBox::setActiveTool( 31891 ): no such button found
Comment 1 Halla Rempt 2013-03-10 15:29:41 UTC
I could confirm, but weirdly enough not often. We should have a minimum size for shapes, though
Comment 2 Dmitry Kazakov 2013-12-31 06:53:46 UTC
Yes, the bug is still actual
Comment 3 Dmitry Kazakov 2013-12-31 11:03:39 UTC
Git commit 97319d8ae47f36c7a31d3ad599f723711135b8c6 by Dmitry Kazakov.
Committed on 31/12/2013 at 10:10.
Pushed by dkazakov into branch 'master'.

Fix a too-small shape bug in the Default Tool

The shape resizing tool should not be able to make the shape have
zero size. So now the new size of the shape is limited by 1px of view
coordinates.

M  +36   -9    plugins/defaultTools/defaulttool/ShapeResizeStrategy.cpp

http://commits.kde.org/calligra/97319d8ae47f36c7a31d3ad599f723711135b8c6
Comment 4 Silvio Grosso 2013-12-31 12:00:49 UTC
Hi Dmitry,

Thanks for taking a look into this bug ;-)

Just tried  today myself on Windows 7 (32 bit) with the latest installer (Krita 2.8 - beta 1).

I can still reproduce the crash myself: I only need to create an arrow shape > change its size very fast (by dragging its border) on the canvas (in less than a minute Krita usually crashes)

BTW, if you move the arrow sshapes on the canvas they leave "artifacts" underneath on the canvas itself (you can sort of "paint" with them...).
In short, with a red arrow with *black* border around it as soon as you move the arrow on the canvas you always leave some black "spots" on the canvas.
When you save the canvas as jpg these black spots are saved as well :-)
Tonight, I am going to fill a new report for this bug as well. 
I have even recorded a video since on Windows 7 (OpenGL disabled) this bug is always reproducible (I am at work now) ;-)






Il Martedì 31 Dicembre 2013 12:03, Dmitry Kazakov <dimula73@gmail.com> ha scritto:
 
https://bugs.kde.org/show_bug.cgi?id=311703
>
>Dmitry Kazakov <dimula73@gmail.com> changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>             Status|CONFIRMED                   |RESOLVED
>         Resolution|---                         |FIXED
>      Latest Commit|                            |http://commits.kde.org/call
>                   |                            |igra/97319d8ae47f36c7a31d3a
>                   |                            |d599f723711135b8c6
>
>--- Comment #3 from Dmitry Kazakov <dimula73@gmail.com> ---
>Git commit 97319d8ae47f36c7a31d3ad599f723711135b8c6 by Dmitry Kazakov.
>Committed on 31/12/2013 at 10:10.
>Pushed by dkazakov into branch 'master'.
>
>Fix a too-small shape bug in the Default Tool
>
>The shape resizing tool should not be able to make the shape have
>zero size. So now the new size of the shape is limited by 1px of view
>coordinates.
>
>M  +36   -9    plugins/defaultTools/defaulttool/ShapeResizeStrategy.cpp
>
>http://commits.kde.org/calligra/97319d8ae47f36c7a31d3ad599f723711135b8c6
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
>
>
Comment 5 Halla Rempt 2013-12-31 14:00:42 UTC
I'm going to make a new build this afternoon, that should have the fix in it.
Comment 6 Dmitry Kazakov 2013-12-31 14:03:50 UTC
Git commit 78e4409fa9aff0112ca06a1bf51ec43475e0a602 by Dmitry Kazakov.
Committed on 31/12/2013 at 10:10.
Pushed by dkazakov into branch 'calligra/2.8'.

Fix a too-small shape bug in the Default Tool

The shape resizing tool should not be able to make the shape have
zero size. So now the new size of the shape is limited by 1px of view
coordinates.

M  +36   -9    plugins/defaultTools/defaulttool/ShapeResizeStrategy.cpp

http://commits.kde.org/calligra/78e4409fa9aff0112ca06a1bf51ec43475e0a602
Comment 7 Dmitry Kazakov 2013-12-31 16:56:14 UTC
Here are the links to the new Krita New Year edition :)

http://heap.kogmbh.net/downloads/krita_x64_2.7.9.3.msi
http://heap.kogmbh.net/downloads/krita_x86_2.7.9.3.msi
Comment 8 Silvio Grosso 2013-12-31 18:36:17 UTC
Thanks a lot Dmitry (and Boud)!

I have just installed the newest installer (Window 7 - 64 bit) and upgraded the Lime ppa on Ubuntu 13.10.
Now everything works fine on both 64 bit platforms (NO crash while resizing the arrow shapes) ! :-)

I think this bug might be closed now.




Il Martedì 31 Dicembre 2013 17:56, Dmitry Kazakov <dimula73@gmail.com> ha scritto:
 
https://bugs.kde.org/show_bug.cgi?id=311703
>
>--- Comment #7 from Dmitry Kazakov <dimula73@gmail.com> ---
>Here are the links to the new Krita New Year edition :)
>
>http://heap.kogmbh.net/downloads/krita_x64_2.7.9.3.msi
>http://heap.kogmbh.net/downloads/krita_x86_2.7.9.3.msi
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
>
>
Comment 9 Dmitry Kazakov 2013-12-31 18:57:06 UTC
On Linux you might also want to remove the file:

/var/tmp/kdecache-<your username>/icon-cache.kcache

:)