Bug 311701 - Add support for configuration options
Summary: Add support for configuration options
Status: RESOLVED FIXED
Alias: None
Product: phonon-backend-vlc
Classification: Unclassified
Component: general (show other bugs)
Version: 0.6
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: 0.7
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 16:51 UTC by Dainius Masiliūnas
Modified: 2013-01-09 11:40 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dainius Masiliūnas 2012-12-14 16:51:18 UTC
At the moment there is no way to configure the Phonon VLC backend, it runs on defaults only. While it generally works, there are certain options that ought to be available for configuration. The VLC player configuration options could be a good reference.

Reproducible: Always




Particularly problematic is the lack of FluidSynth configuration. VLC uses FluidSynth for its MIDI support, and due to the way FluidSynth is coded, a SoundFont file must be passed as an argument every time FluidSynth is evoked. FluidSynth itself does not keep any configuration files (that's why on Phonon GStreamer custom SoundFont support is not a problem, as they use Timidity, which does keep its own configuration files). VLC player has a field for this in its configuration options, which allows the user to define a custom SoundFont to pass to FluidSynth.
Comment 1 Christoph Feck 2012-12-20 21:59:14 UTC
Bug 311650 comment #4 seems to indicate there is a way to configure Phonon VLC options.
Comment 2 Dainius Masiliūnas 2012-12-20 22:31:34 UTC
It loads the file, but I can't see what options it takes from the file, if any. It could be something for Phonon only, not directly related to the VLC backend. Also, that file does not exist by default.
Comment 3 Harald Sitter 2013-01-09 11:39:55 UTC
Git commit dcc7671d89e456114fec50f38e141301238e2f20 by Harald Sitter.
Committed on 09/01/2013 at 12:39.
Pushed by sitter into branch 'master'.

fix config loading

vlc by default for some reason refuses to load configuration options, so
tell it not to ignore the configuration when we are using our own vlc.conf.

Thanks to Ivan Chernyavsky for pointing this out.
CCMAIL: camposer@yandex.ru

M  +1    -0    src/utils/libvlc.cpp

http://commits.kde.org/phonon-vlc/dcc7671d89e456114fec50f38e141301238e2f20
Comment 4 Harald Sitter 2013-01-09 11:40:05 UTC
Git commit 1cafd3d903da7fba8f18ccdfd79bf84018f97977 by Harald Sitter.
Committed on 09/01/2013 at 12:39.
Pushed by sitter into branch '0.6'.

fix config loading

vlc by default for some reason refuses to load configuration options, so
tell it not to ignore the configuration when we are using our own vlc.conf.

Thanks to Ivan Chernyavsky for pointing this out.
CCMAIL: camposer@yandex.ru

M  +1    -0    src/utils/libvlc.cpp

http://commits.kde.org/phonon-vlc/1cafd3d903da7fba8f18ccdfd79bf84018f97977