Bug 311685 - minimap isn't draggable with QtCurve
Summary: minimap isn't draggable with QtCurve
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Kåre Särs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-14 12:29 UTC by Martin Sandsmark
Modified: 2013-02-16 07:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Sandsmark 2012-12-14 12:29:02 UTC
when using the QtCurve widget style I'm unable to drag the minimap like a normal scrollbar.

Reproducible: Always
Comment 1 Kåre Särs 2012-12-14 12:48:18 UTC
Thanks for the report.

Hmm that was strange I have not touched the dragging code att all.... I'll check it out
Comment 2 Martin Sandsmark 2012-12-18 13:21:27 UTC
The mouse interaction is a bit weird overall, I can't really click and get it to go where I want.
Comment 3 Kåre Särs 2012-12-18 14:17:11 UTC
The problem is that the slider in the QScrollbar is not the same size as the slider in the minimap. Especially when you have a smal document it is visible, the QScrollbar slider can be manytimes biger than the minimap slider.

In QtCurve it seems that the slider hit-area-width is constant no mater how wide the scrollbar is -> you can grab the slider if you do it on the left side of the slider.

I need to add a cursor position translation, but the QtCurve problem is a bit tricky as the next style might be right aligned...

/Kåre
Comment 4 Kåre Särs 2013-02-16 07:03:16 UTC
Git commit d2bd65cde6faaf11513fb7ac932ba2ceae0a054e by Kåre Särs.
Committed on 16/02/2013 at 07:30.
Pushed by sars into branch 'KDE/4.10'.

Fix minimap dragging with QtCurve.
Translate minimap-sliders y-coordinates to standard coordinates on small files.
FIXED-IN 4.10.1

M  +61   -3    part/view/kateviewhelpers.cpp
M  +6    -0    part/view/kateviewhelpers.h

http://commits.kde.org/kate/d2bd65cde6faaf11513fb7ac932ba2ceae0a054e
Comment 5 Kåre Särs 2013-02-16 07:04:04 UTC
Git commit 3639663cda8fbad903f23a52ceff1ff603e7f89f by Kåre Särs.
Committed on 16/02/2013 at 07:30.
Pushed by sars into branch 'master'.

Fix minimap dragging with QtCurve.
Translate minimap-sliders y-coordinates to standard coordinates on small files.
FIXED-IN 4.10.1

M  +61   -3    part/view/kateviewhelpers.cpp
M  +6    -0    part/view/kateviewhelpers.h

http://commits.kde.org/kate/3639663cda8fbad903f23a52ceff1ff603e7f89f