Bug 311440 - Crash when rotating images
Summary: Crash when rotating images
Status: RESOLVED DUPLICATE of bug 282235
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 22:08 UTC by Kerry N
Modified: 2012-12-10 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kerry N 2012-12-09 22:08:27 UTC
Application: gwenview (2.9.2)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.6.3-1.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:
Press rotate arrow, application crashed. Doesn't happen with every rotate, but if you rotate a number of images, eventually the application will crash.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f7d2bcb5880 (LWP 10756))]

Thread 4 (Thread 0x7f7d1ffdd700 (LWP 10760)):
#0  __pthread_mutex_lock (mutex=0x7f7d18000a60) at pthread_mutex_lock.c:134
#1  0x00000037bba83981 in g_mutex_lock (mutex=mutex@entry=0x7f7d180009a0) at gthread-posix.c:208
#2  0x00000037bba47339 in g_main_context_prepare (context=context@entry=0x7f7d180009a0, priority=priority@entry=0x7f7d1ffdcb78) at gmain.c:2838
#3  0x00000037bba47a1b in g_main_context_iterate (context=context@entry=0x7f7d180009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3126
#4  0x00000037bba47c14 in g_main_context_iteration (context=0x7f7d180009a0, may_block=1) at gmain.c:3207
#5  0x00000037c7ba5ff6 in QEventDispatcherGlib::processEvents (this=0x7f7d180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00000037c7b76cbf in QEventLoop::processEvents (this=this@entry=0x7f7d1ffdccd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000037c7b76f48 in QEventLoop::exec (this=0x7f7d1ffdccd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00000037c7a787e0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00000037c7b574df in QInotifyFileSystemWatcherEngine::run (this=0x178a170) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00000037c7a7b7bc in QThreadPrivate::start (arg=0x178a170) at thread/qthread_unix.cpp:338
#11 0x00000037b8e07d14 in start_thread (arg=0x7f7d1ffdd700) at pthread_create.c:309
#12 0x00000037b82f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f7d1d77f700 (LWP 20111)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00000037c7a7bc77 in wait (time=30000, this=0x1b6cbd0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1b9e688, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00000037c7a6f4ff in QThreadPoolThread::run (this=0x1bf92c0) at concurrent/qthreadpool.cpp:141
#4  0x00000037c7a7b7bc in QThreadPrivate::start (arg=0x1bf92c0) at thread/qthread_unix.cpp:338
#5  0x00000037b8e07d14 in start_thread (arg=0x7f7d1d77f700) at pthread_create.c:309
#6  0x00000037b82f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f7d1cf7e700 (LWP 20113)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00000037c7a7bd1b in wait (time=18446744073709551615, this=0x1ba3be0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1ba38c8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000037438bf53a in Gwenview::ThumbnailThread::run (this=0x1ba3868) at /usr/src/debug/gwenview-4.9.3/lib/thumbnailloadjob.cpp:200
#4  0x00000037c7a7b7bc in QThreadPrivate::start (arg=0x1ba3868) at thread/qthread_unix.cpp:338
#5  0x00000037b8e07d14 in start_thread (arg=0x7f7d1cf7e700) at pthread_create.c:309
#6  0x00000037b82f168d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f7d2bcb5880 (LWP 10756)):
[KCrash Handler]
#6  0x00000037424c6eba in qt_scale_image_32bit<Blend_RGB32_on_RGB32_NoAlpha> (destPixels=0x2e34c30 "", dbpl=6912, srcPixels=0x7f7d055d2010 <Address 0x7f7d055d2010 out of bounds>, sbpl=13824, targetRect=..., srcRect=..., clip=..., blender=blender@entry=...) at painting/qblendfunctions_p.h:244
#7  0x00000037424c21a3 in qt_scale_image_rgb32_on_rgb32 (destPixels=<optimized out>, dbpl=<optimized out>, srcPixels=<optimized out>, sbpl=<optimized out>, targetRect=..., sourceRect=..., clip=..., const_alpha=256) at painting/qblendfunctions.cpp:630
#8  0x000000374258df15 in QRasterPaintEngine::drawImage (this=this@entry=0x1c0b930, r=..., img=..., sr=...) at painting/qpaintengine_raster.cpp:2380
#9  0x000000374258be05 in QRasterPaintEngine::drawImage (this=0x1c0b930, p=..., img=...) at painting/qpaintengine_raster.cpp:2174
#10 0x0000003742517f5d in QPainter::drawImage (this=0x7fff583b6b90, p=..., image=...) at painting/qpainter.cpp:5636
#11 0x0000003742486db5 in drawImage (image=..., p=..., this=0x7fff583b6b90) at ../../src/gui/painting/qpainter.h:928
#12 QImage::transformed (this=this@entry=0x1b3a420, matrix=..., mode=mode@entry=Qt::FastTransformation) at image/qimage.cpp:6672
#13 0x00000037424878ac in QImage::scaled (this=0x1b3a420, s=..., aspectMode=Qt::KeepAspectRatio, mode=Qt::FastTransformation) at image/qimage.cpp:4469
#14 0x0000003743875837 in Gwenview::Document::prepareDownSampledImageForZoom (this=0x241a620, zoom=<optimized out>) at /usr/src/debug/gwenview-4.9.3/lib/document/document.cpp:384
#15 0x00000000004507d1 in doPreload (this=0x166e900) at /usr/src/debug/gwenview-4.9.3/app/preloader.cpp:109
#16 Gwenview::Preloader::doPreload (this=0x166e900) at /usr/src/debug/gwenview-4.9.3/app/preloader.cpp:89
#17 0x0000000000450965 in Gwenview::Preloader::preload (this=0x166e900, url=..., size=...) at /usr/src/debug/gwenview-4.9.3/app/preloader.cpp:85
#18 0x000000000044b18c in Gwenview::MainWindow::preloadNextUrl (this=0x1645d30) at /usr/src/debug/gwenview-4.9.3/app/mainwindow.cpp:1576
#19 0x00000037c7b8e71f in QMetaObject::activate (sender=0x1b6f2e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#20 0x00000037c7b94fbf in QSingleShotTimer::timerEvent (this=0x1b6f2e0) at kernel/qtimer.cpp:317
#21 0x00000037c7b8c69c in QObject::event (this=0x1b6f2e0, e=<optimized out>) at kernel/qobject.cpp:1157
#22 0x00000037423ca4ac in QApplicationPrivate::notify_helper (this=this@entry=0x14df180, receiver=receiver@entry=0x1b6f2e0, e=e@entry=0x7fff583b7860) at kernel/qapplication.cpp:4557
#23 0x00000037423ce92a in QApplication::notify (this=0x7fff583b7bf0, receiver=0x1b6f2e0, e=0x7fff583b7860) at kernel/qapplication.cpp:4418
#24 0x00000037442468a6 in KApplication::notify (this=0x7fff583b7bf0, receiver=0x1b6f2e0, event=0x7fff583b7860) at /usr/src/debug/kdelibs-4.9.3/kdeui/kernel/kapplication.cpp:311
#25 0x00000037c7b77f6e in QCoreApplication::notifyInternal (this=0x7fff583b7bf0, receiver=0x1b6f2e0, event=0x7fff583b7860) at kernel/qcoreapplication.cpp:915
#26 0x00000037c7ba8842 in sendEvent (event=0x7fff583b7860, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#27 QTimerInfoList::activateTimers (this=0x14df7a0) at kernel/qeventdispatcher_unix.cpp:611
#28 0x00000037c7ba5964 in timerSourceDispatch (source=0x14df740) at kernel/qeventdispatcher_glib.cpp:186
#29 timerSourceDispatch (source=source@entry=0x14df740) at kernel/qeventdispatcher_glib.cpp:180
#30 0x00000037bba47825 in g_main_dispatch (context=0x14da740) at gmain.c:2539
#31 g_main_context_dispatch (context=context@entry=0x14da740) at gmain.c:3075
#32 0x00000037bba47b58 in g_main_context_iterate (context=context@entry=0x14da740, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#33 0x00000037bba47c14 in g_main_context_iteration (context=0x14da740, may_block=1) at gmain.c:3207
#34 0x00000037c7ba5fd6 in QEventDispatcherGlib::processEvents (this=0x14d81e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x000000374246a48e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#36 0x00000037c7b76cbf in QEventLoop::processEvents (this=this@entry=0x7fff583b7ad0, flags=...) at kernel/qeventloop.cpp:149
#37 0x00000037c7b76f48 in QEventLoop::exec (this=0x7fff583b7ad0, flags=...) at kernel/qeventloop.cpp:204
#38 0x00000037c7b7bd38 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00000000004273a2 in main (argc=2, argv=0x7fff583b7d58) at /usr/src/debug/gwenview-4.9.3/app/main.cpp:142

This bug may be a duplicate of or related to bug 282235.

Possible duplicates by query: bug 287628, bug 282235.

Reported using DrKonqi
Comment 1 Benni Hill 2012-12-10 22:00:38 UTC

*** This bug has been marked as a duplicate of bug 282235 ***