Bug 311409 - When dragging text from the 'Rename Inline' box and dropping it on a Places Panel entry, sometimes the drag does not stop
Summary: When dragging text from the 'Rename Inline' box and dropping it on a Places P...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: general (show other bugs)
Version: 2.1
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 13:35 UTC by Frank Reininghaus
Modified: 2017-09-04 01:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Reininghaus 2012-12-09 13:35:24 UTC
Happens with KDE 4.9.4 and later (in KDE 4.9.3 and earlier, Dolphin crashes when trying to reproduce this because of bug 309421).

Reproducible: Sometimes

Steps to Reproduce:
1. Rename an item inline (i.e., by pressing F2).
2. Select some text.
3. Drag the text, drop it on a Places Panel Entry, and click "Cancel" in the "Filename for dropped contents" dialog.

Actual Results:  
Sometimes, the drag does not stop (the mouse pointer is still in the 'dragging' state), and Dolphin crashes when closing with the backtrace below.


Thread 1 (Thread 0x7f4b879c5780 (LWP 6983)):
[KCrash Handler]
#6  0x00007f4b96658a90 in QRect::height (this=0x44) at ../../include/QtCore/../../src/corelib/tools/qrect.h:307
#7  0x00007f4b948d53db in QWidget::rect (this=0x1924320) at ../../include/QtGui/../../src/gui/kernel/qwidget.h:1018
#8  0x00007f4b94e8cf34 in QTextEdit::mouseMoveEvent (this=0x210bd40, e=0x7fff8ea89b90) at widgets/qtextedit.cpp:1563
#9  0x00007f4b94e8ba9f in QTextEdit::timerEvent (this=0x210bd40, e=0x7fff8ea8aab0) at widgets/qtextedit.cpp:1090
#10 0x00007f4b95d37a88 in QObject::event (this=0x210bd40, e=0x7fff8ea8aab0) at kernel/qobject.cpp:1157
#11 0x00007f4b9493839d in QWidget::event (this=0x210bd40, event=0x7fff8ea8aab0) at kernel/qwidget.cpp:8830
#12 0x00007f4b94dfd90f in QFrame::event (this=0x210bd40, e=0x7fff8ea8aab0) at widgets/qframe.cpp:557
#13 0x00007f4b94ea8328 in QAbstractScrollArea::event (this=0x210bd40, e=0x7fff8ea8aab0) at widgets/qabstractscrollarea.cpp:996
#14 0x00007f4b94e8b781 in QTextEdit::event (this=0x210bd40, e=0x7fff8ea8aab0) at widgets/qtextedit.cpp:1070
#15 0x00007f4b96c71ef7 in KTextEdit::event (this=0x210bd40, ev=0x7fff8ea8aab0) at /home/kde-4.9/kde/src/KDE/kdelibs/kdeui/widgets/ktextedit.cpp:327
#16 0x00007f4b98b7b747 in KItemListRoleEditor::event (this=0x210bd40, event=0x7fff8ea8aab0) at /home/kde-4.9/kde/src/KDE/kde-baseapps/dolphin/src/kitemviews/private/kitemlistroleeditor.cpp:84
#17 0x00007f4b948d2518 in QApplicationPrivate::notify_helper (this=0x1925d30, receiver=0x210bd40, e=0x7fff8ea8aab0) at kernel/qapplication.cpp:4551
#18 0x00007f4b948d221a in QApplication::notify (this=0x7fff8ea8ae50, receiver=0x210bd40, e=0x7fff8ea8aab0) at kernel/qapplication.cpp:4516
#19 0x00007f4b96b4f6aa in KApplication::notify (this=0x7fff8ea8ae50, receiver=0x210bd40, event=0x7fff8ea8aab0) at /home/kde-4.9/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#20 0x00007f4b95d1eb96 in QCoreApplication::notifyInternal (this=0x7fff8ea8ae50, receiver=0x210bd40, event=0x7fff8ea8aab0) at kernel/qcoreapplication.cpp:915
#21 0x00007f4b95d22691 in QCoreApplication::sendEvent (receiver=0x210bd40, event=0x7fff8ea8aab0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 0x00007f4b95d5e02f in QTimerInfoList::activateTimers (this=0x192a360) at kernel/qeventdispatcher_unix.cpp:611
#23 0x00007f4b95d5a372 in timerSourceDispatch (source=0x192a300) at kernel/qeventdispatcher_glib.cpp:186
#24 0x00007f4b8ee3d3b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f4b8ee3d6e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f4b8ee3d7a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f4b95d5ae27 in QEventDispatcherGlib::processEvents (this=0x18fe5e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f4b949a9b7c in QGuiEventDispatcherGlib::processEvents (this=0x18fe5e0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f4b95d1c0d0 in QEventLoop::processEvents (this=0x7fff8ea8adc0, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f4b95d1c25a in QEventLoop::exec (this=0x7fff8ea8adc0, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f4b95d1f216 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#32 0x00007f4b948cf73e in QApplication::exec () at kernel/qapplication.cpp:3812
#33 0x00007f4b98e6589c in kdemain (argc=1, argv=0x7fff8ea8b3b8) at /home/kde-4.9/kde/src/KDE/kde-baseapps/dolphin/src/main.cpp:89
#34 0x0000000000400a0e in main (argc=1, argv=0x7fff8ea8b3b8) at /home/kde-4.9/kde/build/KDE/kde-baseapps/dolphin/src/dolphin_dummy.cpp:3
Comment 1 Emmanuel Pescosta 2012-12-14 15:16:26 UTC
I can reproduce this bug in Dolphin 2.1.85 (Also the crash) - Arch Linux

But I can't reproduce it with Dolphin Git Master (Also kdelibs, nepomuk-core, soprano and kde-runtime from master) compiled with llvm/clang.
Comment 2 Nate Graham 2017-09-04 01:44:41 UTC
Also can't reproduce. Let's consider it fixed.