Bug 311394 - import fails silently
Summary: import fails silently
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Import-Gphoto2 (show other bugs)
Version: 2.9.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 09:27 UTC by kavol
Modified: 2021-12-29 14:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kavol 2012-12-09 09:27:45 UTC
this is a spinoff of the bug #311393, so please see that bug

what I'm trying to solve here is not the support for that particular camera, but the fact that choosing the menu entry does nothing, it just fails silently without (visibly) reporting any error

Reproducible: Always

Steps to Reproduce:
1. connect some unsupported camera
2. choose Importovat [Import] => Fotoaparáty [Cameras] => Canon Inc. Canon Digital Camera (automaticky detekované) [... (autodetected)]
3. wait until eternity
Actual Results:  
nothing happens

Expected Results:  
as soon as the program finds out about the error (it writes "Failed to get information for the listed camera" to the console output ...), a dialogue window appears, telling something like:

Importing failed
Reson: Failed to get information for the listed camera 
Failed to detect camera with GPhoto2 from Solid information


... and possibly including some hint what to do next (e.g. configuring the camera manually, or reporting the camera model upstream - Solid or Gphoto? - to get it known, or whatever may be best reaction to this particular error)
Comment 1 caulier.gilles 2012-12-17 05:05:07 UTC

*** This bug has been marked as a duplicate of bug 311393 ***
Comment 2 caulier.gilles 2021-12-29 14:19:33 UTC
Fixed with #311393