Bug 311392 - kolf crash and no start
Summary: kolf crash and no start
Status: RESOLVED DUPLICATE of bug 258998
Alias: None
Product: kolf
Classification: Unclassified
Component: general (show other bugs)
Version: 1.10
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stefan Majewsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-09 09:11 UTC by josan_pansa
Modified: 2012-12-10 10:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josan_pansa 2012-12-09 09:11:24 UTC
Application: kolf (1.10)
KDE Platform Version: 4.9.90
Qt Version: 4.8.4
Operating System: Linux 3.0.6-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Kolf fails to start the program .i have tried to start with alt f2,console and shortcut and always fails and does not start

The crash can be reproduced every time.

-- Backtrace:
Application: Kolf (kolf), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00000032eb038155 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:63
#7  0x00000032eb039625 in __GI_abort () at abort.c:90
#8  0x00000032eb03115e in __assert_fail_base (fmt=<optimized out>, assertion=0x3f9a8bc0d8 "area > b2_floatValues<sizeof(qreal)>::epsilon()", file=0x3f9a8bc060 "/var/tmp/portage/kde-base/kolf-4.9.90/work/kolf-4.9.90/external/Box2D/Collision/Shapes/b2PolygonShape.cpp", line=<optimized out>, function=<optimized out>) at assert.c:92
#9  0x00000032eb031202 in __GI___assert_fail (assertion=0x3f9a8bc0d8 "area > b2_floatValues<sizeof(qreal)>::epsilon()", file=0x3f9a8bc060 "/var/tmp/portage/kde-base/kolf-4.9.90/work/kolf-4.9.90/external/Box2D/Collision/Shapes/b2PolygonShape.cpp", line=115, function=0x3f9a8bc320 <ComputeCentroid(b2Vec2 const*, int)::__PRETTY_FUNCTION__> "b2Vec2 ComputeCentroid(const b2Vec2*, int32)") at assert.c:101
#10 0x0000003f9a8a461c in ComputeCentroid(b2Vec2 const*, int) () from /usr/lib64/libkolfprivate.so.4
#11 0x0000003f9a8a4872 in b2PolygonShape::Set(b2Vec2 const*, int) () from /usr/lib64/libkolfprivate.so.4
#12 0x0000003f9a8740c6 in Kolf::EllipseShape::createShape() () from /usr/lib64/libkolfprivate.so.4
#13 0x0000003f9a873b99 in Kolf::Shape::update() () from /usr/lib64/libkolfprivate.so.4
#14 0x0000003f9a873d52 in Kolf::EllipseShape::setRect(QRectF const&) () from /usr/lib64/libkolfprivate.so.4
#15 0x0000003f9a8589e2 in EllipticalCanvasItem::setSize(QSizeF const&) () from /usr/lib64/libkolfprivate.so.4
#16 0x0000003f9a865841 in Kolf::BlackHole::BlackHole(QGraphicsItem*, b2World*) () from /usr/lib64/libkolfprivate.so.4
#17 0x0000003f9a851a6c in QGraphicsItem* Kolf::ItemFactory::create<Kolf::BlackHole>(QGraphicsItem*, b2World*) () from /usr/lib64/libkolfprivate.so.4
#18 0x0000003f9a85ee03 in Kolf::ItemFactory::createInstance(QString const&, QGraphicsItem*, b2World*) const () from /usr/lib64/libkolfprivate.so.4
#19 0x0000003f9a83d153 in KolfGame::openFile() () from /usr/lib64/libkolfprivate.so.4
#20 0x0000003f9a83bc13 in KolfGame::startNextHole() () from /usr/lib64/libkolfprivate.so.4
#21 0x0000003f9a836dcd in KolfGame::startFirstHole(int) () from /usr/lib64/libkolfprivate.so.4
#22 0x0000003f9a84e8c4 in KolfWindow::createSpacer() () from /usr/lib64/libkolfprivate.so.4
#23 0x0000003f9a8506a9 in KolfWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib64/libkolfprivate.so.4
#24 0x00000032ea1d7dc2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00000032ea1e146f in QSingleShotTimer::timeout() () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00000032ea1e12cb in QSingleShotTimer::timerEvent(QTimerEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00000032ea1d28bc in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00000032f120fa5a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00000032f120d096 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#30 0x0000003f98c91e0b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00000032ea1b99ca in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#32 0x00000032ea1bd4c5 in QCoreApplication::sendEvent(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00000032ea1f90db in QTimerInfoList::activateTimers() () from /usr/lib64/qt4/libQtCore.so.4
#34 0x00000032ea1f53fa in timerSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00000032ed04acd2 in g_main_dispatch (context=0x11baf30) at gmain.c:2539
#36 g_main_context_dispatch (context=0x11baf30) at gmain.c:3075
#37 0x00000032ed04b015 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x11baf30, self=<optimized out>) at gmain.c:3146
#38 g_main_context_iterate (context=0x11baf30, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3083
#39 0x00000032ed04b0cc in g_main_context_iteration (context=0x11baf30, may_block=1) at gmain.c:3207
#40 0x00000032ea1f5e87 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#41 0x00000032f12e7030 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#42 0x00000032ea1b6f04 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#43 0x00000032ea1b708e in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#44 0x00000032ea1ba04a in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#45 0x00000032f120cc80 in QApplication::exec() () from /usr/lib64/qt4/libQtGui.so.4
#46 0x0000000000402e2a in main ()

Possible duplicates by query: bug 303176, bug 301141, bug 289949.

Reported using DrKonqi
Comment 1 josan_pansa 2012-12-10 07:22:47 UTC
Hello,i have recompiled Kolf without the use debug and it works like a charm.it seems that this resolved to compile without the use debug. Thank you for everything
Comment 2 josan_pansa 2012-12-10 10:10:41 UTC

*** This bug has been marked as a duplicate of bug 258998 ***