Bug 311352 - switch presets of stylus ends via shortcut
Summary: switch presets of stylus ends via shortcut
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 16:01 UTC by Tom Hall
Modified: 2012-12-28 16:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Hall 2012-12-08 16:01:38 UTC
Currently I use the e key in krita to turn eraser mode on and off. Sometimes this isn't convenient, because for example I want to sketch with a pressure sensitive brush, but erase with an opaque eraser (whereas eraser mode will give me a pressure sensitive eraser).

I can do this using the different ends of the stylus. However, turning the stylus over isn't nearly as convenient as a key press.
A solution to get the best of both worlds could be as simple as allowing me to 'pretend' that I've turned the stylus over with a keypress, i.e. a shortcut that swaps the pen-end and eraser-end presets.

Note about having shortcuts to select presets (copied from irc):
<Thra11> deevad, sounds good, although I was thinking it would be nice to switch to an eraser and switch back again by pressing the same key. Shortcuts for favourite presets would mean a) I have to remember which presets my brush and eraser are and b) I'd have to press 2 different keys (I like to use my tablet buttons and there aren't many of them.). One other major (for me) issue is that if you turn the stylus over to erase, then back again, all the modifications to the preset (e.g. size) are remembered, whereas reselecting presets resets to the defined preset size.
<Thra11> (I'm not saying favourite preset shortcuts wouldn't be handy, just that I don't see them solving this specific problem)

Reproducible: Always

Steps to Reproduce:
1. 

Actual Results:  
No shortcut exists

Expected Results:  
A nice handy shortcut
Comment 1 David REVOY 2012-12-12 09:36:58 UTC
I would also like as T Hall describe above to have a "switch key" on keyboard to switch 2 presets :

Here a scenario :
1) Open Krita, a canvas, select the freehand painting tool ( a default preset load ) select a brush "preset A" and paint 
2) press the switch key on keyboard ( a default preset load )
3) choose a "preset B" , paint
4) press the switch key on keyboard ( "preset A" loaded back ) ,paint
5) press the switch key on keyboard ( "preset B" loaded back ) ,paint
6) press the switch key on keyboard ( "preset A" loaded back ) ,paint
7) etc...  

Can be good for many stage of drawing painting who require working with 2 presets  :
- Pencil preset soft + opaque eraser
- Paint opaque + blending / smudging edges
- filling zone with experimental brush + small brush rounded for filling little details
- Speedpainting eroded brush + big airbrush to correct values
Comment 2 Halla Rempt 2012-12-20 12:04:06 UTC
Git commit ebd798ea6c52ecbd54329f501541be1ba45f7864 by Boudewijn Rempt.
Committed on 20/12/2012 at 11:32.
Pushed by rempt into branch 'master'.

Make it possible to move through favourite presets with the keyboard

Default shortcuts: left and right.

(Because the number shortcuts are taken by the blender-type canvas
manipulation, zoom, rotate etc.)

M  +53   -0    krita/ui/kis_paintop_box.cc
M  +2    -0    krita/ui/kis_paintop_box.h
M  +3    -3    krita/ui/kis_popup_palette.cpp
M  +2    -3    krita/ui/ko_favorite_resource_manager.cpp
M  +1    -1    krita/ui/ko_favorite_resource_manager.h

http://commits.kde.org/calligra/ebd798ea6c52ecbd54329f501541be1ba45f7864
Comment 3 Halla Rempt 2012-12-20 12:04:06 UTC
Git commit f05ea0f9fb1adb4384a0277f5e36667c12da2ceb by Boudewijn Rempt.
Committed on 20/12/2012 at 13:02.
Pushed by rempt into branch 'master'.

Add shortcut to switch between the current and the previous preset

The default shortcut is / (slash).

M  +17   -3    krita/ui/kis_paintop_box.cc
M  +2    -3    krita/ui/kis_paintop_box.h

http://commits.kde.org/calligra/f05ea0f9fb1adb4384a0277f5e36667c12da2ceb
Comment 4 Jean-Nicolas Artaud 2012-12-28 16:55:44 UTC
Git commit 5b61fc731519a810f52e3795e2d3e3b0eb548655 by Jean-Nicolas Artaud, on behalf of Boudewijn Rempt.
Committed on 20/12/2012 at 13:02.
Pushed by artaud into branch 'flake-configwidgets-boemann'.

Add shortcut to switch between the current and the previous preset

The default shortcut is / (slash).

M  +17   -3    krita/ui/kis_paintop_box.cc
M  +2    -3    krita/ui/kis_paintop_box.h

http://commits.kde.org/calligra/5b61fc731519a810f52e3795e2d3e3b0eb548655
Comment 5 Jean-Nicolas Artaud 2012-12-28 16:55:50 UTC
Git commit a70ce44d783bdb16d7a08d8130ea652c171dc3d7 by Jean-Nicolas Artaud, on behalf of Boudewijn Rempt.
Committed on 20/12/2012 at 11:32.
Pushed by artaud into branch 'flake-configwidgets-boemann'.

Make it possible to move through favourite presets with the keyboard

Default shortcuts: left and right.

(Because the number shortcuts are taken by the blender-type canvas
manipulation, zoom, rotate etc.)

M  +53   -0    krita/ui/kis_paintop_box.cc
M  +2    -0    krita/ui/kis_paintop_box.h
M  +3    -3    krita/ui/kis_popup_palette.cpp
M  +2    -3    krita/ui/ko_favorite_resource_manager.cpp
M  +1    -1    krita/ui/ko_favorite_resource_manager.h

http://commits.kde.org/calligra/a70ce44d783bdb16d7a08d8130ea652c171dc3d7