Bug 311296 - Floating close window buttons appear when rotating the desktop cube
Summary: Floating close window buttons appear when rotating the desktop cube
Status: RESOLVED DUPLICATE of bug 259640
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-window-management (show other bugs)
Version: 4.9.4
Platform: openSUSE RPMs Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: http://dl.dropbox.com/u/49436584/bug_...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-07 10:45 UTC by David de Cos
Modified: 2012-12-07 13:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David de Cos 2012-12-07 10:45:38 UTC
After a few hours working on KDE, I almost always end up with one or more floating close window buttons that show every time I rotate the desktop cube. I don't exactly know how or when they begin to appear, but I'm pretty sure it has to do with the Present Windows effect.

After a great deal of trial and error, I figured out a way to reproduce the bug. However, it is NOT the only way to get this bug.

Reproducible: Always

Steps to Reproduce:
(See http://dl.dropbox.com/u/49436584/bug_cube_rotation.avi)
1. Enable the option to show the close window buttons in the Present Windows settings.
2. Have exactly two windows open.
3. Use the Present Windows effect (in the video, I go to the top left corner of the screen).
4. Close one of the windows by clicking on the button that appears on its top right corner.
5. Click on the remaining window.
6. Rotate the cube.
Actual Results:  
The close window button of the window that you closed shows up. The only way I've found to remove it is by restarting the Desktop Effects.

Expected Results:  
No buttons floating.

This is not the only way to get this bug, because I never close windows in the Present Windows effect, however I almost always end up with at least one of those buttons floating after some hours of work. I use the two effects involved (Present Windows and Cube Rotation) very heavily as I like to distribute my windows in different virtual desktops.

I've reproduced this bug in two OpenSuSE-s and one Kubuntu. It's not exclusive to the last KDE version, as I remember having it for a long time.
Comment 1 Thomas Lübking 2012-12-07 13:21:33 UTC
please please provide the output of
qdbus org.kde.kwin /KWin supportInformation

right after you spot that the next time.

> because I never close windows in the Present Windows effect
*afterwards* ;-) you can btw. disable the feature in "kcmshell4 kwincompositing" / "all effects" / "present windows" settings

*** This bug has been marked as a duplicate of bug 259640 ***