Bug 311285 - network manager failed!!!
Summary: network manager failed!!!
Status: RESOLVED DUPLICATE of bug 296740
Alias: None
Product: Network Management
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-07 03:39 UTC by Aaron Luna
Modified: 2012-12-07 16:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Luna 2012-12-07 03:39:15 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I just started up my OS, and Network Manager didn't work, I installed 12.1 but I update to 12.2 version on repositories and began problem

The crash can be reproduced some of the time.

-- Backtrace:
Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fae7cdb3760 (LWP 6676))]

Thread 2 (Thread 0x7fae5e8fe700 (LWP 6779)):
#0  0x00007fae7a41fff3 in poll () from /lib64/libc.so.6
#1  0x00007fae77210ae8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fae77210fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fae7ba31586 in QEventDispatcherGlib::processEvents (this=0x7fae580008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fae7ba05a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fae7ba05c2f in QEventLoop::exec (this=0x7fae5e8fddf0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fae7b91d5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fae7b9e8aff in QInotifyFileSystemWatcherEngine::run (this=0xb55f90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fae7b920025 in QThreadPrivate::start (arg=0xb55f90) at thread/qthread_unix.cpp:331
#9  0x00007fae7b68ff05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fae7a42910d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fae7cdb3760 (LWP 6676)):
[KCrash Handler]
#6  0x00007fae46e92cbf in qobject_cast<Solid::Control::Ifaces::NetworkInterfaceNm09*> (object=0x1965898) at /usr/src/debug/networkmanagement-0.9.0/solidcontrolfuture/libs/solid/control/ifaces/networkinterface.h:166
#7  Solid::Control::NetworkInterfaceNm09::connectionState (this=<optimized out>) at /usr/src/debug/networkmanagement-0.9.0/solidcontrolfuture/libs/solid/control/networkinterface.cpp:125
#8  0x00007fae479b8be1 in NetworkManagerApplet::interfaceConnectionStateChanged (this=0x1259090) at /usr/src/debug/networkmanagement-0.9.0/applet/networkmanager.cpp:562
#9  0x00007fae479bb449 in NetworkManagerApplet::networkInterfaceRemoved (this=0x1259090, uni=...) at /usr/src/debug/networkmanagement-0.9.0/applet/networkmanager.cpp:532
#10 0x00007fae479bccd2 in NetworkManagerApplet::qt_metacall (this=0x1259090, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b94930) at /usr/src/debug/networkmanagement-0.9.0/build/applet/networkmanager.moc:126
#11 0x00007fae7ba195aa in QMetaObject::activate (sender=0x1270880, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff90b94930) at kernel/qobject.cpp:3287
#12 0x00007fae46e910c5 in Solid::Control::NetworkManagerNm09::Notifier::networkInterfaceRemoved (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement-0.9.0/build/solidcontrolfuture/libs/solid/control/networkmanager.moc:123
#13 0x00007fae46e91621 in Solid::Control::NetworkManagerNm09Private::_k_networkInterfaceRemoved (this=0x1270880, uni=...) at /usr/src/debug/networkmanagement-0.9.0/solidcontrolfuture/libs/solid/control/networkmanager.cpp:229
#14 0x00007fae46e91799 in Solid::Control::NetworkManagerNm09Private::qt_metacall (this=0x1270880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b94a70) at /usr/src/debug/networkmanagement-0.9.0/build/solidcontrolfuture/libs/solid/control/networkmanager_p.moc:82
#15 0x00007fae7ba195aa in QMetaObject::activate (sender=0x15a8040, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff90b94a70) at kernel/qobject.cpp:3287
#16 0x00007fae460c69b5 in Solid::Control::Ifaces::NetworkManagerNm09::networkInterfaceRemoved (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement-0.9.0/build/solidcontrolfuture/libs/solid/control/ifaces/networkmanager.moc:133
#17 0x00007fae462e1b67 in NMNetworkManagerNm09::nameOwnerChanged (this=0x15a8040, name=<optimized out>, oldOwner=..., newOwner=...) at /usr/src/debug/networkmanagement-0.9.0/solidcontrolfuture/solid/networkmanager-0.9/manager.cpp:347
#18 0x00007fae462e3e64 in NMNetworkManagerNm09::qt_metacall (this=0x15a8040, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b94cf0) at /usr/src/debug/networkmanagement-0.9.0/build/solidcontrolfuture/solid/networkmanager-0.9/manager.moc:102
#19 0x00007fae787c19fb in QDBusConnectionPrivate::deliverCall (this=0x81b0b0, object=0x15a8040, msg=..., metaTypes=..., slotIdx=24) at qdbusintegrator.cpp:942
#20 0x00007fae787cad5f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#21 0x00007fae7ba1d15a in QObject::event (this=0x15a8040, e=<optimized out>) at kernel/qobject.cpp:1226
#22 0x00007fae7abb8c34 in notify_helper (e=0xfc8780, receiver=0x15a8040, this=0x6e68d0) at kernel/qapplication.cpp:4481
#23 QApplicationPrivate::notify_helper (this=0x6e68d0, receiver=0x15a8040, e=0xfc8780) at kernel/qapplication.cpp:4453
#24 0x00007fae7abbdac1 in QApplication::notify (this=0x6d73b0, receiver=0x15a8040, e=0xfc8780) at kernel/qapplication.cpp:4360
#25 0x00007fae7c798e36 in KApplication::notify (this=0x6d73b0, receiver=0x15a8040, event=0xfc8780) at /usr/src/debug/kdelibs-4.7.2/kdeui/kernel/kapplication.cpp:311
#26 0x00007fae7ba0682c in QCoreApplication::notifyInternal (this=0x6d73b0, receiver=0x15a8040, event=0xfc8780) at kernel/qcoreapplication.cpp:787
#27 0x00007fae7ba09c08 in sendEvent (event=0xfc8780, receiver=0x15a8040) at kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x615800) at kernel/qcoreapplication.cpp:1428
#29 0x00007fae7ba310c3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007fae772105dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007fae77210dd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007fae77210fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007fae7ba3151f in QEventDispatcherGlib::processEvents (this=0x6e37b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#35 0x00007fae7ac5bf9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007fae7ba05a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007fae7ba05c2f in QEventLoop::exec (this=0x7fff90b956b0, flags=...) at kernel/qeventloop.cpp:201
#38 0x00007fae7ba09df7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#39 0x00007fae6a2bb773 in kdemain (argc=1, argv=0x683c50) at /usr/src/debug/kde-workspace-4.7.2/plasma/desktop/shell/main.cpp:120
#40 0x0000000000408897 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-12-07 16:58:32 UTC

*** This bug has been marked as a duplicate of bug 296740 ***