Bug 311271 - "Open in background tab" opens in foreground tab
Summary: "Open in background tab" opens in foreground tab
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 4.12
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 20:25 UTC by Rolf Eike Beer
Modified: 2016-09-26 15:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2012-12-06 20:25:59 UTC
The settings "open in background tab" and "open in new tab" behave the same, the article is always opened in a foreground tab.

Reproducible: Always
Comment 1 Maarten De Meyer 2012-12-10 20:27:32 UTC
Hi,
I cannot reproduce this bug. (4.9 beta2)
Articles are opened in a background tab. Links clicked in that article not (bug #182807)
Comment 2 Maarten De Meyer 2014-01-16 13:45:32 UTC
Closing.
Please reopen if you can still confirm the issue.
Comment 3 Rolf Eike Beer 2014-01-19 23:02:55 UTC
I still see it, both when opening a link from the article list as well as from within an article.
Comment 4 S. Bryant 2014-03-03 15:43:39 UTC
I still see this behaviour:  when I left-click on a link in an article summary, it often appears to open in a foreground tab although I have it configured to open in a background one.

I suspect, however, that the tab is activated later, unlike 'open in foreground tab' which activates it immediately.  It might possibly have something to do with the speed at which the HTTP connection can be established.

The middle-click ignores the configured setting and always opens the article in an external browser.

I'm using 4.12.2.
Comment 5 Denis Kurz 2016-09-24 19:40:34 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 Rolf Eike Beer 2016-09-26 15:48:33 UTC
Works in 5.3.0.