Bug 311256 - 4.10: plasma-desktop crashes on start
Summary: 4.10: plasma-desktop crashes on start
Status: RESOLVED DUPLICATE of bug 310647
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-06 14:31 UTC by Jure Repinc
Modified: 2012-12-07 14:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2012-12-06 14:31:08 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.90 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.7.0-rc8+ x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:
I just start from KDM or later start plasma-desktop from KRunner and it immidiately crashes. The crash is similar to related bug #310647 except that I already have Qt 4.8.4 and the backtrace is different from #13 on

The crash can be reproduced every time.

-- Backtrace:
Application: Delovno okolje Plasma Desktop (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f56083e6780 (LWP 23801))]

Thread 2 (Thread 0x7f55ffd4e700 (LWP 23802)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:164
#1  0x0000003d2854a487 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3d2883a600 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x0000003d2854a4c9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x000000396c40901b in start_thread (arg=0x7f55ffd4e700) at pthread_create.c:308
#4  0x000000396b8ea74d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7f56083e6780 (LWP 23801)):
[KCrash Handler]
#6  QDeclarativeVMEMetaObject::metaCall (this=0x2c00de0, c=QMetaObject::WriteProperty, _id=32, a=0x7fff7f480458) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x0000003d1da6a6a9 in QPropertyAnimationPrivate::updateProperty (this=0x2dc3c10, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x0000003d1da67b05 in QVariantAnimationPrivate::setCurrentValueForProgress (this=this@entry=0x2dc3c10, progress=progress@entry=0) at animation/qvariantanimation.cpp:294
#9  0x0000003d1da67ed2 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x2dc3c10, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x0000003d1da6ae29 in QPropertyAnimation::updateState (this=0x2dc3bf0, newState=<optimized out>, oldState=QAbstractAnimation::Stopped) at animation/qpropertyanimation.cpp:285
#11 0x0000003d1da65e73 in QAbstractAnimationPrivate::setState (this=0x2dc3c10, newState=QAbstractAnimation::Running) at animation/qabstractanimation.cpp:569
#12 0x00007f560ce769ed in Plasma::ItemBackground::itemChange (this=0x2dc3230, change=<optimized out>, value=...) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/plasma/widgets/itembackground.cpp:255
#13 0x0000003d1f990f42 in QGraphicsItemPrivate::setVisibleHelper (this=0x2dc32f0, newVisible=newVisible@entry=false, explicitly=explicitly@entry=false, update=update@entry=false) at graphicsview/qgraphicsitem.cpp:2288
#14 0x0000003d1f99128b in QGraphicsItemPrivate::setVisibleHelper (this=this@entry=0x20eeba0, newVisible=false, explicitly=explicitly@entry=false, update=update@entry=false) at graphicsview/qgraphicsitem.cpp:2355
#15 0x0000003d1f991d64 in QGraphicsItemPrivate::setParentItemHelper (this=0x20eeba0, newParent=0x2224750, newParentVariant=newParentVariant@entry=0x7fff7f480960, thisPointerVariant=thisPointerVariant@entry=0x7fff7f480980) at graphicsview/qgraphicsitem.cpp:1236
#16 0x0000003d1f992089 in QGraphicsItem::setParentItem (this=0x20eeaf0, newParent=0x2224750) at graphicsview/qgraphicsitem.cpp:1724
#17 0x00007f55feeab033 in syncMainItem (this=0x2224740) at /var/tmp/portage/kde-base/plasma-runtime-9999/work/plasma-runtime-9999/plasma/declarativeimports/core/dialog.cpp:167
#18 DialogProxy::syncMainItem (this=0x2224740) at /var/tmp/portage/kde-base/plasma-runtime-9999/work/plasma-runtime-9999/plasma/declarativeimports/core/dialog.cpp:135
#19 0x0000003d1db929fe in QObject::event (this=0x2224740, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x0000003d1f3dbe8c in QApplicationPrivate::notify_helper (this=this@entry=0x1ca9130, receiver=receiver@entry=0x2224740, e=e@entry=0x2c35da0) at kernel/qapplication.cpp:4562
#21 0x0000003d1f3e02f6 in QApplication::notify (this=0x1c1ae50, receiver=0x2224740, e=0x2c35da0) at kernel/qapplication.cpp:3944
#22 0x00007f560b624688 in KApplication::notify (this=0x1c1ae50, receiver=0x2224740, event=0x2c35da0) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdeui/kernel/kapplication.cpp:311
#23 0x0000003d1db7dd4d in QCoreApplication::notifyInternal (this=0x1c1ae50, receiver=receiver@entry=0x2224740, event=event@entry=0x2c35da0) at kernel/qcoreapplication.cpp:946
#24 0x0000003d1db81700 in sendEvent (event=0x2c35da0, receiver=0x2224740) at kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1be81f0) at kernel/qcoreapplication.cpp:1570
#26 0x0000003d1dbac5f3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=s@entry=0x1ca9980) at kernel/qeventdispatcher_glib.cpp:279
#28 0x000000396f84a5b4 in g_main_dispatch (context=0x1c9f780) at gmain.c:2539
#29 g_main_context_dispatch (context=context@entry=0x1c9f780) at gmain.c:3075
#30 0x000000396f84a924 in g_main_context_iterate (context=context@entry=0x1c9f780, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#31 0x000000396f84a9ec in g_main_context_iteration (context=0x1c9f780, may_block=1) at gmain.c:3207
#32 0x0000003d1dbac764 in QEventDispatcherGlib::processEvents (this=0x1be9ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x0000003d1f47caa6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x0000003d1db7ca4f in QEventLoop::processEvents (this=this@entry=0x7fff7f481310, flags=...) at kernel/qeventloop.cpp:149
#35 0x0000003d1db7cd30 in QEventLoop::exec (this=0x7fff7f481310, flags=...) at kernel/qeventloop.cpp:204
#36 0x0000003d1db81a08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#37 0x00007f560d1f5b2f in kdemain (argc=1, argv=0x7fff7f481618) at /var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace-9999/plasma/desktop/shell/main.cpp:126
#38 0x000000396b8249d5 in __libc_start_main (main=0x400820 <main(int, char**)>, argc=1, ubp_av=0x7fff7f481618, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7f481608) at libc-start.c:225
#39 0x0000000000400851 in _start ()

This bug may be a duplicate of or related to bug 310647.

Possible duplicates by query: bug 310647.

Reported using DrKonqi
Comment 1 Janek Bevendorff 2012-12-07 14:08:07 UTC

*** This bug has been marked as a duplicate of bug 310647 ***