Bug 311201 - opening the tagging menu takes ages
Summary: opening the tagging menu takes ages
Status: RESOLVED UNMAINTAINED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: widgets - TagWidget (show other bugs)
Version: 4.9
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-05 14:38 UTC by m.wege
Modified: 2015-01-23 16:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2012-12-05 14:38:11 UTC
I just wanted to tag three files (in this case a linked folder and two linked files)  by marking them and selecting "add tags" in the side bar. It took about 5 min until the tag menu appeared. This is far to long. This bug may be related to the other bug I will report after: The second time it did this, dolphin crashed.

Reproducible: Didn't try
Comment 1 m.wege 2012-12-05 14:43:59 UTC
The other bug number is https://bugs.kde.org/show_bug.cgi?id=311203
Comment 2 Frank Reininghaus 2012-12-05 14:47:01 UTC
Probably related to Nepomuk.
Comment 3 Vishesh Handa 2013-01-25 14:46:47 UTC
Could you possibly tell me the number of tags you have?

Also, is this reproducible or did it just happen that one time?
Comment 4 m.wege 2013-01-25 14:53:10 UTC
Is there tool which allows to count, because I have quite a few (If I should guess, about 100) Although I have to add most of them where newer created by myself. Most of them where once pulled out of my address book categories.
The crash is not reproducable. The time  this takes is.
Comment 5 Vishesh Handa 2013-01-25 15:02:08 UTC
You can run the following command -

$ nepomukcmd query 'select count(distinct ?r) where { ?r a nao:Tag . }'

nepomukcmd is an alias and can be found over here - http://techbase.kde.org/Development/Tutorials/Metadata/Nepomuk/TipsAndTricks#nepomukcmd
Comment 6 m.wege 2013-01-25 15:05:57 UTC
callret-0 -> "3525"^^<http://www.w3.org/2001/XMLSchema#int>
Total results: 1
Execution time: 00:00:00.17

Is there anyway I can just delete them all?
Comment 7 Vishesh Handa 2013-02-14 22:10:34 UTC
Sorry about the delay. I forgot about this.

Do you mind running the following query - 

$nepomukcmd query 'select ?r ?p ?o where { ?r a nao:Tag . ?r ?p ?o . }'

This will give me information about the tags.

You could try running the nepomukcleaner. It is supposed to remove all invalid tags, and merge duplicate tags.
Comment 8 m.wege 2013-02-15 06:05:53 UTC
Can I send the result of the query to a private email?
I actually ran Nepomuk cleaner, but unfortunately it does not finish. It fails when trying to remove the doubles. I have reported this already as a bug.
But I also deleted the Nepomuk folder (since then Nepomuk is happyly crashing, you already (hopefully fixed that) and I am waiting for 4.10.1
Comment 9 Vishesh Handa 2013-02-15 08:05:28 UTC
(In reply to comment #8)
> Can I send the result of the query to a private email?
> I actually ran Nepomuk cleaner, but unfortunately it does not finish. It
> fails when trying to remove the doubles. I have reported this already as a
> bug.
> But I also deleted the Nepomuk folder (since then Nepomuk is happyly
> crashing, you already (hopefully fixed that) and I am waiting for 4.10.1

Go ahead. It's me@vhanda.in

oh boy. This release doesn't sound really nice. You seems to be having a lot of problems. Hopefully, I can fix all of them in time for 4.10.1.
Comment 10 Vishesh Handa 2013-06-10 13:33:29 UTC
Any clue if this still happens with 4.10.4?
Comment 11 m.wege 2013-06-10 14:40:17 UTC
The first time it takes about 30 seconds (which I still would consider too much, but it has definitely improved), the second time the menu appears instantly.
Comment 12 Vishesh Handa 2015-01-23 16:18:16 UTC
Thank you for taking the time to file a bug report.

The Nepomuk project is no longer included in the KDE Software Compilation. With Plasma 5, we have replaced most of the underlying technology with Baloo and other components. Hopefully this will have addressed your concern.

We encourage you to try out Plasma 5 (+Baloo) and let us know if your problem persists.