Bug 311169 - plasma-desktop crashes on start with kde 4.10 beta2
Summary: plasma-desktop crashes on start with kde 4.10 beta2
Status: RESOLVED DUPLICATE of bug 310647
Alias: None
Product: plasma4
Classification: Unclassified
Component: desktop (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR critical with 1 vote (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 311197 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-05 01:55 UTC by Bernd Buschinski
Modified: 2012-12-07 14:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Buschinski 2012-12-05 01:55:13 UTC
plasma-desktop crashes on start with kde 4.10 beta2
and does not recover, as krunner still works restarting it with krunner also causes a crash

I even tried a new user, but still crashes

Reproducible: Always

Steps to Reproduce:
1. install kde 4.10beta2
2. login with your user
Actual Results:  
crash

Expected Results:  
it should not crash

Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbb113ab780 (LWP 5015))]

Thread 2 (Thread 0x7fbaef4ff700 (LWP 5017)):
#0  0x00007fbb0e8c289d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fbb0b5adb5c in g_main_context_iterate.isra.23 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fbb0b5adc8c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fbb0ffeebae in QEventDispatcherGlib::processEvents (this=0x7fbae80008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbb0ffbc10f in QEventLoop::processEvents (this=this@entry=0x7fbaef4fed70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbb0ffbc3c8 in QEventLoop::exec (this=0x7fbaef4fed70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbb0feb29ed in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007fbb0ff9ba53 in QInotifyFileSystemWatcherEngine::run (this=0x18b8aa0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007fbb0feb5759 in QThreadPrivate::start (arg=0x18b8aa0) at thread/qthread_unix.cpp:338
#9  0x00007fbafea9e344 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007fbb0fc1f01b in start_thread (arg=0x7fbaef4ff700) at pthread_create.c:308
#11 0x00007fbb0e8cb74d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7fbb113ab780 (LWP 5015)):
[KCrash Handler]
#6  QDeclarativeVMEMetaObject::metaCall (this=0x1b75520, c=QMetaObject::WriteProperty, _id=32, a=0x7fffcb9d8178) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x00007fbb0fe9daa9 in QPropertyAnimationPrivate::updateProperty (this=0x1b74de0, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x00007fbb0fe9ade5 in QVariantAnimationPrivate::setCurrentValueForProgress (this=this@entry=0x1b74de0, progress=progress@entry=0) at animation/qvariantanimation.cpp:294
#9  0x00007fbb0fe9b1b2 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x1b74de0, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x00007fbb0fe9e211 in QPropertyAnimation::updateState (this=0xf762a0, newState=<optimized out>, oldState=QAbstractAnimation::Stopped) at animation/qpropertyanimation.cpp:285
#11 0x00007fbb0fe99013 in QAbstractAnimationPrivate::setState (this=0x1b74de0, newState=QAbstractAnimation::Running) at animation/qabstractanimation.cpp:569
#12 0x00007fbb0454b82d in Plasma::ItemBackground::itemChange (this=0x1b74410, change=<optimized out>, value=...) at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/plasma/widgets/itembackground.cpp:255
#13 0x00007fbb0f6da66e in QGraphicsScenePrivate::_q_polishItems (this=0xb9fa10) at graphicsview/qgraphicsscene.cpp:456
#14 0x00007fbb0f6daa51 in qt_static_metacall (_a=<optimized out>, _id=13, _o=0xcc12c0, _c=<optimized out>) at .moc/debug-shared/moc_qgraphicsscene.cpp:106
#15 QGraphicsScene::qt_static_metacall (_o=0xcc12c0, _c=<optimized out>, _id=13, _a=<optimized out>) at .moc/debug-shared/moc_qgraphicsscene.cpp:86
#16 0x00007fbb0ffd4bfe in QObject::event (this=0xcc12c0, e=<optimized out>) at kernel/qobject.cpp:1194
#17 0x00007fbb0f6deb6b in QGraphicsScene::event (this=0xcc12c0, event=0x1a7cd80) at graphicsview/qgraphicsscene.cpp:3565
#18 0x00007fbb0f079d51 in QApplicationPrivate::notify_helper (this=this@entry=0x9f1c00, receiver=receiver@entry=0xcc12c0, e=e@entry=0x1a7cd80) at kernel/qapplication.cpp:4562
#19 0x00007fbb0f07c3f9 in QApplication::notify (this=0x9eed20, receiver=0xcc12c0, e=0x1a7cd80) at kernel/qapplication.cpp:4423
#20 0x00007fbb10da8248 in KApplication::notify (this=0x9eed20, receiver=0xcc12c0, event=0x1a7cd80) at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/kdeui/kernel/kapplication.cpp:311
#21 0x00007fbb0ffbdbad in QCoreApplication::notifyInternal (this=0x9eed20, receiver=receiver@entry=0xcc12c0, event=event@entry=0x1a7cd80) at kernel/qcoreapplication.cpp:946
#22 0x00007fbb0ffc1437 in sendEvent (event=0x1a7cd80, receiver=0xcc12c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8fe2b0) at kernel/qcoreapplication.cpp:1570
#24 0x00007fbb0ffeea13 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#25 postEventSourceDispatch (s=0xb68b80) at kernel/qeventdispatcher_glib.cpp:279
#26 0x00007fbb0b5ad854 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007fbb0b5adbc4 in g_main_context_iterate.isra.23 () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fbb0b5adc8c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fbb0ffeeb84 in QEventDispatcherGlib::processEvents (this=0x9f0b60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007fbb0f123d86 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fbb0ffbc10f in QEventLoop::processEvents (this=this@entry=0x7fffcb9d9050, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fbb0ffbc3c8 in QEventLoop::exec (this=0x7fffcb9d9050, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007fbb0ffc1848 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#34 0x00007fbafb825b2f in kdemain (argc=1, argv=0x8ff710) at /var/tmp/portage/kde-base/plasma-workspace-4.9.90/work/plasma-workspace-4.9.90/plasma/desktop/shell/main.cpp:126
#35 0x0000000000408a3f in launch (argc=argc@entry=1, _name=_name@entry=0x8fdb38 "/usr/bin/plasma-desktop", args=args@entry=0x8fdb50 "", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x8fdb58 "", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x40b31d "0") at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/kinit/kinit.cpp:726
#36 0x000000000040989b in handle_launcher_request (sock=7, who=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/kinit/kinit.cpp:1218
#37 0x0000000000409f03 in handle_requests (waitForPid=waitForPid@entry=0) at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/kinit/kinit.cpp:1411
#38 0x0000000000405b77 in main (argc=2, argv=<optimized out>, envp=0x7fffcb9d9da0) at /var/tmp/portage/kde-base/kdelibs-4.9.90/work/kdelibs-4.9.90/kinit/kinit.cpp:1899
Comment 1 Bernd Buschinski 2012-12-05 19:26:12 UTC
+ using Qt 4.8.4 with debugging symbols and asserts enabled
Comment 2 Jekyll Wu 2012-12-05 19:46:51 UTC
*** Bug 311197 has been marked as a duplicate of this bug. ***
Comment 3 Janek Bevendorff 2012-12-07 14:08:36 UTC

*** This bug has been marked as a duplicate of bug 310647 ***