Bug 311128 - Segmentation fault after extended pause (4+ hours).
Summary: Segmentation fault after extended pause (4+ hours).
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-04 04:07 UTC by Richard Diamond
Modified: 2012-12-04 12:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Diamond 2012-12-04 04:07:34 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I noticed a random bookmark (as in, one i do not remember creating) on the paused song's progress bar, accidently right clicked on the bookmark, then noticed the value on the left of the bar was in the 4+ hour mark, and the time left (right side) said like 28 minutes. Decided to restart, and when I told amarok to quit, segmentation fault.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9f6db857c0 (LWP 32620))]

Thread 14 (Thread 0x7f9f5056f700 (LWP 32621)):
#0  0x00007f9f6a458303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9f65000036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9f6500049a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f5057498b in ?? () from /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
#4  0x00007f9f650219e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9f66b37e9a in start_thread (arg=0x7f9f5056f700) at pthread_create.c:308
#6  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7f9f4fd6e700 (LWP 32622)):
#0  0x00007f9f6a4568bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f9f6503a8cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9f64fffba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f64ffffd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9f6500049a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9f56f19406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#6  0x00007f9f650219e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f9f66b37e9a in start_thread (arg=0x7f9f4fd6e700) at pthread_create.c:308
#8  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f9f3aadf700 (LWP 32628)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f3c31952d in ?? () from /usr/lib/libvlccore.so.5
#2  0x00007f9f66b37e9a in start_thread (arg=0x7f9f3aadf700) at pthread_create.c:308
#3  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f9f34137700 (LWP 32630)):
#0  0x00007f9f6a458303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9f65000036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9f65000164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f6adf2426 in QEventDispatcherGlib::processEvents (this=0x7f9f2c000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9f6adc1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9f6adc1ed7 in QEventLoop::exec (this=0x7f9f34136d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9f6acc0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9f6ada19ff in QInotifyFileSystemWatcherEngine::run (this=0x282d340) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x282d340) at thread/qthread_unix.cpp:298
#9  0x00007f9f66b37e9a in start_thread (arg=0x7f9f34137700) at pthread_create.c:308
#10 0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f9f31aaf700 (LWP 32631)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f6acc44db in wait (time=18446744073709551615, this=0x2f41bc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2f41260, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9f680e20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2f427f0, th=0x2f42ce0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9f680e49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2f3bb00, th=0x2f42ce0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9f680e384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9f31aaede0, parent=0x2f427f0, th=0x2f42ce0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9f680e38db in ThreadWeaver::Thread::run (this=0x2f42ce0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x2f42ce0) at thread/qthread_unix.cpp:298
#8  0x00007f9f66b37e9a in start_thread (arg=0x7f9f31aaf700) at pthread_create.c:308
#9  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f9f312ae700 (LWP 32632)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f6acc44db in wait (time=18446744073709551615, this=0x2f41bc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2f41260, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9f680e20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2f427f0, th=0x2f43a90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9f680e49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2f3bb00, th=0x2f43a90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9f680e384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9f312adde0, parent=0x2f427f0, th=0x2f43a90) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9f680e38db in ThreadWeaver::Thread::run (this=0x2f43a90) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x2f43a90) at thread/qthread_unix.cpp:298
#8  0x00007f9f66b37e9a in start_thread (arg=0x7f9f312ae700) at pthread_create.c:308
#9  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f9f30aad700 (LWP 32633)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f6acc44db in wait (time=18446744073709551615, this=0x2f41bc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2f41260, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9f680e20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2f427f0, th=0x2f44710) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9f680e49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2f3bb00, th=0x2f44710) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9f680e384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9f30aacde0, parent=0x2f427f0, th=0x2f44710) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9f680e38db in ThreadWeaver::Thread::run (this=0x2f44710) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x2f44710) at thread/qthread_unix.cpp:298
#8  0x00007f9f66b37e9a in start_thread (arg=0x7f9f30aad700) at pthread_create.c:308
#9  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f9f1cfa7700 (LWP 32634)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f6acc44db in wait (time=18446744073709551615, this=0x2f41bc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2f41260, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9f680e20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2f427f0, th=0x372f580) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f9f680e49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x2f3bb00, th=0x372f580) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f9f680e384f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9f1cfa6de0, parent=0x2f427f0, th=0x372f580) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f9f680e38db in ThreadWeaver::Thread::run (this=0x372f580) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x372f580) at thread/qthread_unix.cpp:298
#8  0x00007f9f66b37e9a in start_thread (arg=0x7f9f1cfa7700) at pthread_create.c:308
#9  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f9f4e8e7700 (LWP 25774)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f6acc44db in wait (time=18446744073709551615, this=0x3f6d790) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2936020, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9f6bccd354 in QFileInfoGatherer::run (this=0x2936010) at dialogs/qfileinfogatherer.cpp:214
#4  0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x2936010) at thread/qthread_unix.cpp:298
#5  0x00007f9f66b37e9a in start_thread (arg=0x7f9f4e8e7700) at pthread_create.c:308
#6  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f9f0162f700 (LWP 25775)):
#0  0x00007f9f66b39f69 in __pthread_mutex_lock (mutex=0x7f9ef0000a60) at pthread_mutex_lock.c:92
#1  0x00007f9f6503b5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9f64fff675 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9f64ffff5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9f65000164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9f6adf2426 in QEventDispatcherGlib::processEvents (this=0x7f9ef00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f9f6adc1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f9f6adc1ed7 in QEventLoop::exec (this=0x7f9f0162ed90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f9f6acc0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f9f6ada19ff in QInotifyFileSystemWatcherEngine::run (this=0x413e330) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f9f6acc3fcb in QThreadPrivate::start (arg=0x413e330) at thread/qthread_unix.cpp:298
#11 0x00007f9f66b37e9a in start_thread (arg=0x7f9f0162f700) at pthread_create.c:308
#12 0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9f1742f700 (LWP 9335)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f9f3c38b90b in vlc_cond_timedwait () from /usr/lib/libvlccore.so.5
#2  0x00007f9f3c3405e1 in ?? () from /usr/lib/libvlccore.so.5
#3  0x00007f9f3c341185 in ?? () from /usr/lib/libvlccore.so.5
#4  0x00007f9f66b37e9a in start_thread (arg=0x7f9f1742f700) at pthread_create.c:308
#5  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f9f141cf700 (LWP 9336)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9f3c32b197 in ?? () from /usr/lib/libvlccore.so.5
#2  0x00007f9f3c32cf1c in ?? () from /usr/lib/libvlccore.so.5
#3  0x00007f9f3c32da7e in ?? () from /usr/lib/libvlccore.so.5
#4  0x00007f9f3c32dc4b in ?? () from /usr/lib/libvlccore.so.5
#5  0x00007f9f66b37e9a in start_thread (arg=0x7f9f141cf700) at pthread_create.c:308
#6  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9f03fff700 (LWP 9337)):
#0  0x00007f9f6a458303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9f6283835f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f9f6282976c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f9f62829dd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f9f62829e90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f9f6283830f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f9f5dc3fd18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007f9f66b37e9a in start_thread (arg=0x7f9f03fff700) at pthread_create.c:308
#8  0x00007f9f6a463cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9f6db857c0 (LWP 32620)):
[KCrash Handler]
#6  0x0000000003f15728 in ?? ()
#7  0x00007f9f6ca1c02e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x260a5a0, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f9f6ca1c209 in CollectionManager::~CollectionManager (this=0x260a5a0, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f9f6ca1a4b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f9f6cb4f4cf in App::~App (this=0x7fff2d4623a0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fff2d464828) at ../../src/main.cpp:303

Possible duplicates by query: bug 311082, bug 310233, bug 309501, bug 308752, bug 308312.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-12-04 12:16:09 UTC
Please upgrade to Amarok 2.6, this is fixed since quite some time already.

*** This bug has been marked as a duplicate of bug 285951 ***