Bug 311081 - kwin turns on compositing unconditionally even if disabled
Summary: kwin turns on compositing unconditionally even if disabled
Status: RESOLVED DUPLICATE of bug 308438
Alias: None
Product: kwin
Classification: Plasma
Component: rules (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-03 13:33 UTC by Eugeny Shkrigunov
Modified: 2012-12-03 14:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugeny Shkrigunov 2012-12-03 13:33:59 UTC
Hi!

Sorry for my English.

There is a rule for the program (call it weird_prog) which does not work with compositig
~/.kde4/share/config/kwinrulesrc
[1]
Description=off compositing
blockcompositing=true
blockcompositingrule=2
types=4294967295
wmclass=weird_prog
wmclasscomplete=false
wmclassmatch=1

after weird_prog closed kwin turns on compositing unconditionally even if disabled
~/.kde4/share/config/kwinrc
[Compositing]
Enabled=false


Reproducible: Always
Comment 1 Thomas Lübking 2012-12-03 14:07:03 UTC

*** This bug has been marked as a duplicate of bug 308438 ***