Bug 311026 - give ark a feature "preview as"
Summary: give ark a feature "preview as"
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.19
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Raphael Kubo da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-02 15:12 UTC by Martin Walch
Modified: 2012-12-02 21:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Walch 2012-12-02 15:12:52 UTC
Currently, ark allows a preview of a file from an archive. I am using this feature pretty often. However, sometimes the preview application does not fit. There are situations that force me to extract a file and then open it with a standalone application, which is annoying.

I suppose it is not desirable to allow opening such a _temporary_ file with arbitrary applications, because this may tempt the user to edit and save the changes.

Still, it would be nice to have a choice *how* a file is displayed. For example, if the user receives a zip archive with an html file in it, it is possible that he wants to view it interpreted and rendered like in a browser or that he wants to see the html code as plain text.

Therefore, it would be nice to have an additional option like "preview as" or "preview in/with"

Reproducible: Always
Comment 1 Raphael Kubo da Costa 2012-12-02 21:13:24 UTC

*** This bug has been marked as a duplicate of bug 179066 ***