Bug 310828 - After changing the site policy for a web site from reject to accept the module crashed without applying the change
Summary: After changing the site policy for a web site from reject to accept the modul...
Status: RESOLVED DUPLICATE of bug 307831
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-28 15:44 UTC by Martin
Modified: 2012-11-28 18:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2012-11-28 15:44:47 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.5.0-19-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

I came from rekonq/options/privacy/manage cookies to change the cookie policy for a single site. After changing the policy from reject to accept and clicking OK the module crashed. This crash occurs with every site I pick. No changes were applied.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kcmshell4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbe75bc1780 (LWP 13396))]

Thread 2 (Thread 0x7fbe6bde5700 (LWP 13397)):
#0  0x00007fbe7d2b6303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe77c93d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe77c93ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe7bee7c16 in QEventDispatcherGlib::processEvents (this=0x7fbe640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbe7beb82bf in QEventLoop::processEvents (this=this@entry=0x7fbe6bde4dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe7beb8548 in QEventLoop::exec (this=0x7fbe6bde4dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbe7bdb9b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbe7be989af in QInotifyFileSystemWatcherEngine::run (this=0x122abf0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbe7bdbcaec in QThreadPrivate::start (arg=0x122abf0) at thread/qthread_unix.cpp:338
#9  0x00007fbe789b4e9a in start_thread (arg=0x7fbe6bde5700) at pthread_create.c:308
#10 0x00007fbe7d2c1cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbe75bc1780 (LWP 13396)):
[KCrash Handler]
#6  0x0000000200000000 in ?? ()
#7  0x00007fbe6c53e407 in text (column=0, this=<optimized out>) at /usr/include/qt4/QtGui/qtreewidget.h:110
#8  KCookiesPolicies::save (this=0xf306c0) at ../../../../konqueror/settings/kio/kcookiespolicies.cpp:391
#9  0x00007fbe6c53c071 in KCookiesMain::save (this=0xefd380) at ../../../../konqueror/settings/kio/kcookiesmain.cpp:70
#10 0x00007fbe7cfb04a7 in KCModuleProxy::save (this=<optimized out>) at ../../kutils/kcmoduleproxy.cpp:279
#11 0x00007fbe7cfade20 in KCMultiDialogPrivate::apply (this=<optimized out>) at ../../kutils/kcmultidialog.cpp:300
#12 0x00007fbe7cfadf27 in KCMultiDialog::slotOkClicked (this=0xf01490) at ../../kutils/kcmultidialog.cpp:334
#13 0x00007fbe7becef5f in QMetaObject::activate (sender=0xf01490, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x00007fbe7cad2fe8 in KDialog::slotButtonClicked (this=0xf01490, button=4) at ../../kdeui/dialogs/kdialog.cpp:884
#15 0x00007fbe7cad3414 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kdialog.moc:167
#16 KDialog::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./kdialog.moc:127
#17 0x00007fbe7becef5f in QMetaObject::activate (sender=0xece1e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff58992f20) at kernel/qobject.cpp:3547
#18 0x00007fbe7bed4e2e in QSignalMapper::mapped (this=this@entry=0xece1e0, _t1=4) at .moc/release-shared/moc_qsignalmapper.cpp:115
#19 0x00007fbe7bed5035 in QSignalMapper::map (this=0xece1e0, sender=0xecdba0) at kernel/qsignalmapper.cpp:266
#20 0x00007fbe7becef5f in QMetaObject::activate (sender=0xecdba0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff589930b0) at kernel/qobject.cpp:3547
#21 0x00007fbe7b8cb422 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:220
#22 0x00007fbe7b61ed2e in QAbstractButtonPrivate::emitClicked (this=this@entry=0xfab8d0) at widgets/qabstractbutton.cpp:548
#23 0x00007fbe7b61f560 in QAbstractButtonPrivate::click (this=this@entry=0xfab8d0) at widgets/qabstractbutton.cpp:541
#24 0x00007fbe7b61f7cc in QAbstractButton::mouseReleaseEvent (this=0xecdba0, e=0x7fff58993950) at widgets/qabstractbutton.cpp:1123
#25 0x00007fbe7b2b0850 in QWidget::event (this=0xecdba0, event=0x7fff58993950) at kernel/qwidget.cpp:8371
#26 0x00007fbe7b260e9c in QApplicationPrivate::notify_helper (this=this@entry=0xd31a60, receiver=receiver@entry=0xecdba0, e=e@entry=0x7fff58993950) at kernel/qapplication.cpp:4562
#27 0x00007fbe7b265b6b in QApplication::notify (this=<optimized out>, receiver=0xecdba0, e=0x7fff58993950) at kernel/qapplication.cpp:4105
#28 0x00007fbe7cb721d6 in KApplication::notify (this=0x7fff58994750, receiver=0xecdba0, event=0x7fff58993950) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fbe7beb956e in QCoreApplication::notifyInternal (this=0x7fff58994750, receiver=0xecdba0, event=0x7fff58993950) at kernel/qcoreapplication.cpp:915
#30 0x00007fbe7b261cd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QApplicationPrivate::sendMouseEvent (receiver=0xecdba0, event=0x7fff58993950, alienWidget=0xecdba0, nativeWidget=0xecf440, buttonDown=0x7fbe7bd3d308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#32 0x00007fbe7b2df554 in QETWidget::translateMouseEvent (this=this@entry=0xecf440, event=event@entry=0x7fff589940d0) at kernel/qapplication_x11.cpp:4622
#33 0x00007fbe7b2de44f in QApplication::x11ProcessEvent (this=0x7fff58994750, event=0x7fff589940d0) at kernel/qapplication_x11.cpp:3737
#34 0x00007fbe7b305fa2 in x11EventSourceDispatch (s=0xd34640, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#35 0x00007fbe77c93ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fbe77c93de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fbe77c93ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fbe7bee7bf6 in QEventDispatcherGlib::processEvents (this=0xd0e770, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x00007fbe7b305c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fbe7beb82bf in QEventLoop::processEvents (this=this@entry=0x7fff589944b0, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007fbe7beb8548 in QEventLoop::exec (this=0x7fff589944b0, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007fbe7b719428 in QDialog::exec (this=0xf01490) at dialogs/qdialog.cpp:554
#43 0x00007fbe7d5bfb1c in kdemain (_argc=13783264, _argv=<optimized out>) at ../../kcmshell/main.cpp:292
#44 0x00007fbe7d1ef76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=2, ubp_av=0x7fff58994888, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff58994878) at libc-start.c:226
#45 0x00000000004006d1 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2012-11-28 18:27:52 UTC

*** This bug has been marked as a duplicate of bug 307831 ***