Bug 310801 - Dolphin crash on rename then drag
Summary: Dolphin crash on rename then drag
Status: RESOLVED DUPLICATE of bug 309421
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-28 08:04 UTC by Alexey Dyachenko
Modified: 2012-11-28 13:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Dyachenko 2012-11-28 08:04:59 UTC
When trying to rename a file but accidentaly draging selected text (instead of selecting other) Dolphin offers to type in "Filename for dropped contents", If you click cancel Dolphin will crash.
Reproducible everytime.

Reproducible: Always

Steps to Reproduce:
1. Try to rename a file then move selected text to Places or other panel.
2. Dialogue window for "Filename for dropped contents" will open.
3. Click cancel.
Actual Results:  
Crash.


Application: Dolphin (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f27859c2780 (LWP 1033))]

Thread 2 (Thread 0x7f276aa7d700 (LWP 1035)):
#0  0x00007f278301418d in poll () from /usr/lib/libc.so.6
#1  0x00007f277ff6ab14 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f277ff6ac34 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f2784644756 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f278461531f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f27846155a8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f27845167c0 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f27845f5adf in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f278451979c in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f2784289e0f in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f278301c31d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f27859c2780 (LWP 1033)):
[KCrash Handler]
#5  0x00007f2783a51ad5 in QTextCursor::removeSelectedText() () from /usr/lib/libQtGui.so.4
#6  0x00007f27839eaec1 in ?? () from /usr/lib/libQtGui.so.4
#7  0x00007f27839f2e46 in ?? () from /usr/lib/libQtGui.so.4
#8  0x00007f27839f63f0 in QTextControl::processEvent(QEvent*, QMatrix const&, QWidget*) () from /usr/lib/libQtGui.so.4
#9  0x00007f27839eb293 in QTextControl::processEvent(QEvent*, QPointF const&, QWidget*) () from /usr/lib/libQtGui.so.4
#10 0x00007f2783c0cafb in QTextEdit::mouseMoveEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#11 0x00007f27837f9834 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x00007f2783ba43f6 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007f2784616736 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x00007f27837aa05c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x00007f27837aed6b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f27853b7df6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x00007f27846165ce in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00007f27837aaecb in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#19 0x00007f2783825994 in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007f2783824721 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00007f278384a8b2 in ?? () from /usr/lib/libQtGui.so.4
#22 0x00007f277ff6a845 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f277ff6ab78 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f277ff6ac34 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f2784644736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f278384a52e in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007f278461531f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f27846155a8 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007f278461a248 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x00007f277069cab7 in kdemain () from /usr/lib/libkdeinit4_dolphin.so
#31 0x0000000000408286 in _start ()
Comment 1 Frank Reininghaus 2012-11-28 13:07:37 UTC
Thanks for reporting, this has been fixed already for KDE 4.9.4.

*** This bug has been marked as a duplicate of bug 309421 ***