Bug 310743 - akonadi_davgroupware_resoure takes a lot of cpu and memory
Summary: akonadi_davgroupware_resoure takes a lot of cpu and memory
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.9
Platform: OpenSUSE Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2012-11-27 05:37 UTC by Johann-Nikolaus Andreae
Modified: 2018-09-19 14:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johann-Nikolaus Andreae 2012-11-27 05:37:15 UTC
The akonadi_davgroupware_resoure is connected to owncloud with adressbook and tasks.

The resource runs the most time with 50% cpu load and takes other the time more then 2GB of memory.

Reproducible: Always
Comment 1 Grégory Oestreicher 2012-11-27 07:46:28 UTC
Do you have an idea of the total number of items you have in your calendars and addressbooks?
Comment 2 Johann-Nikolaus Andreae 2012-11-28 05:24:16 UTC
I have 92 contact entrys, about 50 task and one events in the cloud.
Comment 3 Johann-Nikolaus Andreae 2013-01-12 03:49:10 UTC
Another detail i found in 4.9.97:
The resource make a lot (current 38GB) of output to the .xsession-errors.

Always the same line:
akonadi_davgroupware_resource_0(2644)/akonadiserializer (addressee) Akonadi::SerializerPluginAddressee::deserialize: Empty addressee object!
Comment 4 tony den haan 2014-07-10 11:47:18 UTC
I just had it nearly kill my system using all memory + swap after it thought it encountered invalid cert on davical server.
Comment 5 Erik Quaeghebeur 2014-08-13 14:52:42 UTC
(In reply to tony den haan from comment #4)
> I just had it nearly kill my system using all memory + swap after it thought
> it encountered invalid cert on davical server.

I can confirm this for 4.12.5. I encountered the same type of behavior: after a problem verifying the server certificate (dav part of akonadi seems to be unable to properly deal with being offline while starting up) the process took all resources of one of my two CPU cores and started eating up GB of RAM (killed it before it took down my system).
Comment 6 auxsvr 2014-09-14 18:24:31 UTC
I've encountered problems with certificates and the davgroupware resource, but in my case the culprit was kded, as it was not responding. After restarting it, the davgroupware resource resumed proper operation.
Comment 7 Grégory Oestreicher 2014-10-01 18:27:43 UTC
I had a certificate expired yesterday, and the resource behaved fine. No high CPU or RAM usage. I'm using 4.14.1, can anyone test on this version?

Cheers,
Grégory
Comment 8 Andrew Crouthamel 2018-09-19 14:37:35 UTC
This bug has had its resolution changed, but accidentally has been left in NEEDSINFO status. I am thus closing this bug and setting the status as RESOLVED to reflect the resolution change.