Bug 310629 - Cannot run script on log out
Summary: Cannot run script on log out
Status: RESOLVED DUPLICATE of bug 228795
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_autostart (show other bugs)
Version: 4.9.3
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Laurent Montel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-25 00:33 UTC by Kai Uwe Broulik
Modified: 2012-11-25 07:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2012-11-25 00:33:18 UTC
The Startup and Shutdown kcm provides an option to run a script when logging out. When I check that, however, the script seems not to be run on shutdown but when I log back in again and when I checked the settings, it was on Log in again.

Reproducible: Always

Steps to Reproduce:
1. Create a script such as "kdialog --sorry 'shutting down'"
2. Add to Startup and shutdown kcm
3. Change "On Log in" to "On Log out"
4. Restart computer
Actual Results:  
Script is executed on logging in, and the setting has changed back to "On Log in"

Expected Results:  
The script is executed when logging out
Comment 1 Jekyll Wu 2012-11-25 07:50:40 UTC
Should be fixed in 4.9.4

*** This bug has been marked as a duplicate of bug 228795 ***