Bug 310572 - Inaccessible yellow highlighting annotation because of wrongly calculated boundary
Summary: Inaccessible yellow highlighting annotation because of wrongly calculated bou...
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.15.3
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-23 21:13 UTC by Jaan Vajakas
Modified: 2012-12-23 09:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.0


Attachments
a document with inaccessible annotation (13.79 KB, application/zip)
2012-11-23 21:13 UTC, Jaan Vajakas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaan Vajakas 2012-11-23 21:13:14 UTC
Created attachment 75433 [details]
a document with inaccessible annotation

With the yellow highlighter tool, is possible to create annotations which cannot be edited or deleted by clicking on them.

How to reproduce:
Open some PDF file, select the yellow markup tool, start dragging to the right from the beginning of some line and release the mouse button when the cursor is on the vertical scrollbar on the right. Then click with the left mouse button somewhere in the document.

Actual result:
A yellow highlighting annotation is created which cannot be accessed by clicking on it: a left double-click or right-click on the yellow area does nothing (but fortunately, it is still accessible via the Navigation Panel).

The XML file in ~/.kde4/share/apps/okular/docdata/ contains a tag like this:
      <boundary l="-0.000673401" r="0" b="0" t="-0.00047619"/>
The negative coordinates of the boundary suggest that the problem is that the boundary of the annotation has been wrongly calculated.

Attached is a file LoremIpsum.pdf.zip containing an original document LoremIpsum.pdf and the corresponding XML file ~/.kde4/share/apps/okular/docdata/13561.LoremIpsum.pdf.xml which contains an inaccessible annotation created as described above.

Expected result:
The created yellow highlighting annotation should be accessible by clicking on it. It would be nice, but maybe not worth the trouble, if such annotations created by older versions of Okular became clickable, too, in the new fixed version of Okular (i. e. if the boundaries were recalculated).
Comment 1 Albert Astals Cid 2012-12-16 19:49:21 UTC
Git commit 1ef6929344a423a837aa9fff56524706220def56 by Albert Astals Cid.
Committed on 16/12/2012 at 20:48.
Pushed by aacid into branch 'master'.

Don't ignore mouse movements on the annotator when not on the locked item

REVIEW: 107726

M  +13   -14   ui/pageviewannotator.cpp

http://commits.kde.org/okular/1ef6929344a423a837aa9fff56524706220def56
Comment 2 Albert Astals Cid 2012-12-16 19:52:28 UTC
Fixed the creation, if you feel that the reparation of existing ones it's important please open a new bug, but take into account that's qiute of a corner case so it won't really be one of the topmost things we will be working since there's lots of things to work on and limited manpower.

Thanks for caring about Okular :-)
Comment 3 Albert Astals Cid 2012-12-16 19:54:44 UTC
Git commit 55c413332e709750305e1eede1ef3b81e433d225 by Albert Astals Cid.
Committed on 16/12/2012 at 20:48.
Pushed by aacid into branch 'KDE/4.10'.

Don't ignore mouse movements on the annotator when not on the locked item

REVIEW: 107726
(cherry picked from commit 1ef6929344a423a837aa9fff56524706220def56)

M  +13   -14   ui/pageviewannotator.cpp

http://commits.kde.org/okular/55c413332e709750305e1eede1ef3b81e433d225
Comment 4 Jaan Vajakas 2012-12-23 09:07:44 UTC
Thank you!

I agree that reparation of the existing annotations is not important (they can be accessed via the Navigation Panel anyway).