Bug 310526 - Kmail crashed at launch
Summary: Kmail crashed at launch
Status: RESOLVED DUPLICATE of bug 310072
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-22 20:10 UTC by Giuseppe Mameli
Modified: 2012-11-22 20:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Mameli 2012-11-22 20:10:03 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-33-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed: I logged into my profile. Last applications used during logoff start at login and KMail was one of them. IMAP server is imap.tiscali.it and went off.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Giuseppe Mameli (Tiscali) di tipo Server di posta IMAP (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fea61f31780 (LWP 2538))]

Thread 2 (Thread 0x7fea4e81a700 (LWP 3228)):
#0  0x00007fea5d8c5303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fea5c410036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fea5c410164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fea61343426 in QEventDispatcherGlib::processEvents (this=0x7fea480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fea61312c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fea61312ed7 in QEventLoop::exec (this=0x7fea4e819de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fea61211fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fea5ff48c39 in KIMAP::SessionThread::run (this=0x24ad990) at ../../kimap/sessionthread.cpp:181
#8  0x00007fea61214fcb in QThreadPrivate::start (arg=0x24ad990) at thread/qthread_unix.cpp:298
#9  0x00007fea5cf2be9a in start_thread (arg=0x7fea4e81a700) at pthread_create.c:308
#10 0x00007fea5d8d0cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fea61f31780 (LWP 2538)):
[KCrash Handler]
#6  0x00007fea54314c90 in vtable for Oxygen::WidgetStateData () from /usr/lib/kde4/plugins/styles/oxygen.so
#7  0x00007fea61327b04 in QObject::disconnect (sender=0x24b5700, signal=0x24c3449 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x2462600, method=0x24e2ce9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2891
#8  0x0000000000454365 in SessionPool::killSession (this=0x2462600, session=0x24b5700, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:176
#9  0x0000000000454d67 in SessionPool::cancelSessionCreation (this=0x2462600, session=0x24b5700, errorCode=4, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:233
#10 0x0000000000455090 in SessionPool::onPasswordRequestDone (this=0x2462600, resultType=<optimized out>, password=...) at ../../../resources/imap/sessionpool.cpp:308
#11 0x0000000000456cd7 in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:94
#12 0x00007fea61328281 in QMetaObject::activate (sender=0x2462fe0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa62caeb0) at kernel/qobject.cpp:3547
#13 0x00000000004421c1 in PasswordRequesterInterface::done (this=<optimized out>, _t1=2, _t2=...) at ./passwordrequesterinterface.moc:118
#14 0x0000000000420d2a in SettingsPasswordRequester::askUserInput (this=0x2462fe0, serverError=...) at ../../../resources/imap/settingspasswordrequester.cpp:75
#15 0x00007fea6132d446 in QObject::event (this=0x2462fe0, e=<optimized out>) at kernel/qobject.cpp:1195
#16 0x00007fea60696894 in notify_helper (e=0x2481200, receiver=0x2462fe0, this=0x22b51c0) at kernel/qapplication.cpp:4559
#17 QApplicationPrivate::notify_helper (this=0x22b51c0, receiver=0x2462fe0, e=0x2481200) at kernel/qapplication.cpp:4531
#18 0x00007fea6069b713 in QApplication::notify (this=0x7fffa62cba70, receiver=0x2462fe0, e=0x2481200) at kernel/qapplication.cpp:4420
#19 0x00007fea5e7c03f6 in KApplication::notify (this=0x7fffa62cba70, receiver=0x2462fe0, event=0x2481200) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007fea61313e9c in QCoreApplication::notifyInternal (this=0x7fffa62cba70, receiver=0x2462fe0, event=0x2481200) at kernel/qcoreapplication.cpp:876
#21 0x00007fea61317c6a in sendEvent (event=0x2481200, receiver=0x2462fe0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x22874d0) at kernel/qcoreapplication.cpp:1500
#23 0x00007fea61342f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007fea5c40fd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fea5c4100a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fea5c410164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fea613433bf in QEventDispatcherGlib::processEvents (this=0x2288cb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00007fea6073ed5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007fea61312c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fea61312ed7 in QEventLoop::exec (this=0x7fffa62cb9f0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007fea61317f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x00007fea61a42326 in Akonadi::ResourceBase::init (r=0x243ff00) at ../../akonadi/resourcebase.cpp:412
#34 0x000000000041a996 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#35 0x00007fea5d7fe76d in __libc_start_main (main=0x4151c0 <main(int, char**)>, argc=3, ubp_av=0x7fffa62cbb88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa62cbb78) at libc-start.c:226
#36 0x0000000000415375 in _start ()

Possible duplicates by query: bug 310072, bug 305691.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-22 20:13:21 UTC

*** This bug has been marked as a duplicate of bug 310072 ***