Bug 310244 - kded blocks when selecting text in konsole
Summary: kded blocks when selecting text in konsole
Status: RESOLVED DUPLICATE of bug 307973
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: 4.9.3
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 13:38 UTC by Sandro Mani
Modified: 2012-11-17 20:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtraces and analysis (25.84 KB, text/plain)
2012-11-17 13:39 UTC, Sandro Mani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Mani 2012-11-17 13:38:49 UTC
The effect is the same as in bug 306338, but the cause appears to be different.

On the first login after boot, very often selecting text in console results in konsole hanging, which is due to the fact that kded blocks (with which konsole communicates through dbus). Appears to be related to the fact that the computer is behind a proxy and the cntlm daemon does not properly start on boot, see below.

My investigations of the issue so far seem to indicate that kded blocks as a result a dbus call to "org.kde.Solid.PowerManagement", "backendCapabilities", see attached backtraces and analysis. However, I didn't manage to get further than what I described in the attachment.

Reproducible: Sometimes

Steps to Reproduce:
1. Place computer behind proxy, set proxy in kconf network settings
2. Start pc, login, open konsole
3. Start a selection in konsole: With high probability, it will hang.



Some possibly relevant background: The affected computer is behind a ntlm proxy in the office. I have installed cntlm to get through that ugly beast, but for some reason reason (probably service trying to start before network is up), the service does not successfully start on boot, and I always have to manually restart it when I log in. This is relevant for the following observations: - if I log into kde without cntlm enabled, I konsole freezes when selection, plus many other applications (dolphin, rekonq, kfiledialog to name a few) take awfully long to start, and logout does not work.
- if I do init 3 followed by init 5 to restart the session, in the subsequent login everything works fine
- if I start cntlm from a vritual terminal before logging into kde, everything works fine The proxy is configured for all protocols in the respective kde control module.
Comment 1 Sandro Mani 2012-11-17 13:39:07 UTC
Created attachment 75312 [details]
Backtraces and analysis
Comment 2 Dawit Alemayehu 2012-11-17 20:23:20 UTC

*** This bug has been marked as a duplicate of bug 307973 ***