Bug 310224 - Crash when saving removals to list of cookie enabled/disabled websites
Summary: Crash when saving removals to list of cookie enabled/disabled websites
Status: RESOLVED DUPLICATE of bug 307831
Alias: None
Product: konqueror
Classification: Unclassified
Component: kcookiejar (show other bugs)
Version: 4.9.3
Platform: Archlinux Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-16 19:33 UTC by Christoph Berg
Modified: 2012-11-17 19:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Berg 2012-11-16 19:33:58 UTC
After removing one or more items from the list of websites, the KCM crashes when the dialog would be closed via pressing "Ok" or accepting the changes via "Accept".

Reproducible: Always

Steps to Reproduce:
1. Start Konqueror or reKonq
2. Choose "Configure Konqueror…"
3. Go to the Cookie configuration part
4. Remove an item from the list of websites
5. Press Accept or Ok
Actual Results:  
The application crashes presenting the attached backtrace.

Expected Results:  
List should be saved.

Application: KDE-Kontrollmodul (kcmshell4), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f4730a16444 in text (column=0, this=0x1ff0da0) at /usr/include/QtGui/qtreewidget.h:110
#7  KCookiesPolicies::save (this=0x21fa4f0) at /home/chrber/abs/kdebase/src/kde-baseapps-4.9.3/konqueror/settings/kio/kcookiespolicies.cpp:391
#8  0x00007f4730a140b1 in KCookiesMain::save (this=0x2200350) at /home/chrber/abs/kdebase/src/kde-baseapps-4.9.3/konqueror/settings/kio/kcookiesmain.cpp:70
#9  0x00007f474187e9e7 in KCModuleProxy::save (this=<optimized out>) at /home/chrber/abs/kdelibs/src/kdelibs-4.9.3/kutils/kcmoduleproxy.cpp:279
#10 0x00007f474187c360 in KCMultiDialogPrivate::apply (this=<optimized out>) at /home/chrber/abs/kdelibs/src/kdelibs-4.9.3/kutils/kcmultidialog.cpp:300
#11 0x00007f47407533df in QMetaObject::activate (sender=0x2192790, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#12 0x00007f47413989f7 in KDialog::slotButtonClicked (this=0x2192790, button=8) at /home/chrber/abs/kdelibs/src/kdelibs-4.9.3/kdeui/dialogs/kdialog.cpp:888
#13 0x00007f4741398f34 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /home/chrber/abs/kdelibs/src/build/kdeui/kdialog.moc:167
#14 KDialog::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /home/chrber/abs/kdelibs/src/build/kdeui/kdialog.moc:127
#15 0x00007f47407533df in QMetaObject::activate (sender=0x2192a50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9b675660) at kernel/qobject.cpp:3547
#16 0x00007f474075950e in QSignalMapper::mapped (this=this@entry=0x2192a50, _t1=8) at .moc/debug-shared/moc_qsignalmapper.cpp:115
#17 0x00007f4740759715 in QSignalMapper::map (this=0x2192a50, sender=0x21bc050) at kernel/qsignalmapper.cpp:266
#18 0x00007f47407533df in QMetaObject::activate (sender=0x21bc050, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9b6757f0) at kernel/qobject.cpp:3547
#19 0x00007f4740111d32 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/debug-shared/moc_qabstractbutton.cpp:220
#20 0x00007f473fe1ecae in QAbstractButtonPrivate::emitClicked (this=this@entry=0x21bea80) at widgets/qabstractbutton.cpp:548
#21 0x00007f473fe1f570 in QAbstractButtonPrivate::click (this=this@entry=0x21bea80) at widgets/qabstractbutton.cpp:541
#22 0x00007f473fe1f7dc in QAbstractButton::mouseReleaseEvent (this=0x21bc050, e=0x7fff9b6760a0) at widgets/qabstractbutton.cpp:1123
#23 0x00007f473fa6a5c9 in QWidget::event (this=0x21bc050, event=0x7fff9b6760a0) at kernel/qwidget.cpp:8371
#24 0x00007f473fa12311 in QApplicationPrivate::notify_helper (this=this@entry=0x1f67e60, receiver=receiver@entry=0x21bc050, e=e@entry=0x7fff9b6760a0) at kernel/qapplication.cpp:4557
#25 0x00007f473fa17d74 in QApplication::notify (this=<optimized out>, receiver=0x21bc050, e=0x7fff9b6760a0) at kernel/qapplication.cpp:4100
#26 0x00007f4741437df6 in KApplication::notify (this=0x7fff9b676e90, receiver=0x21bc050, event=0x7fff9b6760a0) at /home/chrber/abs/kdelibs/src/kdelibs-4.9.3/kdeui/kernel/kapplication.cpp:311
#27 0x00007f474073bd3e in QCoreApplication::notifyInternal (this=0x7fff9b676e90, receiver=0x21bc050, event=0x7fff9b6760a0) at kernel/qcoreapplication.cpp:915
#28 0x00007f473fa13712 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#29 QApplicationPrivate::sendMouseEvent (receiver=0x21bc050, event=0x7fff9b6760a0, alienWidget=0x21bc050, nativeWidget=0x2192790, buttonDown=0x7f47405b1368 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3168
#30 0x00007f473fa998fe in QETWidget::translateMouseEvent (this=this@entry=0x2192790, event=event@entry=0x7fff9b676810) at kernel/qapplication_x11.cpp:4507
#31 0x00007f473fa98671 in QApplication::x11ProcessEvent (this=0x7fff9b676e90, event=0x7fff9b676810) at kernel/qapplication_x11.cpp:3630
#32 0x00007f473fac01b2 in x11EventSourceDispatch (s=0x1f67ca0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#33 0x00007f473c25d845 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#34 0x00007f473c25db78 in ?? () from /usr/lib/libglib-2.0.so.0
#35 0x00007f473c25dc34 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#36 0x00007f474076d2a6 in QEventDispatcherGlib::processEvents (this=0x1f1d770, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#37 0x00007f473fabfe1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f474073a27f in QEventLoop::processEvents (this=this@entry=0x7fff9b676bf0, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f474073a4d8 in QEventLoop::exec (this=0x7fff9b676bf0, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f473ff30788 in QDialog::exec (this=0x2192790) at dialogs/qdialog.cpp:554
#41 0x00007f4741e4bb4c in kdemain () from /usr/lib/libkdeinit4_kcmshell4.so
#42 0x00007f4741abe725 in __libc_start_main () from /usr/lib/libc.so.6
#43 0x0000000000400711 in _start ()
Comment 1 Dawit Alemayehu 2012-11-17 19:15:41 UTC

*** This bug has been marked as a duplicate of bug 307831 ***