Bug 310173 - Age limit option for calendar items
Summary: Age limit option for calendar items
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Google Resource (show other bugs)
Version: 4.9
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-15 20:49 UTC by km
Modified: 2013-03-14 19:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description km 2012-11-15 20:49:24 UTC
Please add an option to only fetch calendar items whose end-date is later than X months back from now. Usually there is no need to have events that are few years old locally.

Reproducible: Always
Comment 1 Daniel Vrátil 2013-03-14 19:51:28 UTC
Git commit e427b25088aab13d57792e8562dcc7cb97500ea9 by Dan Vrátil.
Committed on 14/03/2013 at 20:50.
Pushed by dvratil into branch 'master'.

Age limit option for items in Google Calendar

Fetch only events that occur after a specified date. The default
time span is three years. This filter does not take in account
recurrent events that have started before the set date (they
will be included nontheless).
FIXED-IN: 4.11
GUI:

M  +5    -0    resources/google/calendar/calendarresource.cpp
M  +2    -6    resources/google/calendar/settingsbase.kcfg
M  +25   -0    resources/google/calendar/settingsdialog.cpp
M  +4    -0    resources/google/calendar/settingsdialog.h

http://commits.kde.org/kdepim-runtime/e427b25088aab13d57792e8562dcc7cb97500ea9