Bug 310066 - KOrganizer allows to create invalid events (without dtstart)
Summary: KOrganizer allows to create invalid events (without dtstart)
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: incidence editors (show other bugs)
Version: GIT (master)
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sergio Martins
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-14 00:06 UTC by Christian Mollekopf
Modified: 2012-11-14 10:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Mollekopf 2012-11-14 00:06:44 UTC
If the one clears the start date of an event in the incidenceeditor, it's still possible to save the event, resulting in an event without dtstart. This is invalid according to the RFC 5545, although it is not explicitly forbidden in rfc2445 (the predecessor rfc).
Since I generally think we should comply to RFC5545, and the event is anyways not accessible from Korganizer anymore once it has no dtstart (at least I don't know how), this should be fixed IMO by validating the event before saving (in the editor).

Reproducible: Always

Steps to Reproduce:
1. Create new event
2. remove dtstart
3. save
Actual Results:  
event without dtstart

Expected Results:  
Error dialog
Comment 1 Sergio Martins 2012-11-14 10:46:43 UTC
Git commit 447806f1b2c1a0ee8f703c220911661df88ec1b7 by Sergio Martins.
Committed on 14/11/2012 at 11:43.
Pushed by smartins into branch 'KDE/4.9'.

Don't allow invalid end and start times.
FIXED-IN: 4.9.4

M  +12   -0    incidenceeditor-ng/incidencedatetime.cpp

http://commits.kde.org/kdepim/447806f1b2c1a0ee8f703c220911661df88ec1b7