Bug 309845 - Crashed when try to import project from network (KDE Project)
Summary: Crashed when try to import project from network (KDE Project)
Status: RESOLVED DUPLICATE of bug 278252
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3.1
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 4.3.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-10 09:07 UTC by Fabian
Modified: 2012-11-11 12:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2012-11-10 09:07:06 UTC
Application: kdevelop (4.3.1)
KDE Platform Version: 4.9.3 "release 520"
Qt Version: 4.8.3
Operating System: Linux 3.4.11-2.16-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Trying to import a project from kde (plasma-mediacenter)

It crashed every time I tried.

https://bugs.kde.org/show_bug.cgi?id=278252
seems to be very similar, but that bug was closed 2011-08-09 08:21:01 UTC . Even so there too is one new crash report including a backtrace on a recent version of KDE Platform and Kdevelop

The crash can be reproduced every time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd02d23b780 (LWP 14104))]

Thread 5 (Thread 0x7fd014b94700 (LWP 14105)):
#0  0x00007fd02a101c61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd02b6f6457 in wait (time=1000, this=0x22be7b0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22c66d0, time=1000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fd027850dcb in KDevelop::DUChainPrivate::CleanupThread::run (this=0x22c66b0) at /usr/src/debug/kdevplatform-1.3.1/language/duchain/duchain.cpp:282
#4  0x00007fd02b6f5f9c in QThreadPrivate::start (arg=0x22c66b0) at thread/qthread_unix.cpp:338
#5  0x00007fd02a0fde0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007fd02a3f62bd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fcffbfff700 (LWP 14113)):
#0  0x00007fd02a3ee13f in poll () from /lib64/libc.so.6
#1  0x00007fd024ec6684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fd024ec67a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fd02b81fcf6 in QEventDispatcherGlib::processEvents (this=0x7fcff40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fd02b7f085f in QEventLoop::processEvents (this=this@entry=0x7fcffbffedd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd02b7f0ae8 in QEventLoop::exec (this=0x7fcffbffedd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fd02b6f2fc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fd02b7d0fcf in QInotifyFileSystemWatcherEngine::run (this=0x3d035d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd02b6f5f9c in QThreadPrivate::start (arg=0x3d035d0) at thread/qthread_unix.cpp:338
#9  0x00007fd02a0fde0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007fd02a3f62bd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fcffb7fe700 (LWP 14179)):
#0  0x00007fd02a1018f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd021bc7eb7 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fd021bc7ee9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fd02a0fde0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007fd02a3f62bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fcffaffd700 (LWP 14180)):
#0  0x00007fd02a402b37 in pthread_mutex_unlock () from /lib64/libc.so.6
#1  0x00007fd024f024a1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fd024ec5876 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fd024ec6564 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fd024ec67a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fd02b81fcf6 in QEventDispatcherGlib::processEvents (this=0x7fcfec002900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fd02b7f085f in QEventLoop::processEvents (this=this@entry=0x7fcffaffce00, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fd02b7f0ae8 in QEventLoop::exec (this=0x7fcffaffce00, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fd02b6f2fc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fd02b6f5f9c in QThreadPrivate::start (arg=0x40e9550) at thread/qthread_unix.cpp:338
#10 0x00007fd02a0fde0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007fd02a3f62bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fd02d23b780 (LWP 14104)):
[KCrash Handler]
#5  QList (l=<error reading variable: Cannot access memory at address 0x20>, this=0x7fffc5edfe60) at /usr/include/QtCore/qlist.h:122
#6  QStringList (l=<error reading variable: Cannot access memory at address 0x20>, this=0x7fffc5edfe60) at /usr/include/QtCore/qstringlist.h:71
#7  KDevelop::IPlugin::extensions (this=0x0) at /usr/src/debug/kdevplatform-1.3.1/interfaces/iplugin.cpp:155
#8  0x00007fd008378c1d in extension<KDevelop::IBasicVersionControl> (this=0x0) at /usr/include/kdevplatform/interfaces/iplugin.h:183
#9  KDEProviderWidget::createWorkingCopy (this=<optimized out>, destinationDirectory=...) at /usr/src/debug/kdevelop-4.3.1/providers/kdeprovider/kdeproviderwidget.cpp:98
#10 0x00007fd02c7355af in KDevelop::ProjectSourcePage::jobPerCurrent (this=this@entry=0x49a4e20) at /usr/src/debug/kdevplatform-1.3.1/shell/projectsourcepage.cpp:125
#11 0x00007fd02c73563d in KDevelop::ProjectSourcePage::getVcsProject (this=0x49a4e20) at /usr/src/debug/kdevplatform-1.3.1/shell/projectsourcepage.cpp:143
#12 0x00007fd02b80839f in QMetaObject::activate (sender=0x49adfd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc5ee0130) at kernel/qobject.cpp:3556
#13 0x00007fd02b200a82 in QAbstractButton::clicked (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:220
#14 0x00007fd02af5582e in QAbstractButtonPrivate::emitClicked (this=this@entry=0x49ae000) at widgets/qabstractbutton.cpp:548
#15 0x00007fd02af56060 in QAbstractButtonPrivate::click (this=this@entry=0x49ae000) at widgets/qabstractbutton.cpp:541
#16 0x00007fd02af562cc in QAbstractButton::mouseReleaseEvent (this=0x49adfd0, e=0x7fffc5ee09d0) at widgets/qabstractbutton.cpp:1123
#17 0x00007fd02abebed0 in QWidget::event (this=0x49adfd0, event=0x7fffc5ee09d0) at kernel/qwidget.cpp:8371
#18 0x00007fd02ab9c74c in QApplicationPrivate::notify_helper (this=this@entry=0x1e587e0, receiver=receiver@entry=0x49adfd0, e=e@entry=0x7fffc5ee09d0) at kernel/qapplication.cpp:4557
#19 0x00007fd02aba142b in QApplication::notify (this=<optimized out>, receiver=0x49adfd0, e=0x7fffc5ee09d0) at kernel/qapplication.cpp:4100
#20 0x00007fd02c002616 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#21 0x00007fd02b7f1b0e in QCoreApplication::notifyInternal (this=0x7fffc5ee3580, receiver=0x49adfd0, event=0x7fffc5ee09d0) at kernel/qcoreapplication.cpp:915
#22 0x00007fd02ab9d58b in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#23 QApplicationPrivate::sendMouseEvent (receiver=0x49adfd0, event=0x7fffc5ee09d0, alienWidget=0x0, nativeWidget=0x49adfd0, buttonDown=0x7fd02b670248 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3168
#24 0x00007fd02ac17d14 in QETWidget::translateMouseEvent (this=this@entry=0x49adfd0, event=event@entry=0x7fffc5ee1140) at kernel/qapplication_x11.cpp:4518
#25 0x00007fd02ac16aa1 in QApplication::x11ProcessEvent (this=0x7fffc5ee3580, event=0x7fffc5ee1140) at kernel/qapplication_x11.cpp:3641
#26 0x00007fd02ac3cde2 in x11EventSourceDispatch (s=0x1e559c0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#27 0x00007fd024ec63b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fd024ec66e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fd024ec67a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#30 0x00007fd02b81fcf6 in QEventDispatcherGlib::processEvents (this=0x1e26ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#31 0x00007fd02ac3ca5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fd02b7f085f in QEventLoop::processEvents (this=this@entry=0x7fffc5ee1520, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fd02b7f0ae8 in QEventLoop::exec (this=0x7fffc5ee1520, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fd02b04feb8 in QDialog::exec (this=0x7fffc5ee16e0) at dialogs/qdialog.cpp:554
#35 0x00007fd02c6dd5a7 in KDevelop::ProjectDialogProvider::askProjectConfigLocation (this=0x2111d90, fetch=fetch@entry=true, startUrl=...) at /usr/src/debug/kdevplatform-1.3.1/shell/projectcontroller.cpp:331
#36 0x00007fd02c6defa9 in KDevelop::ProjectController::fetchProject (this=0x217d730) at /usr/src/debug/kdevplatform-1.3.1/shell/projectcontroller.cpp:689
#37 0x00007fd02c6dfd59 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdevplatform-1.3.1/build/shell/projectcontroller.moc:165
#38 KDevelop::ProjectController::qt_static_metacall (_o=0x217d730, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdevplatform-1.3.1/build/shell/projectcontroller.moc:158
#39 0x00007fd02b80839f in QMetaObject::activate (sender=0x210de90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc5ee1970) at kernel/qobject.cpp:3556
#40 0x00007fd02ab96542 in QAction::triggered (this=this@entry=0x210de90, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#41 0x00007fd02ab96730 in QAction::activate (this=0x210de90, event=<optimized out>) at kernel/qaction.cpp:1257
#42 0x00007fd02afcfdc3 in QMenuPrivate::activateCausedStack (this=this@entry=0x225a970, causedStack=..., action=action@entry=0x210de90, action_e=action_e@entry=QAction::Trigger, self=self@entry=true) at widgets/qmenu.cpp:1028
#43 0x00007fd02afd60d9 in QMenuPrivate::activateAction (this=0x225a970, action=0x210de90, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#44 0x00007fd02c0bb7c0 in KMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib64/libkdeui.so.5
#45 0x00007fd02abebed0 in QWidget::event (this=0x225c390, event=0x7fffc5ee2510) at kernel/qwidget.cpp:8371
#46 0x00007fd02afd738b in QMenu::event (this=0x225c390, e=0x7fffc5ee2510) at widgets/qmenu.cpp:2469
#47 0x00007fd02ab9c74c in QApplicationPrivate::notify_helper (this=this@entry=0x1e587e0, receiver=receiver@entry=0x225c390, e=e@entry=0x7fffc5ee2510) at kernel/qapplication.cpp:4557
#48 0x00007fd02aba142b in QApplication::notify (this=<optimized out>, receiver=0x225c390, e=0x7fffc5ee2510) at kernel/qapplication.cpp:4100
#49 0x00007fd02c002616 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#50 0x00007fd02b7f1b0e in QCoreApplication::notifyInternal (this=0x7fffc5ee3580, receiver=0x225c390, event=0x7fffc5ee2510) at kernel/qcoreapplication.cpp:915
#51 0x00007fd02ab9d58b in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#52 QApplicationPrivate::sendMouseEvent (receiver=0x225c390, event=0x7fffc5ee2510, alienWidget=0x0, nativeWidget=0x225c390, buttonDown=0x7fd02b670248 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3168
#53 0x00007fd02ac17bdc in QETWidget::translateMouseEvent (this=this@entry=0x225c390, event=event@entry=0x7fffc5ee2c80) at kernel/qapplication_x11.cpp:4452
#54 0x00007fd02ac16aa1 in QApplication::x11ProcessEvent (this=0x7fffc5ee3580, event=0x7fffc5ee2c80) at kernel/qapplication_x11.cpp:3641
#55 0x00007fd02ac3cde2 in x11EventSourceDispatch (s=0x1e559c0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0x00007fd024ec63b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#57 0x00007fd024ec66e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#58 0x00007fd024ec67a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#59 0x00007fd02b81fcd6 in QEventDispatcherGlib::processEvents (this=0x1e26ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#60 0x00007fd02ac3ca5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x00007fd02b7f085f in QEventLoop::processEvents (this=this@entry=0x7fffc5ee3050, flags=...) at kernel/qeventloop.cpp:149
#62 0x00007fd02b7f0ae8 in QEventLoop::exec (this=0x7fffc5ee3050, flags=...) at kernel/qeventloop.cpp:204
#63 0x00007fd02b7f5788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#64 0x0000000000409b88 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdevelop-4.3.1/app/main.cpp:479

Possible duplicates by query: bug 278252.

Reported using DrKonqi
Comment 1 Milian Wolff 2012-11-11 12:29:46 UTC

*** This bug has been marked as a duplicate of bug 278252 ***