Bug 309839 - system settings : common appearance and behavior -> locale -> country/region and language -> select a money tab (I set country to Hungary) and there decimal places set to 4/7/12 (or maybe to any other), apply and the desktop crashes :( I tried 2-3 times,
Summary: system settings : common appearance and behavior -> locale -> country/region ...
Status: RESOLVED DUPLICATE of bug 299237
Alias: None
Product: plasma4
Classification: Plasma
Component: desktop (show other bugs)
Version: 4.8.3
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-10 06:29 UTC by Nyilas MISY
Modified: 2012-11-10 13:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nyilas MISY 2012-11-10 06:29:55 UTC
system settings : common appearance and behavior -> locale -> country/region and language -> select a money tab (I set country to Hungary) and there decimal places set to 4/7/12 (or maybe to any other), apply and the desktop crashes :( I tried 2-3 times, and every times happened..
I using PCLinuxOS KDE4 FullMonty 2012.09, without update

Reproducible: Always
Comment 1 Jekyll Wu 2012-11-10 06:56:33 UTC
When something has crashed, please always try to provide a backtrace.

And please paste the backtrace in comment . Do not attach it.
Comment 2 Christoph Feck 2012-11-10 09:21:18 UTC
For more information, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 3 Nyilas MISY 2012-11-10 10:46:23 UTC
(In reply to comment #0)
> system settings : common appearance and behavior -> locale -> country/region
> and language -> select a money tab (I set country to Hungary) and there
> decimal places set to 4/7/12 (or maybe to any other), apply and the desktop
> crashes :( I tried 2-3 times, and every times happened..
> I using PCLinuxOS KDE4 FullMonty 2012.09, without update
> 
> Reproducible: Always



Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.2
Operating System: Linux 3.2.18-pclos2.bfs i686
Distribution: "PCLinuxOS"

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

The crash can be reproduced every time.

-- Backtrace:
A useful backtrace could not be generated

Report to https://bugs.kde.org

Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[Current thread is 1 (Thread 0xb52646e0 (LWP 3563))]

Thread 2 (Thread 0xa6f72b70 (LWP 3577)):
#0  0xb772e424 in __kernel_vsyscall ()
#1  0xb6b1402c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb1c3f687 in ?? () from /usr/lib/libQtScript.so.4
#3  0xb1c3f6d1 in ?? () from /usr/lib/libQtScript.so.4
#4  0xb0bff0e1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#5  0x5c8b0824 in ?? ()
#6  0xbab80424 in ?? ()
#7  0x65000000 in ?? ()
#8  0x001015ff in ?? ()
#9  0xd3890000 in ?? ()
#10 0xfff0013d in ?? ()
#11 0xc30173ff in ?? ()
#12 0x0e98f1e8 in ?? ()
#13 0xdfc18100 in ?? ()
#14 0x8b001391 in ?? ()
#15 0xffff0889 in ?? ()
#16 0x29d231ff in ?? ()
#17 0x0d0365c2 in ?? ()
#18 0x00000000 in ?? ()

Thread 1 (Thread 0xb52646e0 (LWP 3563)):
[KCrash Handler]
#7  0x0ad0d539 in ?? ()
#8  0x00000000 in ?? ()
Comment 4 Nyilas MISY 2012-11-10 10:54:55 UTC
http://dabzse.x90x.net/upld/bug-001.png
Comment 5 Christoph Feck 2012-11-10 12:35:19 UTC
Resolved in KDE 4.9, please update.

*** This bug has been marked as a duplicate of bug 299237 ***
Comment 6 Nyilas MISY 2012-11-10 12:49:07 UTC
only update can fix it?
PCLinuxOS : Synaptic, and a full KDE update? or which component?
Comment 7 Nyilas MISY 2012-11-10 12:52:43 UTC
2012/11/10 Christoph Feck <christoph@maxiom.de>:
> https://bugs.kde.org/show_bug.cgi?id=309839
>
> Christoph Feck <christoph@maxiom.de> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|NEEDSINFO                   |RESOLVED
>                  CC|                            |christoph@maxiom.de
>          Resolution|BACKTRACE                   |DUPLICATE
>
> --- Comment #5 from Christoph Feck <christoph@maxiom.de> ---
> Resolved in KDE 4.9, please update.
>
> *** This bug has been marked as a duplicate of bug 299237 ***
>
> --
> You are receiving this mail because:
> You reported the bug.

I see it.. nothing anything can fix it? :/
so, if I again reinstall the os, then again update the KDE :(
yesterday I reinstalled, because I can't fix it, and how I know, in
this year I need again to reinstall :D
thx a lot :-)
Comment 8 Christoph Feck 2012-11-10 13:10:15 UTC
You only need to update KDE. Distributions usually offer update repositories (so called "backports"), those will automatically pull in any new dependencies.

Please ask in a forum for your distribution how to update to KDE 4.9.3.
Comment 9 Nyilas MISY 2012-11-10 13:37:21 UTC
PCLinuxOS repository :
installed version : 4.8.3-1pclos2012, 4.8.3-2pclos2012, 4.8.3-3pclos2012, 4.8.3-4pclos2012, 4.8.3-5pclos2012, 4.8.3-5pclos2012; (this is 4.8.3, with pclos revisions, how I know)
latest version : 4.9.2-1_archie_201
which component(s) needs to be updated? all?