Bug 309784 - KATE crashes when cutting/pasting/typing
Summary: KATE crashes when cutting/pasting/typing
Status: RESOLVED DUPLICATE of bug 294241
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-09 00:36 UTC by Malcolm Smith
Modified: 2013-03-23 15:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malcolm Smith 2012-11-09 00:36:56 UTC
Application: kate (3.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.2
Operating System: Linux 3.6-5.slh.3-aptosid-686 i686
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Cutting/pasting/typing/deleting text within KATE sometimes kills the whole program. Luckily she's always managed to Recover the last edits. Weirdly, repeating the same edit (after recovering) doesn't crash, so it seems random and not repeatable, just keeps happening every few days - sometimes a few times in succession at random moments, other times just once in a while.

BTW, I read all the other related bugs that the Crash Reporting Assitant suggested, and while this is quite close to some, it has nothing to do with Code Folding.

Other programs running: Iceweasel with lotsa tabs (no flash installed, just Gnash but no heavy videos in use), Rox-Filer, Terminal, and usually 4+ KATE instances each with 20-ish documents open. I live in KATE, and she runs my entire life+business! :-) This is in fluxbox on Debian/Aptosid (not xfce as mentioned below).

Host/Kernel/OS  "trancefer" running Linux 3.6-5.slh.3-aptosid-686 i686 [ aptosid 2011-02 Ἡμέρα - xfce - (201107131632) ]
CPU Info        Intel Pentium 4 1024 KB cache flags( sse3 ht ) clocked at [ 2932.121 MHz ]
Videocard       Intel 82915G/GV/910GL Integrated Graphics Controller  X.Org 1.12.4  [ 1280x1024@60.0hz ]
Network cards   D-Link System DGE-528T Gigabit Ethernet Adapter, at port: e800 
Processes 138 | Uptime 8:03 | Memory 1125.4/2525.9MB | HDD M4-CT064M4SSD2,SAMSUNG HD204UI Size 2064GB (58%used) | Client Shell | Infobash v3.45

- Custom settings of the application:

I often use Other->Diff Highlighting mode for some of my text documents, not because they are diffs, but purely for the nice colourscheme :-) The crashes seem to happen to these kind of files, but might not just be limited to them. I'd offer to submit an example text file, but many contain personal data or are huge, and the bug seems unrepeatable anyway so I don't think it would help much. After seeing the bug quite a lot I installed kate-dbg to hopefully give you better info.

P.S. KATE rocks! Even in her slightly borken state ;-)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/i686/cmov/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4dab930 (LWP 2901))]

Thread 3 (Thread 0xb1821b70 (LWP 2987)):
#0  0xb5e3c48c in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb5e17b3f in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb61d285f in QEventDispatcherGlib::processEvents (this=0x8a3c810, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#3  0xb619f02c in QEventLoop::processEvents (this=this@entry=0xb18212a8, flags=...) at kernel/qeventloop.cpp:149
#4  0xb619f321 in QEventLoop::exec (this=0xb18212a8, flags=...) at kernel/qeventloop.cpp:204
#5  0xb608bb3c in QThread::exec (this=0x8a2a4e0) at thread/qthread.cpp:501
#6  0xb617d77d in QInotifyFileSystemWatcherEngine::run (this=0x8a2a4e0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0xb608ef00 in QThreadPrivate::start (arg=0x8a2a4e0) at thread/qthread_unix.cpp:307
#8  0xb5eebc39 in start_thread () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#9  0xb76f57be in clone () from /lib/i386-linux-gnu/i686/cmov/libc.so.6

Thread 2 (Thread 0xb0f21b70 (LWP 3135)):
#0  0xb77a8424 in __kernel_vsyscall ()
#1  0xb5ef020a in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#2  0xb77028ad in pthread_cond_wait () from /lib/i386-linux-gnu/i686/cmov/libc.so.6
#3  0xb1b5319d in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb1b531cf in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb5eebc39 in start_thread () from /lib/i386-linux-gnu/i686/cmov/libpthread.so.0
#6  0xb76f57be in clone () from /lib/i386-linux-gnu/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4dab930 (LWP 2901)):
[KCrash Handler]
#7  getStartMatching (endNode=0x8fb3350, this=0x8f36570) at ../../part/syntax/katecodefolding.cpp:151
#8  KateCodeFoldingTree::getLineInfo (this=0x87e8bc8, info=0xbfcc485c, line=1117) at ../../part/syntax/katecodefolding.cpp:1020
#9  0xb1d68566 in lineInfo (line=1117, info=0xbfcc485c, this=<optimized out>) at ../../part/document/katebuffer.h:187
#10 KateDocument::lineInfo (this=0x87e8728, info=0xbfcc485c, line=1117) at ../../part/document/katedocument.cpp:4041
#11 0xb1e21e43 in KateIconBorder::paintBorder (this=this@entry=0x8e37f28, y=y@entry=585, height=30) at ../../part/view/kateviewhelpers.cpp:1040
#12 0xb1e22a8a in KateIconBorder::paintEvent (this=0x8e37f28, e=0xbfcc4fdc) at ../../part/view/kateviewhelpers.cpp:955
#13 0xb6ce1ba4 in QWidget::event (this=0x8e37f28, event=0xbfcc4fdc) at kernel/qwidget.cpp:8517
#14 0xb6c8847c in QApplicationPrivate::notify_helper (this=0x85bbfb8, receiver=0x8e37f28, e=0xbfcc4fdc) at kernel/qapplication.cpp:4556
#15 0xb6c8cf24 in QApplication::notify (this=0x85bbfb8, receiver=0x8e37f28, e=0xbfcc4fdc) at kernel/qapplication.cpp:4417
#16 0xb658c6b1 in KApplication::notify (this=0xbfcc764c, receiver=0x8e37f28, event=0xbfcc4fdc) at ../../kdeui/kernel/kapplication.cpp:311
#17 0xb61a055e in QCoreApplication::notifyInternal (this=0xbfcc764c, receiver=0x8e37f28, event=0xbfcc4fdc) at kernel/qcoreapplication.cpp:915
#18 0xb6cdd423 in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#19 QWidgetPrivate::drawWidget (this=0x8e37fc0, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5594
#20 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x8e372a8, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#21 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x8e372a8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#22 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x890f338, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#23 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x890f338, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#24 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x890f0a8, pdev=pdev@entry=0x8bc2618, siblings=..., index=<optimized out>, index@entry=1, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x8906818) at kernel/qwidget.cpp:5803
#25 0xb6cddda2 in QWidgetPrivate::paintSiblingsRecursive (this=0x890f0a8, pdev=0x8bc2618, siblings=..., index=1, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5790
#26 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x890f0a8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#27 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x890acf8, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#28 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x890acf8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#29 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x8904560, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#30 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x8904560, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#31 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x8903ee8, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#32 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x8903ee8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#33 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x89031a8, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#34 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x89031a8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#35 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x8901fa8, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#36 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x8901fa8, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#37 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x88fb980, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#38 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x88fb980, pdev=0x8bc2618, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#39 0xb6cddf5a in QWidgetPrivate::paintSiblingsRecursive (this=0x87fbd70, pdev=0x8bc2618, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5803
#40 0xb6cdcf5d in QWidgetPrivate::drawWidget (this=0x87fbd70, pdev=0x8bc2618, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8906818) at kernel/qwidget.cpp:5647
#41 0xb6ed3b96 in QWidgetBackingStore::sync (this=0x8906818) at painting/qbackingstore.cpp:1373
#42 0xb6cd0f2b in QWidgetPrivate::syncBackingStore (this=0x87fbd70) at kernel/qwidget.cpp:1892
#43 0xb6ce221f in QWidget::event (this=0x87fe170, event=0x8f2b558) at kernel/qwidget.cpp:8664
#44 0xb710ff1c in QMainWindow::event (this=0x87fe170, event=0x8f2b558) at widgets/qmainwindow.cpp:1478
#45 0xb6661ca4 in KMainWindow::event (this=0x87fe170, ev=0x8f2b558) at ../../kdeui/widgets/kmainwindow.cpp:1084
#46 0xb66a8ca2 in KXmlGuiWindow::event (this=0x87fe170, ev=0x8f2b558) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#47 0xb6c8847c in QApplicationPrivate::notify_helper (this=0x85bbfb8, receiver=0x87fe170, e=0x8f2b558) at kernel/qapplication.cpp:4556
#48 0xb6c8cf24 in QApplication::notify (this=0x85bbfb8, receiver=0x87fe170, e=0x8f2b558) at kernel/qapplication.cpp:4417
#49 0xb658c6b1 in KApplication::notify (this=0xbfcc764c, receiver=0x87fe170, event=0x8f2b558) at ../../kdeui/kernel/kapplication.cpp:311
#50 0xb61a055e in QCoreApplication::notifyInternal (this=0xbfcc764c, receiver=0x87fe170, event=0x8f2b558) at kernel/qcoreapplication.cpp:915
#51 0xb61a476d in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8593370) at kernel/qcoreapplication.cpp:1539
#53 0xb61a49ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1432
#54 0xb61d26c4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#55 postEventSourceDispatch (s=0x85bbdf8) at kernel/qeventdispatcher_glib.cpp:279
#56 0xb5e176d3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#57 0xb5e17a70 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0xb5e17b51 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0xb61d2841 in QEventDispatcherGlib::processEvents (this=0x8593f08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#60 0xb6d3b1fa in QGuiEventDispatcherGlib::processEvents (this=0x8593f08, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0xb619f02c in QEventLoop::processEvents (this=this@entry=0xbfcc7428, flags=...) at kernel/qeventloop.cpp:149
#62 0xb619f321 in QEventLoop::exec (this=0xbfcc7428, flags=...) at kernel/qeventloop.cpp:204
#63 0xb61a4a9a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#64 0xb6c862f4 in QApplication::exec () at kernel/qapplication.cpp:3817
#65 0xb77a0655 in kdemain (argc=3, argv=0xbfcc7764) at ../../../kate/app/katemain.cpp:377
#66 0x080485fb in main (argc=3, argv=0xbfcc7764) at kate_dummy.cpp:3

Possible duplicates by query: bug 308139, bug 306369, bug 297317, bug 297261, bug 296177.

Reported using DrKonqi
Comment 1 Christoph Cullmann 2012-11-09 19:46:24 UTC
We had some fixes to the folding which caused the crash here, see:

 getStartMatching (endNode=0x8fb3350, this=0x8f36570) at ../../part/syntax/katecodefolding.cpp:151

Could you retry with kate.git master, as shown on kate-editor.org/get-it?
Or provide some example to let us reproduce it?

Thanks a lot!
Sorry for the problem :(
Comment 2 Dominik Haumann 2013-03-23 15:32:41 UTC

*** This bug has been marked as a duplicate of bug 294241 ***