Bug 309774 - CSV Plugin - Wishlist: Ability to copy an investment activity type or detail/description to memo field.
Summary: CSV Plugin - Wishlist: Ability to copy an investment activity type or detail/...
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: git (master)
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-08 21:38 UTC by allan
Modified: 2012-11-10 13:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description allan 2012-11-08 21:38:06 UTC
A while ago, I added a similar feature for non-investment transactions, to be able to copy the payee field of a CSV file to the memo field.  At that time, I didn't see a need for a similar facility with investment transactions.  Since then, however, I've found myself having to copy/paste from the activity type field, or the description/detail field to the memo field.  Sometimes, there may be no suitable type field, but the needed type may be present in a description field, and this can be extracted to use as the activity type, but there can be other data in that field which does not get imported.
So, I've now implemented this, mainly in investprocessing.cpp.  However, I've also made a few changes in csvdialog.cpp, in order to keep some measure of similarity between the two main object files.
Tested with many different format files.


Reproducible: Always
Comment 1 allan 2012-11-10 13:17:19 UTC
Git commit eaf56f886f2c127c2624f8571cf6107215adcc9f by Allan Anderson.
Committed on 08/11/2012 at 23:36.
Pushed by allananderson into branch 'master'.

M  +85   -54   kmymoney/plugins/csvimport/csvdialog.cpp
M  +2    -1    kmymoney/plugins/csvimport/csvdialog.h
M  +1    -3    kmymoney/plugins/csvimport/csvutil.cpp
M  +6    -6    kmymoney/plugins/csvimport/investmentwizardpage.ui
M  +133  -42   kmymoney/plugins/csvimport/investprocessing.cpp
M  +7    -3    kmymoney/plugins/csvimport/investprocessing.h
M  +3    -3    kmymoney/plugins/csvimport/redefinedlg.cpp
M  +1    -1    kmymoney/plugins/csvimport/redefinedlgdecl.ui

http://commits.kde.org/kmymoney/eaf56f886f2c127c2624f8571cf6107215adcc9f