Bug 309541 - Startup feedback effect leaves traces on the screen
Summary: Startup feedback effect leaves traces on the screen
Status: RESOLVED DUPLICATE of bug 260727
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 4.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-04 17:27 UTC by Ralf Jung
Modified: 2012-11-04 17:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2012-11-04 17:27:28 UTC
I have startup feedback set to "Passive busy cursor". When an application starts and the cursor appears for a few seconds, if I move the mouse, the icon attached to the cursor leaves traces on the screen.

Reproducible: Always

Steps to Reproduce:
1. Set launch feedback to "Passive busy cursor"
2. Enable the "Startup feedback" KWin effect
3. Start Firefox or Thunderbird (or anything else which takes a few seconds until the icon disappears)
4. Move the cursor
Actual Results:  
The startup feedback icon leaves traces on the screen.

Expected Results:  
There should be no glitches.

Everything looks all right if I disable the effect in KWin, or if I disable compositing.

If I use the "Blinking cursor", I get no traces, but the blinking icon is clipped instead of being displayed in its complete size - the damage area doesn't seem to be all right either.
Comment 1 Thomas Lübking 2012-11-04 17:41:04 UTC

*** This bug has been marked as a duplicate of bug 260727 ***