Bug 309465 - Failed to load image for XCF files
Summary: Failed to load image for XCF files
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-DImg-QImage (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-03 09:36 UTC by rtalbot
Modified: 2020-05-09 12:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rtalbot 2012-11-03 09:36:18 UTC
I just upgraded to Xubuntu 12.04 from 10.04, which upgraded my digiKam to 2.5, and now my album view won't render XCF files.  I don't recall which version of digiKam ran in Xubuntu 10.04, but this issue was not present.  Most (but not all) XCF thumbnails show up as the generic balloon image, but even those that have a thumbnail will not load in preview.

Reproducible: Always

Steps to Reproduce:
1. Try to open any XCF file created in GIMP
2.
3.
Actual Results:  
Album view says, "Failed to load image"
Console says:
digikam(17729)/digikam (core) Digikam::ThumbnailCreator::createThumbnail: Cannot create thumbnail for  "/home/guardd0gg/Photos/2009-08-06/processed/_dsc4833.xcf" 
digikam(17729)/digikam (core) Digikam::ThumbnailCreator::load: Thumbnail is null for  "/home/guardd0gg/Photos/2009-08-06/processed/_dsc4833.xcf" 


Expected Results:  
Album displays preview of XCF file

The only useful thing digiKam 2.5 appears to be able to do with XCF files is send them to the GIMP for editing, any other operation results in failure to load.

System is x86_64 Xubuntu 12.04
Comment 1 caulier.gilles 2012-11-03 09:49:06 UTC
For XCF files, digiKam use KDELibs kimgio components as Qt Image loader plugin...

Gilles Caulier
Comment 2 Jekyll Wu 2012-11-03 09:52:06 UTC

*** This bug has been marked as a duplicate of bug 308143 ***
Comment 3 caulier.gilles 2020-05-09 12:35:29 UTC
Git commit d9a57550ee4d08f1ab612723b315348af9bab9da by Gilles Caulier.
Committed on 09/05/2020 at 12:31.
Pushed by cgilles into branch 'master'.

Switch all digiKam bundles to last 5.70 which now support new Gimp XCF file format.
See KF5 release announcement : https://kde.org/announcements/kde-frameworks-5.70.0.php
"KImageFormats: Add support for modern Gimp images/XCF files"
This will permit to digiKam and Showfoto to show XCF thumbnail and load preview/full image (read only)
Related: bug 186641, bug 224697, bug 250003, bug 339152, bug 368444, bug 412339

M  +3    -3    project/bundles/3rdparty/ext_kf5_frameworks/CMakeLists.txt

https://invent.kde.org/kde/digikam/commit/d9a57550ee4d08f1ab612723b315348af9bab9da