Bug 309336 - Unmuting does not restore volume to where it was
Summary: Unmuting does not restore volume to where it was
Status: RESOLVED DUPLICATE of bug 309334
Alias: None
Product: kmix
Classification: Unclassified
Component: Backend: Pulseaudio (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Colin Guthrie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-31 18:28 UTC by Thiago Macieira
Modified: 2012-11-12 21:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Macieira 2012-10-31 18:28:59 UTC
When I mute the volume by using the UI (clicking the Mute button), the volume is brought down to zero. Clicking again to unmute does not restore to where it was.

Reproducible: Always

Steps to Reproduce:
1. Ensure that volume is non-zero and not muted
2. Click KMix in the systray and, optionally, show the mixer
3. Click the Mute button for a mixer
4. Click the button again to Umute
Actual Results:  
The volume remains on zero, even after unmuting.

Expected Results:  
Volume is restored to where it was before the muting action.

pulseaudio-1.1-9, on Fedora 17.

It might not be related to Pulseaudio. I have not tested direct ALSA support.
Comment 1 Colin Guthrie 2012-11-01 10:00:13 UTC
I couldn't reproduce here with PA 2.1 and kmix 4.9.2.

I do see the slider dropping to 0 (which I must say is a little odd to me) but it seems to restore itself to the correct position happily.

Can I ask if the underlying alsa volumes are zeroed when muting (i.e. when the visual slider first drops to 0) or only when unmuting again? On my system, the actual alsa volumes (and thus also the PA volumes) still stay at their correct values - it's only the slider that says it's at 0, when it's not really. You can run "alsamixer -c0" in a terminal to see the underlying values easily.
Comment 2 Thiago Macieira 2012-11-01 14:46:52 UTC
Yes, the ALSA volumes drop to zero too, in alsamixer.
Comment 3 Christian Esken 2012-11-12 21:19:46 UTC

*** This bug has been marked as a duplicate of bug 309334 ***