Bug 309330 - show the time/date when the crash happened
Summary: show the time/date when the crash happened
Status: RESOLVED FIXED
Alias: None
Product: drkonqi
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.2
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-31 17:37 UTC by Jaime Torres
Modified: 2013-01-03 13:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Torres 2012-10-31 17:37:28 UTC
show the time/date when the crash happened in the detailed crash information in the general tab (or in the developer tab).
Sometimes the crash happens when the computer is alone, and you do not know when it happened.
I've got a crash from solid, but I can not check in dmesg or /var/log/messages if something happened because I do not know when it happened.

Reproducible: Always
Comment 1 Christoph Feck 2012-10-31 22:28:46 UTC
When you click the backtrace "Save" button, it generates a filename with a timestamp. Can you check, if the time is that of the crash, or that of the button event?
Comment 2 Jaime Torres 2012-11-05 11:07:17 UTC
The filename generated includes the time of the button event.
Comment 3 Jekyll Wu 2012-12-26 18:22:29 UTC
https://git.reviewboard.kde.org/r/107775/
Comment 4 Jekyll Wu 2013-01-03 13:44:50 UTC
Git commit 24d218e7645e2f003a96725fdaf2d98682b11acf by Jekyll Wu.
Committed on 03/01/2013 at 14:38.
Pushed by jekyllwu into branch 'master'.

Remember and show the time information of the crashed application
REVIEW:  107775
FIXED-IN: 4.11.0

M  +5    -0    drkonqi/crashedapplication.cpp
M  +4    -0    drkonqi/crashedapplication.h
M  +1    -1    drkonqi/drkonqi.cpp
M  +1    -0    drkonqi/drkonqibackends.cpp
M  +9    -5    drkonqi/drkonqidialog.cpp

http://commits.kde.org/kde-runtime/24d218e7645e2f003a96725fdaf2d98682b11acf