Bug 309318 - Can't save contacts with custom IM protocol
Summary: Can't save contacts with custom IM protocol
Status: RESOLVED FIXED
Alias: None
Product: libkgapi
Classification: Unclassified
Component: contacts (show other bugs)
Version: 0.4.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-31 14:43 UTC by karaluh
Modified: 2012-12-05 14:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 0.4.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karaluh 2012-10-31 14:43:45 UTC
As in summary, the contact has only name and some notes so there is no reason for it not to be copied.

Reproducible: Always
Comment 1 Daniel Vrátil 2012-10-31 14:59:29 UTC
I assume this is a duplicate of bug 309314 - contacts with "&" in notes are not copied to server.

*** This bug has been marked as a duplicate of bug 309314 ***
Comment 2 karaluh 2012-11-05 07:27:51 UTC
(In reply to comment #1)
> I assume this is a duplicate of bug 309314 - contacts with "&" in notes are
> not copied to server.

This contact doesn't have "unsafe" characters anywhere.
Comment 3 Daniel Vrátil 2012-11-07 14:54:41 UTC
Is this reproducible with another contacts as well? Could you provide some more information about the contact in question?
Comment 4 karaluh 2012-11-07 15:06:27 UTC
(In reply to comment #3)
> Is this reproducible with another contacts as well?

No, only with this one.

> Could you provide some
> more information about the contact in question?

Below is exported vcard:
BEGIN:VCARD
CLASS:PUBLIC
FN:Klaudiusz Korzeniewicz
N:Korzeniewicz;Klaudiusz;;;
NOTE:kkorzeniewicz@server.com\nklaudiusz@server.pl\n000000000
ORG:www
UID:yl1YtIRZWI
VERSION:3.0
X-GADUGADU:666666
END:VCARD

The problem might be the X-GADUGADU field which is instant messaging network contact name that was supported in pre akonadi kaddresbook. In current version it isn't even visible.
Comment 5 Daniel Vrátil 2012-12-05 14:17:53 UTC
Git commit fc8a7991257a3cac091388d9eb4566cadd7b11d4 by Dan Vrátil.
Committed on 05/12/2012 at 15:14.
Pushed by dvratil into branch 'LibKGAPI/0.4'.

Support custom IM protocols

For IM protocols that Google does not officially support (i.e.
they don't have scheme URL for them), we should not create our
own scheme, but just send the name of the protocol in 'protocol'
attribute of the gd:im element.
FIXED-IN: 0.4.4

M  +14   -4    libkgapi/objects/contact.cpp
M  +11   -0    libkgapi/services/contacts.cpp

http://commits.kde.org/akonadi-google/fc8a7991257a3cac091388d9eb4566cadd7b11d4