Bug 309270 - Homerun segfaults on load every time -- began with package upgrade 10/30/2012 -- still segfaulting
Summary: Homerun segfaults on load every time -- began with package upgrade 10/30/2012...
Status: RESOLVED FIXED
Alias: None
Product: homerun
Classification: Unclassified
Component: applet (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR critical
Target Milestone: 0.1.0
Assignee: Aurelien Gateau
URL:
Keywords:
: 309714 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-30 20:36 UTC by jstalnak
Modified: 2012-11-12 17:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jstalnak 2012-10-30 20:36:35 UTC
Application: homerunviewer (0.1.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Logout and back in after upgrade via package manager. Homerun upgrade indicated by package manager so selected and installed: homerun (0.1.0~git20121024+r391-23~precise1) to 0.1.0~git20121029+r419-23~precise1. Now, on logout/login Homerun immediately segfaults and does not load. Clicking on KDE crash manager "Restart Application" button results in immediate crash and triggers a new bug report dialog. I have deleted existing homerunrc files in ./kde/blah without positive results. Homerun is effectively dead. I installed homerun debug files and the output below is what I get on loggin in.

Her e is the package manager commit log for the upgrades of which homerun was a part:

<quote>
Commit Log for Tue Oct 30 13:38:44 2012

Upgraded the following packages:
apparmor (2.7.102-0ubuntu3.2) to 2.7.102-0ubuntu3.4
clementine (1.1.0~precise) to 1.1.0~precise
dh-apparmor (2.7.102-0ubuntu3.2) to 2.7.102-0ubuntu3.4
firefox (16.0.1+build1-0ubuntu0.12.04.1) to 16.0.2+build1-0ubuntu0.12.04.1
firefox-globalmenu (16.0.1+build1-0ubuntu0.12.04.1) to 16.0.2+build1-0ubuntu0.12.04.1
firefox-locale-en (16.0.1+build1-0ubuntu0.12.04.1) to 16.0.2+build1-0ubuntu0.12.04.1
homerun (0.1.0~git20121024+r391-23~precise1) to 0.1.0~git20121029+r419-23~precise1
icedtea-6-jre-cacao (6b24-1.11.4-1ubuntu0.12.04.1) to 6b24-1.11.5-0ubuntu1~12.04.1
icedtea-6-jre-jamvm (6b24-1.11.4-1ubuntu0.12.04.1) to 6b24-1.11.5-0ubuntu1~12.04.1
icedtea-7-jre-jamvm (7u7-2.3.2a-0ubuntu0.12.04.1) to 7u9-2.3.3-0ubuntu1~12.04.1
libhomerun0 (0.1.0~git20121024+r391-23~precise1) to 0.1.0~git20121029+r419-23~precise1
openjdk-6-jre (6b24-1.11.4-1ubuntu0.12.04.1) to 6b24-1.11.5-0ubuntu1~12.04.1
openjdk-6-jre-headless (6b24-1.11.4-1ubuntu0.12.04.1) to 6b24-1.11.5-0ubuntu1~12.04.1
openjdk-6-jre-lib (6b24-1.11.4-1ubuntu0.12.04.1) to 6b24-1.11.5-0ubuntu1~12.04.1
openjdk-7-jre (7u7-2.3.2a-0ubuntu0.12.04.1) to 7u9-2.3.3-0ubuntu1~12.04.1
openjdk-7-jre-headless (7u7-2.3.2a-0ubuntu0.12.04.1) to 7u9-2.3.3-0ubuntu1~12.04.1
openjdk-7-jre-lib (7u7-2.3.2a-0ubuntu0.12.04.1) to 7u9-2.3.3-0ubuntu1~12.04.1
thunderbird (16.0.1+build1-0ubuntu0.12.04.1) to 16.0.2+build1-0ubuntu0.12.04.1
thunderbird-globalmenu (16.0.1+build1-0ubuntu0.12.04.1) to 16.0.2+build1-0ubuntu0.12.04.1
</quote>

The crash can be reproduced every time.

-- Backtrace:
Application: Homerun (homerunviewer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f37956e47c0 (LWP 5846))]

Thread 3 (Thread 0x7f3779daa700 (LWP 5847)):
#0  0x00007f378ba58d84 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f378e7fd222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f378e7fd259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f378749ab74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f378ba54e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f3792329cbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3778991700 (LWP 5848)):
#0  0x00007f379231e303 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f378b588036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f378b588164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3792a9f426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f3792a6ec82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f3792a6eed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f379296dfa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f3792a4e9ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f3792970fcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f378749ab74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f378ba54e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f3792329cbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f37956e47c0 (LWP 5846)):
[KCrash Handler]
#6  0x00007f3792a89eab in QObject::setProperty(char const*, QVariant const&) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x0000000000406442 in FullView::setupBackground (this=0x7fffbb1a2400) at /build/buildd/homerun-0.1.0~git20121029+r419/shell/fullview.cpp:102
#8  0x0000000000406778 in FullView::FullView (this=0x7fffbb1a2400) at /build/buildd/homerun-0.1.0~git20121029+r419/shell/fullview.cpp:87
#9  0x00000000004057bd in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/homerun-0.1.0~git20121029+r419/shell/main.cpp:68
Comment 1 jstalnak 2012-11-01 16:23:38 UTC
New upgrade this morning (I was out of town yesterday) and still Homerun segfaults. Here is the KDE crash report:

<quote>
Application: homerunviewer (0.1.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was simply adding Homerun to my KDE panel. It immediately crashes and continues to crash if I select "Reload" on the crash notice dialog.

The crash can be reproduced every time.

-- Backtrace:
Application: Homerun (homerunviewer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4cc96487c0 (LWP 14640))]

Thread 3 (Thread 0x7f4cadd0e700 (LWP 14641)):
#0  0x00007f4cbf9bcd84 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f4cc2761222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f4cc2761259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f4cbb3feb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f4cbf9b8e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f4cc628dcbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4cac8f5700 (LWP 14642)):
#0  0x00007f4cc62808bd in read () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f4cbb3fd0bc in ?? () from /usr/lib/nvidia-current/libGL.so.1
#2  0x00007f4cb8e80b27 in ?? () from /usr/lib/nvidia-current/tls/libnvidia-tls.so.295.40
#3  0x00007f4cbf5268cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4cbf4ebba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4cbf4ebfd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f4cbf4ec164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f4cc6a03426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f4cc69d2c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f4cc69d2ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f4cc68d1fa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f4cc69b29ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#12 0x00007f4cc68d4fcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007f4cbb3feb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#14 0x00007f4cbf9b8e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#15 0x00007f4cc628dcbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#16 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4cc96487c0 (LWP 14640)):
[KCrash Handler]
#6  0x00007f4cc69edeab in QObject::setProperty(char const*, QVariant const&) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x0000000000406442 in FullView::setupBackground (this=0x7fffdc717ee0) at /build/buildd/homerun-0.1.0~git20121031+r429/shell/fullview.cpp:102
#8  0x0000000000406778 in FullView::FullView (this=0x7fffdc717ee0) at /build/buildd/homerun-0.1.0~git20121031+r429/shell/fullview.cpp:87
#9  0x00000000004057bd in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/homerun-0.1.0~git20121031+r429/shell/main.cpp:68

Report to https://bugs.kde.org
</quote>
Comment 2 jstalnak 2012-11-05 16:05:38 UTC
Application: homerunviewer (0.1.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-32-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

After update I attempted to add Homerun to panel. Immediately segfaulted. This is the second update since I first reported the segfault following an update.

-- Backtrace:
Application: Homerun (homerunviewer), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe5ea2a97c0 (LWP 2596))]

Thread 3 (Thread 0x7fe5ce96f700 (LWP 2597)):
#0  0x00007fe5e061dd84 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007fe5e33c2222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fe5e33c2259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fe5dc05fb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007fe5e0619e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007fe5e6eeecbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe5cd541700 (LWP 2598)):
#0  0x00007fe5e061d05d in pthread_mutex_unlock () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007fe5e01885d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe5e014cf4e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe5e014d164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe5e7664426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fe5e7633c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fe5e7633ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fe5e7532fa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fe5e76139ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fe5e7535fcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fe5dc05fb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#11 0x00007fe5e0619e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007fe5e6eeecbd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe5ea2a97c0 (LWP 2596)):
[KCrash Handler]
#6  0x00007fe5e764eeab in QObject::setProperty(char const*, QVariant const&) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x0000000000406442 in FullView::setupBackground (this=0x7fffa4bf8910) at /build/buildd/homerun-0.1.0~git20121103+r436/shell/fullview.cpp:102
#8  0x0000000000406778 in FullView::FullView (this=0x7fffa4bf8910) at /build/buildd/homerun-0.1.0~git20121103+r436/shell/fullview.cpp:87
#9  0x00000000004057bd in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/homerun-0.1.0~git20121103+r436/shell/main.cpp:68

Report to https://bugs.kde.org
Comment 3 Aurelien Gateau 2012-11-09 22:52:42 UTC
*** Bug 309714 has been marked as a duplicate of this bug. ***
Comment 4 Aurelien Gateau 2012-11-09 22:54:20 UTC
Hi, can you check if you have an up-to-date libhomerun0 package? I think there 
is a missing dependency which could cause the homerun package to be updated 
without libhomerun0 updated as well.
Comment 5 Aurelien Gateau 2012-11-09 23:47:10 UTC
Investigating a bit more I realize this is not a package issue. The code 
changed to use a component which is not available in KDE 4.8. I am about to 
commit a fix for this.
Comment 6 Aurelien Gateau 2012-11-09 23:47:29 UTC
Git commit 7fe08f675d224aaa2bf13e14674240fb1f65e280 by Aurélien Gâteau.
Committed on 10/11/2012 at 00:44.
Pushed by gateau into branch 'master'.

Ship a copy of ScrollArea

ScrollArea does not exist in kde-runtime 4.8, so we have to ship our own
copy of it.

M  +4    -0    fixes/README.md
A  +248  -0    fixes/qml/ScrollArea.qml     [License: LGPL (v2+)]
M  +1    -0    fixes/qml/qmldir
M  +2    -3    package/contents/ui/Page.qml

http://commits.kde.org/homerun/7fe08f675d224aaa2bf13e14674240fb1f65e280
Comment 7 jstalnak 2012-11-10 00:04:21 UTC
Thanks for your persistence! I very much like Homerun and want to encourage its continued development. The segfaults happen on my work/office desktop. I've held off updating at home pending resolution. When the package manager 'sees' the upgrade I'll install and let you know what happens.

Best regards!
Comment 8 jstalnak 2012-11-12 17:49:33 UTC
Confirmed -- updated this morning and all is working at both home and work. Thanks again!