Bug 309119 - Wrong "New directory" dialog behavior: can't clear all typed text
Summary: Wrong "New directory" dialog behavior: can't clear all typed text
Status: RESOLVED FIXED
Alias: None
Product: krusader
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4.0-beta2 "Giant Steps"
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords: reproducible
: 310481 313363 317369 317686 318189 326101 335687 345343 345702 359435 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-28 05:25 UTC by WiseLord
Modified: 2018-05-06 00:15 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WiseLord 2012-10-28 05:25:41 UTC
It's impossible to clear textbox in "New directory" dialog.

Reproducible: Always

Steps to Reproduce:
1. Press F7 button to create new directory
2. Type any text
3. Try to clear typed text with any method.
Actual Results:  
It's impossible to clear whole textbox, at least one symbol is undeletable

Expected Results:  
Empty checkbox

Bug comes with "validator" object (from FilePathValidator class) in Panel/panelfunc.cpp.
There is no need in these object and class at all, everything works fine without them.

Maybe validation of text input is not a bad idea, but usually exactly first letter of new directory needs correction (for example, when changing it lowercase/uppercase status, or when wrong keyboard layout (Russian/English) was selected when executing dialog). So it's impossible to clear mistyped text with Backspace button due this bug.
Comment 1 Jekyll Wu 2012-11-27 12:50:42 UTC
*** Bug 310481 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Potashev 2012-12-31 18:56:27 UTC
I confirm this with Krusader 2.4.0-beta3 on KDE SC 4.9.4.
Comment 3 Jan Lepper 2013-01-02 20:40:46 UTC
Git commit 5cb23ac98046a07d5db3a52b41e3a42544eb13f9 by Jan Lepper.
Committed on 02/01/2013 at 21:38.
Pushed by janlepper into branch 'master'.

FIXED: [ 309119 ] Wrong "New directory" dialog behavior: can't clear all typed text
return QValidator::Intermediate instead of Invalid when input is empty

M  +1    -0    ChangeLog
M  +1    -1    krusader/Panel/panelfunc.cpp

http://commits.kde.org/krusader/5cb23ac98046a07d5db3a52b41e3a42544eb13f9
Comment 4 Jekyll Wu 2013-01-16 16:16:14 UTC
*** Bug 313363 has been marked as a duplicate of this bug. ***
Comment 5 Bruce Ouyang 2013-02-18 04:11:32 UTC
os : openSUSE12.2
KDE: KDE 4.10
krusader: 2.4.0 beta3
this bug is still not fixed.
Comment 6 Jekyll Wu 2013-02-18 09:55:11 UTC
(In reply to comment #5)
> os : openSUSE12.2
> KDE: KDE 4.10
> krusader: 2.4.0 beta3
> this bug is still not fixed.

Read comment #3.  Nobody says it is fixed in beta3. You need to wait for next release or build from git master .
Comment 7 Jekyll Wu 2013-03-26 09:48:37 UTC
*** Bug 317369 has been marked as a duplicate of this bug. ***
Comment 8 Jekyll Wu 2013-04-01 15:48:10 UTC
*** Bug 317686 has been marked as a duplicate of this bug. ***
Comment 9 Jekyll Wu 2013-04-11 13:26:22 UTC
*** Bug 318189 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2013-10-17 02:21:03 UTC
*** Bug 326101 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2014-06-02 10:20:40 UTC
*** Bug 335687 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2015-03-19 21:53:22 UTC
*** Bug 345343 has been marked as a duplicate of this bug. ***
Comment 13 Davide Gianforte 2015-08-18 18:00:35 UTC
*** Bug 345702 has been marked as a duplicate of this bug. ***
Comment 14 Marko 2016-01-13 09:27:58 UTC
says it's fixed in 2.4.0 beta2, but bug is reproducible in krusader 2.4.0 beta3.
Comment 15 Till Schäfer 2016-01-13 11:33:02 UTC
(In reply to Marko from comment #14)
> says it's fixed in 2.4.0 beta2, but bug is reproducible in krusader 2.4.0
> beta3.

nope, it was reported for beta2, but was fixed after beta3 ...

if you are running source distribution (such as gentoo) your can also just apply this patch here: 

--- krusader/Panel/panelfunc.cpp
+++ krusader/Panel/panelfunc.cpp
@@ -100,7 +100,7 @@
 {
 public:
     virtual State validate(QString &input, int &pos) const {
-        return input.isEmpty() ? Invalid : Acceptable;
+            return input.isEmpty() ? Intermediate : Acceptable;
     }
 };
Comment 16 Davide Gianforte 2016-02-20 09:02:29 UTC
*** Bug 359435 has been marked as a duplicate of this bug. ***