Bug 308956 - failed to load image preview on all but tiny images
Summary: failed to load image preview on all but tiny images
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: 2.9.0
Platform: Microsoft Windows Microsoft Windows
: NOR major with 1 vote (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-24 20:03 UTC by James McGregor
Modified: 2016-07-07 21:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments
Screenshot of Digikam warning if trying to overwrite a library file using a picture on the camera (89.55 KB, image/png)
2014-05-31 00:39 UTC, Philippe Cloutier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James McGregor 2012-10-24 20:03:42 UTC
New installation on Windows 7 of digikam 2.9. when scrolling throuh thumbnails and clicking on thumbnail images main preview screen shows a message "failed to load image"  exceptions are small images 2 megapixel or less which display correctly. 

Reproducible: Always

Steps to Reproduce:
1. in thumbnal view 
2. click (once) on an image over 2mpx

Actual Results:  
preview window will display error message

Expected Results:  
preview window will display a preview of the image selected
Comment 1 Ananta Palani 2013-01-23 22:54:02 UTC
Sorry you are having trouble. Just a few questions:

Could you attach a few images that are causing problems? (If you don't want to upload here you could e-mail them to me)?
Is the thumbnail viewer showing a thumbnail for the images?
How large is your collection (approximately how many images)?
Comment 2 Christoph Feck 2013-01-29 23:36:20 UTC
If you can provide the information requested in comment #1, please add it.
Comment 3 James McGregor 2013-01-30 01:59:10 UTC
This was reported some months ago and there was no response .
I could not work it out so I deleted the application.

James McGregor




On 30 January 2013 10:36, Christoph Feck <christoph@maxiom.de> wrote:

> https://bugs.kde.org/show_bug.cgi?id=308956
>
> --- Comment #2 from Christoph Feck <christoph@maxiom.de> ---
> If you can provide the information requested in comment #1, please add it.
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 4 Marcel Wiesweg 2013-01-30 18:14:46 UTC
apparently no feedback to be accepted
Comment 5 Philippe Cloutier 2014-05-31 00:39:17 UTC
Created attachment 86923 [details]
Screenshot of Digikam warning if trying to overwrite a library file using a picture on the camera
Comment 6 Philippe Cloutier 2014-05-31 00:41:23 UTC
I'm experiencing an issue which might be related to this one with Digikam 4.0.0 on Debian testing. The symptom is basically the same, but this seems unrelated to image size. It also happens with 640x480 pictures (44 kiB). 

The same problem affects Digikam 2.6.0 on Debian 7 (although it's less visible there since the large versions don't show unless explicitly requested) on a different PC. On 2.6, the issue can be seen using "View". The camera is a Canon Powershot SX200 IS.

Thumbnails works fine, it's just Preview Item which displays the issue. Downloading works fine. The camera contains 25 pictures.

Attachment #86923 [details] may provide a hint on what is wrong.
Comment 7 caulier.gilles 2015-06-26 13:43:31 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles Caulier
Comment 8 caulier.gilles 2015-07-06 07:40:20 UTC
digiKam 4.11.0 Windows installer is available for download :

http://download.kde.org/stable/digikam/digiKam-installer-4.11.0-win32.exe.mirrorlist
Comment 9 caulier.gilles 2015-08-21 07:03:46 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 10 caulier.gilles 2016-05-31 12:10:25 UTC
With next digiKam 5.0.0, we will provide a fully cross-compiled version Windows
under Linux where a lots of problems have been fixed.

https://www.flickr.com/photos/digikam/27033685570/in/dateposted-public/

The Windows installer is available here to test :

https://drive.google.com/open?id=0B7yq-xFihT0_SzhxVzF1RDhPbFE

Gilles Caulier