Bug 308917 - Plasma segmentation fault on startup
Summary: Plasma segmentation fault on startup
Status: RESOLVED DUPLICATE of bug 281035
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-24 08:21 UTC by Giorgio Loi
Modified: 2012-11-04 10:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giorgio Loi 2012-10-24 08:21:16 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-18-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
The error happens always on startup.

The crash can be reproduced every time.

-- Backtrace:
Application: Shell del desktop di Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fead581b7c0 (LWP 3622))]

Thread 7 (Thread 0x7feab6f44700 (LWP 3623)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fead0278b2d in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fead0278c39 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#4  0x00007feac94a3e9a in start_thread (arg=0x7feab6f44700) at pthread_create.c:308
#5  0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7feab6643700 (LWP 3624)):
#0  0x00007feac8de19d6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007feac8de1c29 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007feac8da479a in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007feac8da4d22 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007feac8da4ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fead1db3c16 in QEventDispatcherGlib::processEvents (this=0x7feab00008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fead1d842bf in QEventLoop::processEvents (this=this@entry=0x7feab6642d00, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fead1d84548 in QEventLoop::exec (this=0x7feab6642d00, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fead1c85b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fead1c88aec in QThreadPrivate::start (arg=0x1fd5b80) at thread/qthread_unix.cpp:338
#10 0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#11 0x00007feac94a3e9a in start_thread (arg=0x7feab6643700) at pthread_create.c:308
#12 0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7feab4a73700 (LWP 3625)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007feacee0acd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007feacee0ad09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#4  0x00007feac94a3e9a in start_thread (arg=0x7feab4a73700) at pthread_create.c:308
#5  0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fea6702a700 (LWP 3626)):
#0  0x00007feac94a5e8c in __pthread_mutex_lock (mutex=0x7fea60000a90) at pthread_mutex_lock.c:50
#1  0x00007feac8de1c31 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007feac8da46eb in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007feac8da4cf9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007feac8da4ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fead1db3c16 in QEventDispatcherGlib::processEvents (this=0x7fea600008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fead1d842bf in QEventLoop::processEvents (this=this@entry=0x7fea67029cd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fead1d84548 in QEventLoop::exec (this=0x7fea67029cd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fead1c85b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fead1d649af in QInotifyFileSystemWatcherEngine::run (this=0x2a2c7c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fead1c88aec in QThreadPrivate::start (arg=0x2a2c7c0) at thread/qthread_unix.cpp:338
#11 0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#12 0x00007feac94a3e9a in start_thread (arg=0x7fea6702a700) at pthread_create.c:308
#13 0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fea64b26700 (LWP 3627)):
#0  0x00007fead5107023 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fead1d63fe2 in QProcessManager::run (this=0x7fead20dd520 <processManager()::processManager>) at io/qprocess_unix.cpp:245
#2  0x00007fead1c88aec in QThreadPrivate::start (arg=0x7fead20dd520 <processManager()::processManager>) at thread/qthread_unix.cpp:338
#3  0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#4  0x00007feac94a3e9a in start_thread (arg=0x7fea64b26700) at pthread_create.c:308
#5  0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fea5ffff700 (LWP 3629)):
#0  0x00007feac94a5fc0 in __pthread_mutex_lock (mutex=0x7fea54000a90) at pthread_mutex_lock.c:113
#1  0x00007feac8de1c31 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007feac8da46eb in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007feac8da4cf9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007feac8da4ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fead1db3c16 in QEventDispatcherGlib::processEvents (this=0x7fea540008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fead1d842bf in QEventLoop::processEvents (this=this@entry=0x7fea5fffecd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fead1d84548 in QEventLoop::exec (this=0x7fea5fffecd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fead1c85b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fead1d649af in QInotifyFileSystemWatcherEngine::run (this=0x3060870) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fead1c88aec in QThreadPrivate::start (arg=0x3060870) at thread/qthread_unix.cpp:338
#11 0x00007feac66dc754 in ?? () from /usr/lib/nvidia-experimental-304/libGL.so.1
#12 0x00007feac94a3e9a in start_thread (arg=0x7fea5ffff700) at pthread_create.c:308
#13 0x00007fead510dcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fead581b7c0 (LWP 3622)):
[KCrash Handler]
#6  QHash<unsigned long, TaskManager::Task*>::findNode (this=this@entry=0x4f7dd80, akey=@0x7fead20d0ff8: <error reading variable>, ahp=ahp@entry=0x0) at /usr/include/qt4/QtCore/qhash.h:882
#7  0x00007fea507d4212 in value (akey=@0x7fead20d0ff8: <error reading variable>, this=0x4f7dd80) at /usr/include/qt4/QtCore/qhash.h:609
#8  TaskManager::TaskManager::isOnTop (this=0x4f96500, task=0x50fb360) at ../../../libs/taskmanager/taskmanager.cpp:482
#9  0x00007fea509f96e3 in TaskSource::updateTask (this=this@entry=0x50f5430, taskChanges=...) at ../../../../../plasma/generic/dataengines/tasks/tasksource.cpp:97
#10 0x00007fea509fa5db in TaskSource::TaskSource (this=0x50f5430, task=0x50fb360, parent=<optimized out>) at ../../../../../plasma/generic/dataengines/tasks/tasksource.cpp:44
#11 0x00007fea509f7c1b in TasksEngine::taskAdded (this=0x4f94770, task=0x50fb360) at ../../../../../plasma/generic/dataengines/tasks/tasksengine.cpp:109
#12 0x00007fead1d9af5f in QMetaObject::activate (sender=0x4f96500, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc117f860) at kernel/qobject.cpp:3547
#13 0x00007fea507d3d1f in TaskManager::TaskManager::taskAdded (this=this@entry=0x4f96500, _t1=_t1@entry=0x50fb360) at ./taskmanager.moc:187
#14 0x00007fea507d5074 in TaskManager::TaskManager::windowAdded (this=0x4f96500, w=14680082) at ../../../libs/taskmanager/taskmanager.cpp:297
#15 0x00007fea507d55ec in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./taskmanager.moc:103
#16 TaskManager::TaskManager::qt_static_metacall (_o=0x4f7dd80, _c=3524071416, _id=0, _a=0x569ad80) at ./taskmanager.moc:90
#17 0x00007fead1d9af5f in QMetaObject::activate (sender=0x1e85cb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc117fad0) at kernel/qobject.cpp:3547
#18 0x00007fead2b647d2 in KWindowSystem::windowAdded (this=this@entry=0x1e85cb0, _t1=14680082) at ./kwindowsystem.moc:143
#19 0x00007fead2b65549 in KWindowSystemPrivate::addClient (this=0x1debed0, w=14680082) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:269
#20 0x00007fead2b73c13 in NETRootInfo::update (this=this@entry=0x1debef8, dirty_props=dirty_props@entry=0x7fffc117fcb0) at ../../kdeui/windowmanagement/netwm.cpp:2227
#21 0x00007fead2b7476b in NETRootInfo::event (this=0x1debef8, event=0x7fffc117fe10, properties=0x7fffc117fd30, properties_size=5) at ../../kdeui/windowmanagement/netwm.cpp:2099
#22 0x00007fead2b66e5b in KWindowSystemPrivate::x11Event (this=0x1debed0, ev=0x7fffc117fe10) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:172
#23 0x00007fead2a65f7d in publicX11Event (e=0x7fffc117fe10, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#24 KSystemEventFilterPrivate::filterEvent (this=0x1bb4e90, message=0x7fffc117fe10) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#25 0x00007fead1d77fae in QAbstractEventDispatcher::filterEvent (this=0x4f7dd80, message=0x7fead20d0ff8) at kernel/qabstracteventdispatcher.cpp:539
#26 0x00007fead11d1f18 in x11EventSourceDispatch (s=0x1bb1e00, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#27 0x00007feac8da4ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007feac8da4de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007feac8da4ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fead1db3bf6 in QEventDispatcherGlib::processEvents (this=0x1a91ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007fead11d1c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fead1d842bf in QEventLoop::processEvents (this=this@entry=0x7fffc11801e0, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fead1d84548 in QEventLoop::exec (this=0x7fffc11801e0, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fead1d89708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0x00007fead5414035 in kdemain (argc=1, argv=0x7fffc11804d8) at ../../../../plasma/desktop/shell/main.cpp:120
#36 0x00007fead503b76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fffc11804d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffc11804c8) at libc-start.c:226
#37 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 281035.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-11-04 10:01:39 UTC

*** This bug has been marked as a duplicate of bug 281035 ***