Bug 308854 - KMail2 is not able to connect to an imap server which uses IMAPS (port 993) with TLSv1
Summary: KMail2 is not able to connect to an imap server which uses IMAPS (port 993) w...
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: GIT (master)
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2012-10-23 09:27 UTC by Marcel Bosling
Modified: 2018-10-27 03:56 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Bosling 2012-10-23 09:27:33 UTC
The mailserver I am using (mailbox.rwth-aachen.de) uses IMAPS on port 993 with TLSv1 for encryption. KMail2 is unable to connect to that mailbox as it may not correctly set the SSL/TLS version (just my guess).

Reproducible: Always

Steps to Reproduce:
1. Create account with IMPAS for mailbox.rwth-aachen.de on port 993 with SSL/TLS.
Actual Results:  
The server is offline.


Expected Results:  
The mailbox should work out-of-the-box.

Checking with "openssl s_client -connect mailbox.rwth-aachen.de -tls1" results in being able to connect via openssl. So the connection could be established if KMail2 would use (would be forced to use) TLSv1.
Comment 1 Marcel Bosling 2012-10-23 09:29:24 UTC
For openssl use:
"openssl s_client -connect mailbox.rwth-aachen.de:993 -tls1"
Comment 2 S. Burmeister 2012-11-02 10:30:21 UTC
See bug 306964. Currently it is only possible to work around this by using a different openSSL version or not using security.
Comment 3 S. Burmeister 2012-11-02 16:55:39 UTC
You can report to your IT-department that their server is buggy. See https://bugzilla.novell.com/show_bug.cgi?id=782309#c3

"The bug with IMAP happens because the server is to old and does not understand
the TLS1.2 ClientHello (actually a server bug)"

They have to update their server report the bug to SUN respectively.
Comment 4 Kevin Ottens 2013-11-16 07:26:03 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 5 Stefan Brüns 2013-11-24 19:31:32 UTC
This bug was fixed in 4.9.4, but will likely reappear in 4.11.4
Comment 6 Christian Mollekopf 2013-12-02 11:18:57 UTC
Please reopen if this is indeed the case.
Comment 7 Andrew Crouthamel 2018-09-25 03:43:42 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Andrew Crouthamel 2018-10-27 03:56:27 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!