Bug 308800 - 'Next page' should switch two pages when viewing two pages on screen
Summary: 'Next page' should switch two pages when viewing two pages on screen
Status: RESOLVED INTENTIONAL
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.15.2
Platform: OpenSUSE Linux
: NOR minor with 10 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks: extramile
  Show dependency treegraph
 
Reported: 2012-10-22 10:10 UTC by jens
Modified: 2014-05-08 15:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jens 2012-10-22 10:10:46 UTC
I usually use the following settings in okular:
Fit page, Facing pages.

When pressing the keyboard button 'page down' I can smoothly browse through the document. However when using the next page button in the menu or on the next button on the page bar I have to click 2 times since it goes to the next page which I already see on my screen. In my opinion the next page button should behave exactly like keyboard 'page down' when using 'Fit page'. The same applies to previous/page-up.

Regards,
Jens

PS: I guess this one qualifies as issue for the extra mile initiative.

Reproducible: Always

Steps to Reproduce:
1. Open a document with multiple pages
2. Select Fit page and Facing pages as View Mode
3. Click on 'Next page' with you mouse
Actual Results:  
The current page switches from 1 to 2.

Expected Results:  
The current page should switch from 1 to 3 since I see two pages at the same time on my screen. Pressing page-down on the keyboard does exactly this.

Note that my description in 'Expected results' should be a little bit different when using 'Facing pages (Center first page)' or 'Overview' View Mode. 

Facing pages (Center first page): Switch 1 page when viewing the first page, otherwise 2.
Overview: Switch 3 pages.
Comment 1 Albert Astals Cid 2012-10-22 10:29:42 UTC
You say next page going to the next page is wrong. I don't think this is a bug, you can already "scroll by a reading viewport" using the page down key, as a matter of fact i'm sure this is a dupe of a bug we already closed back then, i just don't have time to look for it, i'd appreciate if you do go there, read the discussion we had and if you have anything new to add to it write it on that bug.

If not somebody (or eventually me when i get more time) will find that bug and mark yours as duplicate.

Thanks for caring about Okular :-)
Comment 2 jens 2012-10-22 11:24:39 UTC
Thanks a lot for your fast comment. Sorry for opening a new issue, I found only these two closed entries with a rather short discussion. Are you referring to these?
https://bugs.kde.org/show_bug.cgi?id=258966
https://bugs.kde.org/show_bug.cgi?id=234177

I completely agree that the button 'next page' does indeed exactly does what it promises, but you have to admit that it is a kind of strange behavior when having 2 or 3 pages at the same time on the screen :). As a user I want to read a document and when having finished reading what is on my screen I want to press a button (1 time) to read more. The exact page positions is imho not very interesting for the average user, especially since okular is a reading tool and not one for editing. Is there even a use case when one want to switch to the next page, but not want to switch the viewport. Neverless I see the dilemma because a viewport is not a page :)

What about renaming 'Next Page' to 'Next Page(s)' just Next" and let it behave like page-down?
Or add a second pair of buttons for previous/next viewport?
Comment 3 Albert Astals Cid 2012-10-22 20:07:39 UTC
My rationale:
 * Changing the behaviour of the current actions is a no go since there are valid use cases for them just switching one page.
 * Adding new buttons is an overkill given the feature is already accessible from other places.
Comment 4 jens 2012-10-22 20:20:55 UTC
Could you describe a valid use case for switching from page 3 to 4 when both pages are already fully visible on the screen/viewport?
Comment 5 Albert Astals Cid 2012-10-22 20:29:17 UTC
Using the text to speech feature, searching from the current page
Comment 6 jens 2012-10-22 20:55:15 UTC
Agree, text to speech is indeed a valid one. I still think that the current behavior is at least not very consistent between what you can do with the keyboard vs the mouse.
Following your rationale I would then suggest to let page-down behave like the next-page button (thus switching exactly one page) and let arrow down do the viewport change (as it does now). 
Since there is currently no way to do the arrow-down action with the mouse (or pen in my case) I would suggest a set of buttons for prev/next viewport available in 'configure toolbars'. Then I/a user could just hide the navigation bar and put the two new buttons on my toolbaar.

What do you think? :)
PS: I really appreciate the time and thoughts you spend on my corner case, thanks a lot!
Comment 7 Albert Astals Cid 2012-11-01 16:33:41 UTC
I am still failing to see your point, are you using a device without keyboard? Or is it just that you prefer using the mouse?
Comment 8 jens 2012-11-02 13:21:29 UTC
I'm using a Wacom pen and a keyboard. The way I use my input devices depends heavily on the task I'm doing. When doing reading stuff (Internet, reading mails, document etc) I use only my pen. When doing programming related stuff I put my pen away and tend to do everything with my keyboard. So there are moments when I use okular only with a pen and moments when I use it only with my keyboard. May be that's why I feel this little inconsistency more easily than users using either mouse/pen or keyboard.
Comment 9 Dennis Nienhüser 2013-09-11 20:17:20 UTC
okular 0.16.5 (using KDE 4.10.5) jumps to the vertical center of every second page here in the fit page / facing pages setting.

Besides that I agree with Jens that the behavior of next page in facing pages mode feels immature if it advances just one page.
Comment 10 Dennis Nienhüser 2013-09-11 20:19:02 UTC
(In reply to comment #9)
> okular 0.16.5 (using KDE 4.10.5) jumps to the vertical center of every
> second page here in the fit page / facing pages setting.

More precise: This happens in facing pages (center first) only.
Comment 11 Albert Astals Cid 2013-09-21 15:32:10 UTC
Dennis, you're saying that pressing the next page button on facing pages does switch two pages at a time? I don't see that happening here.
Comment 12 Albert Astals Cid 2014-05-08 15:42:16 UTC
Ok, guys, i'm sorry we can't reach an agreement, but we've talked here and we agree that next page is fine doing what it does not, which is go to the next page. I understand you agree but ultimately we can't please everyone.

Thanks for caring about Okular :)