Bug 308767 - power management settings not correctly restored
Summary: power management settings not correctly restored
Status: RESOLVED DUPLICATE of bug 295164
Alias: None
Product: solid
Classification: Unclassified
Component: powermanagement (show other bugs)
Version: 4.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 19:32 UTC by illumilore
Modified: 2013-02-07 14:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description illumilore 2012-10-21 19:32:58 UTC
After playing a video with dragon, the settings on my monitor have always gotten reset. Even though I have the monitor set to never sleep, it will always turn off after a couple of minutes after playing a video.
Comment 1 Harald Sitter 2012-10-22 12:53:03 UTC
Which version of the KDE SC? And which distribution?

Also FWIW, to me that sounds like a bug in the power management components.... what happens is that dragon inhibits screensaver and screen deactivation when playing a video, it then releases the inhibition upon stopping the video. naturally it would appear possible that solid (the power management library) does not store the previous state correct so stopping the inhibition in fact becomes activating the mentioned feature rather than restoring whatever state it was in before the inhibition.
Comment 2 Harald Sitter 2012-10-22 12:53:22 UTC
Oh, also how do you turn off screen power management?
Comment 3 illumilore 2012-10-23 00:30:00 UTC
kde 4.9.2, on kubuntu 12.10, x64.

I go into system settings, power management, then check the screen energy saving box (it stays unchecked even though screen still turns off), hit apply, uncheck, hit apply.
Comment 4 Harald Sitter 2012-10-25 10:25:54 UTC
Sounds like a powerdevil issue then.
Comment 5 Oliver Henshaw 2013-02-07 14:48:04 UTC

*** This bug has been marked as a duplicate of bug 295164 ***