Bug 308557 - blur left on screen
Summary: blur left on screen
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.2
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 14:53 UTC by Leon Maurer
Modified: 2013-01-17 15:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Shows the blur on the upper left part of the screen -- above a window (obscuring it) and below the cursor. (270.32 KB, image/png)
2012-10-17 14:54 UTC, Leon Maurer
Details
Output from qdbus org.kde.kwin /KWin supportInformation (4.94 KB, text/plain)
2012-10-22 14:15 UTC, Leon Maurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Maurer 2012-10-17 14:53:32 UTC
There's something that leaves a blur on the screen. See the attached image, where the cursor is. The blur goes over any windows, but underneath the cursor. The blur goes away with a 'kwin --replace'.

I'm not sure exactly what causes the blur. It only seems to happen after the screen saver/screen sleep has been active for a while (e.g. if I leave the computer on overnight). However, that's about the location where notifications appear, so maybe it's due to one of them that pops up while the screensaver/screen sleep is active.

Reproducible: Sometimes

Steps to Reproduce:
1. Leave computer for some time.
2. Come back to find blur.
Comment 1 Leon Maurer 2012-10-17 14:54:34 UTC
Created attachment 74602 [details]
Shows the blur on the upper left part of the screen -- above a window (obscuring it) and below the cursor.
Comment 2 Martin Flöser 2012-10-17 15:14:01 UTC
please provide output of 
qdbus org.kde.kwin /KWin supportInformation
when the problem is visible
Comment 3 Thomas Lübking 2012-10-17 15:46:31 UTC
and afterwards check whether it's also reproducible when disabling caching in the blur settings (looks like what i inintially ran into reg. bug #307112 but could not reproduce afterwards)
Comment 4 Leon Maurer 2012-10-17 15:56:37 UTC
Thomas, could you provide more specific instructions? If I go to configure 'Blur' in the Desktop Effects system setting, I don't see anything about disabling caching, and I didn't see directions in skimming that bug report.
Comment 5 Thomas Lübking 2012-10-17 16:17:59 UTC
"Safe intermediate rendering results" - it's the only checkbox in the config dialog, below the slider.
Comment 6 Leon Maurer 2012-10-22 14:15:32 UTC
Created attachment 74726 [details]
Output from qdbus org.kde.kwin /KWin supportInformation
Comment 7 Leon Maurer 2012-10-22 14:17:21 UTC
Ok, I've run in to the blur again, so I've attached the requested output. I've now disabled the blur caching, and I'll see if I run in to this again.
Comment 8 Thomas Lübking 2012-10-22 19:25:45 UTC
> kwin4_effect_fade
> kwin4_effect_blur

Actually sounds related to bug #306186 now (unless the fade was in action for sth. entirely different, like a popup)

But also actually, the blur should take the opacity ("0") into account then.
Comment 9 Leon Maurer 2012-10-23 14:28:06 UTC
The bug still happens with blur caching disabled.

FWIW, I've also run in to that issue with the password dialog box; it was common for some time, but I haven't seen it in a little while now.
Comment 10 Martin Flöser 2013-01-07 17:09:49 UTC
given that Bug #306186 has been fixed for 4.10: please provide an update whether it solved the issue once you tested out 4.10.
Comment 11 Leon Maurer 2013-01-07 17:40:01 UTC
Will do. I may try out one of the release candidates before the final release.
Comment 12 Martin Flöser 2013-01-17 15:37:44 UTC
Let's do it different: I assume it's fixed. In case you are still able to reproduce once you have had the chance to give 4.10 a try, please reopen. I think that's easier as you cannot properly say that it is fixed given that there is no concrete way to reproduce it.