Bug 308507 - digikam crashes when browsing images
Summary: digikam crashes when browsing images
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Bqm-Rotate (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 313389 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-16 18:46 UTC by bertram.lueckehe
Modified: 2021-08-26 16:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bertram.lueckehe 2012-10-16 18:46:05 UTC
Application: digikam (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-30-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

browsing images using the cursor keys, preview is open, properties tab is open. Works fine for some time and then crashes

The crash can be reproduced some of the time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7dd710ca00 (LWP 2462))]

Thread 5 (Thread 0x7f7db2966700 (LWP 2463)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7dd136d4db in wait (time=18446744073709551615, this=0x1603f30) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1603e28, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005ca1d0 in Digikam::ScanController::run (this=0x1603bc0) at /build/buildd/digikam-2.5.0/core/digikam/database/scancontroller.cpp:647
#4  0x00007f7dd136cfcb in QThreadPrivate::start (arg=0x1603bc0) at thread/qthread_unix.cpp:298
#5  0x00007f7dcbeaee9a in start_thread (arg=0x7f7db2966700) at pthread_create.c:308
#6  0x00007f7dd0598dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f7db2165700 (LWP 2464)):
#0  0x00007f7dd058d403 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7dc9afc036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7dc9afc164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7dd149b426 in QEventDispatcherGlib::processEvents (this=0x7f7da40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f7dd146ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7dd146aed7 in QEventLoop::exec (this=0x7f7db2164b50, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7dd1369fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f7dd144a9ff in QInotifyFileSystemWatcherEngine::run (this=0x153b450) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7dd136cfcb in QThreadPrivate::start (arg=0x153b450) at thread/qthread_unix.cpp:298
#9  0x00007f7dcbeaee9a in start_thread (arg=0x7f7db2165700) at pthread_create.c:308
#10 0x00007f7dd0598dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f7db1964700 (LWP 2468)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7dd136d4db in wait (time=18446744073709551615, this=0x194cbc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x194c928, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7dd4772ff1 in Digikam::ParkingThread::run (this=0x194c910) at /build/buildd/digikam-2.5.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f7dd136cfcb in QThreadPrivate::start (arg=0x194c910) at thread/qthread_unix.cpp:298
#5  0x00007f7dcbeaee9a in start_thread (arg=0x7f7db1964700) at pthread_create.c:308
#6  0x00007f7dd0598dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7db0a0c700 (LWP 2469)):
#0  0x00007f7dd058d403 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7dc9afc036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7dc9afc164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7dd149b426 in QEventDispatcherGlib::processEvents (this=0x7f7d9c000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f7dd146ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7dd146aed7 in QEventLoop::exec (this=0x7f7db0a0bb50, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7dd1369fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f7dd144a9ff in QInotifyFileSystemWatcherEngine::run (this=0x1aa88e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7dd136cfcb in QThreadPrivate::start (arg=0x1aa88e0) at thread/qthread_unix.cpp:298
#9  0x00007f7dcbeaee9a in start_thread (arg=0x7f7db0a0c700) at pthread_create.c:308
#10 0x00007f7dd0598dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7dd710ca00 (LWP 2462)):
[KCrash Handler]
#6  0x00007f7dd04db445 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f7dd04debab in __GI_abort () at abort.c:91
#8  0x00007f7dd051949e in __libc_message (do_abort=2, fmt=0x7f7dd0623108 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
#9  0x00007f7dd0523c96 in malloc_printerr (action=3, str=0x7f7dd0623240 "free(): invalid next size (normal)", ptr=<optimized out>) at malloc.c:5007
#10 0x00007f7dd4570fd1 in ~DImgPrivate (this=0x7f7d5d090930, __in_chrg=<optimized out>) at /build/buildd/digikam-2.5.0/core/libs/dimg/dimg_p.h:87
#11 ~DSharedDataPointer (this=<optimized out>, __in_chrg=<optimized out>) at /build/buildd/digikam-2.5.0/core/libs/dimg/dshareddata.h:177
#12 ~DSharedDataPointer (this=<optimized out>, __in_chrg=<optimized out>) at /build/buildd/digikam-2.5.0/core/libs/dimg/dimg.cpp:173
#13 Digikam::DImg::~DImg (this=<optimized out>, __in_chrg=<optimized out>) at /build/buildd/digikam-2.5.0/core/libs/dimg/dimg.cpp:173
#14 0x00007f7dd473d6fa in unlink (n=..., this=<optimized out>) at /usr/include/qt4/QtCore/qcache.h:75
#15 remove (key=..., this=<optimized out>) at /usr/include/qt4/QtCore/qcache.h:161
#16 Digikam::LoadingCache::notifyFileChanged (this=0x1636880, filePath=...) at /build/buildd/digikam-2.5.0/core/libs/threadimageio/loadingcache.cpp:338
#17 0x00007f7dd4740fdf in Digikam::LoadingCacheInterface::fileChanged (filePath=...) at /build/buildd/digikam-2.5.0/core/libs/threadimageio/loadingcacheinterface.cpp:47
#18 0x0000000000520e67 in Digikam::KipiInterface::refreshImages (this=<optimized out>, urls=...) at /build/buildd/digikam-2.5.0/core/utilities/kipiiface/kipiinterface.cpp:186
#19 0x00007f7d91a76b10 in Plugin_JPEGLossless::slotCancel (this=0x322e6f0) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/jpeglossless/plugin/plugin_jpeglossless.cpp:328
#20 0x00007f7d91a772bd in oneTaskCompleted (this=0x322e6f0) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/jpeglossless/plugin/plugin_jpeglossless.cpp:454
#21 Plugin_JPEGLossless::oneTaskCompleted (this=0x322e6f0) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/jpeglossless/plugin/plugin_jpeglossless.cpp:436
#22 0x00007f7d91a778dd in Plugin_JPEGLossless::slotFinished (this=0x322e6f0, filePath=..., action=<optimized out>) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/jpeglossless/plugin/plugin_jpeglossless.cpp:394
#23 0x00007f7dd1485446 in QObject::event (this=0x322e6f0, e=<optimized out>) at kernel/qobject.cpp:1195
#24 0x00007f7dd1e65894 in notify_helper (e=0x7f7d8c0015c0, receiver=0x322e6f0, this=0x1481c90) at kernel/qapplication.cpp:4559
#25 QApplicationPrivate::notify_helper (this=0x1481c90, receiver=0x322e6f0, e=0x7f7d8c0015c0) at kernel/qapplication.cpp:4531
#26 0x00007f7dd1e6a713 in QApplication::notify (this=0x7fff5bd74400, receiver=0x322e6f0, e=0x7f7d8c0015c0) at kernel/qapplication.cpp:4420
#27 0x00007f7dd2b9f3f6 in KApplication::notify (this=0x7fff5bd74400, receiver=0x322e6f0, event=0x7f7d8c0015c0) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f7dd146be9c in QCoreApplication::notifyInternal (this=0x7fff5bd74400, receiver=0x322e6f0, event=0x7f7d8c0015c0) at kernel/qcoreapplication.cpp:876
#29 0x00007f7dd146fc6a in sendEvent (event=0x7f7d8c0015c0, receiver=0x322e6f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x141e4d0) at kernel/qcoreapplication.cpp:1500
#31 0x00007f7dd149af93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#33 0x00007f7dc9afbd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f7dc9afc0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f7dc9afc164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f7dd149b3bf in QEventDispatcherGlib::processEvents (this=0x141fdb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0x00007f7dd1f0dd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f7dd146ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f7dd146aed7 in QEventLoop::exec (this=0x7fff5bd74280, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f7dd146ff67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#41 0x000000000048bc5d in main (argc=1, argv=<optimized out>) at /build/buildd/digikam-2.5.0/core/digikam/main/main.cpp:232

Possible duplicates by query: bug 308019, bug 307561, bug 306284, bug 306240, bug 305122.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-10-16 20:32:35 UTC

*** This bug has been marked as a duplicate of bug 276592 ***
Comment 2 caulier.gilles 2013-01-21 07:37:39 UTC
*** Bug 313389 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2021-08-26 16:50:32 UTC
Fixed with #276592