Bug 30825 - IMAP folders cannot be the target of filter action "move"
Summary: IMAP folders cannot be the target of filter action "move"
Status: RESOLVED DUPLICATE of bug 50997
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: SVN (3.5 branch)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-08-17 06:18 UTC by tanis
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tanis 2001-08-17 06:09:09 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           KDE 2.2.0 
Severity:          wishlist
Installed from:    SuSE RPMs
Compiler:          doesn't matter using .rpms
OS:                Linux
OS/Compiler notes: Not Specified

I want to establish a filter on my incoming IMAP folder which distributes mails into other IMAP folders. 
Unfortunately I can only select local folders as targets of filter actions.


(Submitted via bugs.kde.org)
Comment 1 Ferdinand Gassauer 2003-09-03 20:43:03 UTC
CVS HEAD of today - In the target list only local folders are selectable.  
IMHO also IMAP folders must  be selectable to allow kmail as fully functional IMAP 
client. 
 
 
Comment 2 Ferdinand Gassauer 2003-09-03 20:45:25 UTC
 not "fixed" in current CVS
Comment 3 Ferdinand Gassauer 2003-09-03 20:47:29 UTC
Does not work in KDE 3.1.x neither
Comment 4 Thorsten Schnebeck 2003-09-03 23:33:11 UTC
Main thread about this issue is bug #50997 - with 829 votes (today) 
Even though this bug report is older maybe it's better to close this report and vote for 50997. 
 
The main problem is still the same: IMAP filter belongs to the server. If you use a client side 
imap filter you can build circular rules with two or more clients working with the same folders at 
the same time. This could result in huge traffic for the mail server. 
 
But there is no real standard for server side filtering: While "procmail" is popular, "sieve" is the 
way go go - especially when using cyrus server  - like kolab. 
 
Bye 
 
  Thorsten  
Comment 5 Stephan Kulow 2003-09-23 11:20:20 UTC

*** This bug has been marked as a duplicate of 50997 ***