Bug 308084 - Amarok doesn't play CDs but skips tracks when one tries to play
Summary: Amarok doesn't play CDs but skips tracks when one tries to play
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playback (show other bugs)
Version: 2.6-git
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords: regression, release_blocker
Depends on: 311446 313011
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 17:26 UTC by valentin.petzel
Modified: 2013-01-10 22:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description valentin.petzel 2012-10-08 17:26:46 UTC
The CD collection says, that the CD has got, for example, eight tracks, but when I click on the CD-Tab, the arrow changes, but no tracks are listed.
When trying to play the CD, nothing happens.

Reproducible: Always




Fehlerdiagnose für Amarok

Amarok-Version: 2.6.0
KDE-Version: 4.8.4 (4.8.4)
Qt-Version: 4.8.2
Phonon-Version: 4.6.0
Phonon-Backend: VLC (0.6.0)
PulseAudio: Nein

Amarok-Skripte:
    Amarok Script Console 1.0 (angehalten)
Lyricwiki .2 (läuft)
Free Music Charts 1.6.0 (läuft)
Librivox.org 1.0 (läuft)
Cool Streams 1.0 (läuft)

Amarok-Module:
    Audio-CD-Sammlung (aktiviert)
DAAP-Sammlung (deaktiviert)
MTP-Sammlung (aktiviert)
MySQLServer-Sammlung (aktiviert)
MySQLe-Sammlung (aktiviert)
Sammlung auf iPod, iPad und iPhone (aktiviert)
UPnP-Sammlung (deaktiviert)
Universelle Massenspeicher-Sammlung (aktiviert)
Ampache (deaktiviert)
Jamendo (aktiviert)
Last.fm (aktiviert)
MP3-Musikladen (aktiviert)
MP3tunes (deaktiviert)
Magnatune-Online-Shop (aktiviert)
Podcast-Verzeichnis (aktiviert)
Backend für NFS-Freigaben (aktiviert)
Backend für SMB-(Windows-)Freigaben (aktiviert)
Backend für lokale Dateien und USB-Massenspeicher (aktiviert)
Comment 1 Myriam Schweingruber 2012-11-29 11:13:38 UTC
Console output when trying to play a track, phonon-backend-vlc 0.6.0:

amarok: BEGIN: void EngineController::slotStateChanged(Phonon::State, Phonon::State) 
amarok:   [WARNING] [EngineController] Phonon failed to play this URL. Error:  "" 
amarok:   [WARNING] [EngineController] Forcing phonon engine reinitialization. 
amarok:   BEGIN: void EngineController::initializePhonon() 
[0x7f022c2de848] main stream error: cannot pre fill buffer
"PulseSupport(2): Clearing stream cache for stream {3929c82c-fad3-4034-af47-86b4c0228c75}" 
"PulseSupport(2): Initialising streamindex {1b818c5b-91a2-4a5e-89ad-83902e60d1aa}" 
"PulseSupport(2): Setting role to music for streamindex {1b818c5b-91a2-4a5e-89ad-83902e60d1aa}" 
emitting a state change because the backend object has been replaced 
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioDataOutput ( no objectName ). 
void Phonon::FrontendInterfacePrivate::_backendObjectChanged() 
Object::connect: No such signal Phonon::VLC::MediaObject::angleChanged(int) in ../../phonon/mediacontroller.cpp:64
Object::connect: No such signal Phonon::VLC::MediaObject::availableAnglesChanged(int) in ../../phonon/mediacontroller.cpp:65
amarok:     [EngineController] Tick Interval (actual):  100 
amarok:   END__: void EngineController::initializePhonon() [Took: 0.26s] 
amarok:   BEGIN: void EngineController::slotAboutToFinish() 
amarok:     BEGIN: void Playlist::Actions::requestNextTrack() 
amarok:     END__: void Playlist::Actions::requestNextTrack() [Took: 0s] 
amarok:   END__: void EngineController::slotAboutToFinish() [Took: 0s] 
amarok: END__: void EngineController::slotStateChanged(Phonon::State, Phonon::State) [Took: 0.26s] 
amarok(14208)/kio (KIOJob) KIO::TransferJob::slotFinished: KUrl("http://lyrics.wikia.com/api.php?action=query&prop=revisions&rvprop=content&format=xml&titles=Scriabin:Six_Studies_Op42_No7_In_F_Minor")
amarok(14208)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::TransferJob(0x60421c0) KIO::Slave(0x3ad4090)
amarok: BEGIN: static QScriptValue Downloader::init(QScriptContext*, QScriptEngine*, bool) 
amarok(14208)/kio (Scheduler) KIO::SchedulerPrivate::doJob: KIO::SimpleJob(0x3ab7ce0)
amarok: END__: static QScriptValue Downloader::init(QScriptContext*, QScriptEngine*, bool) [Took: 0s] 
amarok(14208)/kio (KIOJob) KIO::TransferJob::slotFinished: KUrl("http://lyrics.wikia.com/api.php?action=lyrics&func=getSong&fmt=xml&artist=Scriabin&song=Six_Studies_Op42_No7_In_F_Minor")
amarok(14208)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::TransferJob(0x3ab7ce0) KIO::Slave(0x3ad4090)
Comment 2 Matěj Laitl 2013-01-05 14:21:43 UTC
I think incorrect Amarok behaviour described by Harald in bug 311446 causes this.
Comment 3 Matěj Laitl 2013-01-10 22:49:31 UTC
http://commits.kde.org/amarok/09Resolved in commit http://commits.kde.org/amarok/090070dfe700 - why the hell commit hook didn't work here?