Bug 308024 - space for panel reserved on wrong output
Summary: space for panel reserved on wrong output
Status: RESOLVED DUPLICATE of bug 94470
Alias: None
Product: plasma4
Classification: Plasma
Component: containment-panel (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-07 13:53 UTC by Jozef Šiška
Modified: 2012-10-07 15:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
xwininfo and xrandr output (3.76 KB, text/plain)
2012-10-07 14:18 UTC, Jozef Šiška
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jozef Šiška 2012-10-07 13:53:11 UTC
In a two output setup, if the panel is on the edge common to both outputs (ie right side of the left output), the space for it is reserved on the other output (ie at the side of the the framebuffer, not the output with the panel). This can be easily seen with a  maximized window on each output.

Reproducible: Always

Steps to Reproduce:
1. Setup a panel on the right side of the primary output, set it to "always visible"
2. Add a second output to the right side of the the primary output (so that the panel is at the common edge)
3. Maximize a window on each output
Actual Results:  
The maximized window on the left output extends below the panel, the one on the right output leaves free space on the right  as if for the panel.
The problem can be seen in screenshots at http://people.ksp.sk/~yoyo/screenshots/2012/panel-multiple-outputs/

Expected Results:  
The window on the left output should not extend below the panel, the one on the right output should cover the whole output.

The behavior is a bit weird even if I try to to move the panel afterwards: if I move it to the left (of the left) output, the maximized window makes place for it, but on the second output the window still leaves the space on the right. Even if I move the panel to the right output to any screen edge, the area of the maximized window doesn't change.
Comment 1 Martin Flöser 2012-10-07 13:57:55 UTC
Reassigning to Plasma, as strut is set on Plasma panel and I doubt it's wrong inside KWin (being a multi screen user myself).

@Josef: please ensure that the panel does not overlap to the other screen, not even by one pixel.
Comment 2 Jozef Šiška 2012-10-07 14:18:01 UTC
Created attachment 74388 [details]
xwininfo and xrandr output

I put the panel to the right edge of the screen while still having only one output, so unless plasma positions it weirdly, it shouldn't overlay (is it possible to put a plasma panel so it extends through two outputs ?)

Anyway attaching xwininfo output for the panel and xrandr output, there are two cases in the attachment, first is with only one output, second after the second output was enabled. As far as I can tell the panel is only on the first screen (I checked also on the monitor, at 1024x768 I can see pixels easily on this monitor ;)
Comment 3 Thomas Lübking 2012-10-07 14:28:08 UTC
(In reply to comment #3)
> In a two output setup, if the panel is on the edge common to both outputs

This is bug #94470, see bug #167852 for a patch hacking around NETWM limitations.

In general, this is WONTFIX for KWin as long as we stick to NETWM and plasma panels should simply not strut on shared edges under those circumstances.

*** This bug has been marked as a duplicate of bug 94470 ***
Comment 4 Jozef Šiška 2012-10-07 14:59:50 UTC
I experimented a bit more and it seems that the window on the left output covering the whole output (event below the panel) and the window on the right output not covering the whole output are separate issuses:

Aside from the plasma panel I was running also gkrellm set to "Set window to be a dock or panel"  on the same screen edge as the plasma panel (it can be seen in this screenshot: http://people.ksp.sk/~yoyo/screenshots/2012/panel-multiple-outputs/panel-single-output.png) and that was causing the free space on the right output...

However the problem of the window on the left output maximizing under the panel was there even when I tried with a default kde setup under a new user: 
-  If the panel is at the "outer" edge of an output (left edge of the left output or the right edge of the right output) it is ok - a maximized  window doesn't extend under it, but if the panel 
-  If the panel is at the inner / common edge (right  edge of the left output...), a maximized  window extends below it.
Comment 5 Thomas Lübking 2012-10-07 15:14:16 UTC
then there's no issue on the plasma side and what's left is the dupe of a defect in the netwm spec :-(